Is it possible to use my Sony DCR-TRV250 as a USB webcam?

Questions about hardware,drivers and peripherals
Forum rules
Before you post please read how to get help
Post Reply
User avatar
otacon14112
Level 3
Level 3
Posts: 105
Joined: Sun Apr 21, 2013 11:43 pm

Is it possible to use my Sony DCR-TRV250 as a USB webcam?

Post by otacon14112 » Wed Oct 09, 2019 11:20 pm

I did in Windows XP, but I can't get any video app to see it. I tried VLC, and under "Open capture device", it had video camera selected at the top, and when I clicked on Play, I just got a black screen. I think it was trying to play video through one of my Oculus Rift sensors. The DCR-TRV250 has a mini USB jack on it. I have it plugged into a USB 2.0 port with a USB 1 mini to USB A cable. I enabled the camcorder to stream video in its menu. It also has a IEEE 1394 FireWire jack on it, which was how I've always imported video from Digital 8 tapes to my computers. I may have used it as a webcam with FireWire in the past, but it was so long ago that I don't remember how I did it.

Interestingly, it shows up in lshw and lsusb as a Handycam DCR-30:

lshw

Code: Select all

        *-usb
             description: USB controller
             product: 100 Series/C230 Series Chipset Family USB 3.0 xHCI Controller
             vendor: Intel Corporation
             physical id: 14
             bus info: pci@0000:00:14.0
             version: 31
             width: 64 bits
             clock: 33MHz
             capabilities: pm msi xhci bus_master cap_list
             configuration: driver=xhci_hcd latency=0
             resources: irq:120 memory:df330000-df33ffff
           *-usbhost:0
                product: xHCI Host Controller
                vendor: Linux 4.15.0-62-generic xhci-hcd
                physical id: 0
                bus info: usb@1
                logical name: usb1
                version: 4.15
                capabilities: usb-2.00
                configuration: driver=hub slots=16 speed=480Mbit/s
              *-usb:0
                   description: Video
                   product: Rift Sensor
                   vendor: Oculus VR
                   physical id: 9
                   bus info: usb@1:9
                   version: 0.00
                   serial: WMTD306S5026G7
                   capabilities: usb-2.10
                   configuration: driver=uvcvideo maxpower=200mA speed=480Mbit/s
              *-usb:1
                   description: Mass storage device
                   product: ImageMate 14 in 1 Reader/Writer
                   vendor: SanDisk
                   physical id: a
                   bus info: usb@1:a
                   version: 93.39
                   serial: 200611110A
                   capabilities: usb-2.00 scsi
                   configuration: driver=usb-storage maxpower=500mA speed=480Mbit/s
              *-usb:2
                   description: Audio device
                   product: Handycam DCR-30
                   vendor: Sony Corp.
                   physical id: b
                   bus info: usb@1:b
                   version: 1.00
                   capabilities: usb-1.10 audio-control
                   configuration: driver=snd-usb-audio maxpower=2mA speed=12Mbit/s
lsusb

Code: Select all

Bus 004 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 003 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 002: ID 2833:0211  
Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 001 Device 003: ID 2833:0211  
Bus 001 Device 007: ID 2433:b200  
Bus 001 Device 031: ID 046d:c534 Logitech, Inc. Unifying Receiver
Bus 001 Device 038: ID 054c:00c0 Sony Corp. Handycam DCR-30
Bus 001 Device 004: ID 0781:b4b5 SanDisk Corp. SDDR-89 V4 ImageMate 12-in-1 Reader
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
I tried a kernel module:

Code: Select all

# modprobe g_webcam
but it didn't help.

So I searched for anything I could think of in Synaptic Package Manager like webcam, USB, Sony, video4linux, etc, and installed what seemed relevant. That didn't help, either.

My motherboard is an Asus Z170-Pro, and it has headers on the motherboard to install a FireWire connector to a slot in back of the computer where expansion slots are, but I haven't gotten around to ordering it. I wanted to try it with mini USB though, because I wanted to use it as a webcam on my Raspberry Pi 4. I figured since my gaming computer is way faster than the Pi, it would be faster and easier to try it on this first, get it working, and then simply replicate the steps and procedures on the Pi, which runs Raspbian, which is derived from Debian, which means it has apt-get.

I saw this topic viewtopic.php?f=48&t=129642&p=702779&hi ... am#p702779 and he has a different Sony Handycam than I do, and it's showing up as a DCR-30 on his computer also.

Here's my system info:

Code: Select all

$ uname -a
Linux gamingcomputer 4.15.0-62-generic #69~16.04.1-Ubuntu SMP Fri Sep 6 02:43:35 UTC 2019 x86_64 x86_64 x86_64 GNU/Linux
So is this even possible? I did numerous searches for "DRC-TRV250" "Linux" on google, but there were few relevant results, and ended up not finding anything useful for my situation. Can anyone think of other things I can try? Thanks in advance.
Otacon: You remember pre-ripped jeans? Manufacturers thought that just because people loved old, broken-in jeans, they would want to buy new jeans that looked old. So they purposefully...
Solid Snake: What do jeans have to do with nature and order?

Post Reply

Return to “Hardware Support”