nvidia geforce210 black screen

Questions about hardware,drivers and peripherals
Forum rules
Before you post please read how to get help
Post Reply
ranger077
Level 1
Level 1
Posts: 30
Joined: Tue Nov 25, 2014 5:15 am

nvidia geforce210 black screen

Post by ranger077 »

Hi all. I got an Nvidia GeForce210 card which works perfectly on windows 10. But on linux mint 19 installed on other hdd id doesnt show annything even if system boots just fine. And another thing...which may help you get a clue. Before upgrade, i used the internal realtek hd 2500 integrated card which was compatible with everything . But now , on this newer card, my bios splash doesn't even show up as it usual did and no os select grub menu... i cant enter bios , or linux installed hdd...nothing. Just black screen. Any idea? is it maybe an incompatibility between my motherboard and video card? (i have Asus motherboard.)

User avatar
kukamuumuka
Level 16
Level 16
Posts: 6657
Joined: Tue Sep 03, 2013 4:51 am
Location: Finland
Contact:

Re: nvidia geforce210 black screen

Post by kukamuumuka »

If bios splash doesn't even show, it is a mechanical issue.

ranger077
Level 1
Level 1
Posts: 30
Joined: Tue Nov 25, 2014 5:15 am

Re: nvidia geforce210 black screen

Post by ranger077 »

kukamuumuka wrote:
Thu Jan 16, 2020 2:06 pm
If bios splash doesn't even show, it is a mechanical issue.
What do you mean by that? The card maybe not compatible with motherboard slot or? i mean that the vga cable cannot be broken ,in the same position on the monitor and same slot on nvidia card windows shows up but anything else no. If i get the vga end in the integrated card slot, then everything goes well ..so i can hardly believe it is a bad metal contact terminals issue.
And yes, even if i can use my card on windows 10 without any problems, it goes straight into its welcome screen, skipping the entire Asus logo and bios splash.
i get like 15 seconds black screen then suddenly i am logged in fully operational...pretty weird.

User avatar
kukamuumuka
Level 16
Level 16
Posts: 6657
Joined: Tue Sep 03, 2013 4:51 am
Location: Finland
Contact:

Re: nvidia geforce210 black screen

Post by kukamuumuka »

I understand bios splash about the things what happens before bootloader is working. If you mean blank screen, read the next article:

Fixing the black screen after grub boot-up (screen/video settings mismatch) -> https://community.linuxmint.com/tutorial/view/842

ranger077
Level 1
Level 1
Posts: 30
Joined: Tue Nov 25, 2014 5:15 am

Re: nvidia geforce210 black screen

Post by ranger077 »

no, i mean black screen, not blank. I dont get any linuxmint logo or blinking cursor..just nothing happens. its like the monitor is off..after a while if i let it too much, it eventually says no input and suspends(the monitor).

User avatar
kukamuumuka
Level 16
Level 16
Posts: 6657
Joined: Tue Sep 03, 2013 4:51 am
Location: Finland
Contact:

Re: nvidia geforce210 black screen

Post by kukamuumuka »

ranger077 wrote:
Thu Jan 16, 2020 2:24 pm
no, i mean black screen, not blank. I dont get any linuxmint logo or blinking cursor..just nothing happens. its like the monitor is off..after a while if i let it too much, it eventually says no input and suspends(the monitor).
If Mint is installed, did you install Mint in the right mode (UEFI versus bios), and where did you install the bootloader?

ranger077
Level 1
Level 1
Posts: 30
Joined: Tue Nov 25, 2014 5:15 am

Re: nvidia geforce210 black screen

Post by ranger077 »

well i dont remember for sure...uefi probably cuz those newer and newer pc's cannot take linux in any other mode from what i experienced. I got some time ago both windows10 and linuxmint on same hdd on different partitions. And because windows was the 4 th option in that blind grub i couldn't see anything even if it worked i had to press down button 4 times every boot,and it was annoying ...and now i got Linux mint on its own separate hdd so i guess the loader is there also. After i installed it using integrated card i rebooted few times and it went well. so the installation is properly done , i assume.

ranger077
Level 1
Level 1
Posts: 30
Joined: Tue Nov 25, 2014 5:15 am

Re: nvidia geforce210 black screen

Post by ranger077 »

i keep thinking it may be hardware error or something broken. I admit i bought the card at second hand, is not new by any means and it may have issues...if that's the case, i must get a newer one. But i hope that is not the case, taking into account that it still displays very well on w10.

ranger077
Level 1
Level 1
Posts: 30
Joined: Tue Nov 25, 2014 5:15 am

Re: nvidia geforce210 black screen

Post by ranger077 »

any other ideas?

User avatar
kukamuumuka
Level 16
Level 16
Posts: 6657
Joined: Tue Sep 03, 2013 4:51 am
Location: Finland
Contact:

Re: nvidia geforce210 black screen

Post by kukamuumuka »

ranger077 wrote:
Fri Jan 17, 2020 1:58 pm
any other ideas?
How about if you boot from liveUSB and run the command inxi -Fxpoz and tell the result. Read also the next article: https://wiki.archlinux.org/index.php/Hybrid_graphics

ranger077
Level 1
Level 1
Posts: 30
Joined: Tue Nov 25, 2014 5:15 am

Re: nvidia geforce210 black screen

Post by ranger077 »

you mean, boot live usb and use the integrated graphic card instead. and the run the command,because on nvidia nothin will show up. Ok, i will give it a try but that article is mainly about laptops with dual-graphic cards, i got a desktop.

Post Reply

Return to “Hardware Support”