[Solved]Fn>F4 not working.

Questions about hardware,drivers and peripherals
Forum rules
Before you post please read how to get help
Post Reply
rjsrjs
Level 3
Level 3
Posts: 132
Joined: Sun Mar 17, 2019 6:47 pm
Location: Florida

[Solved]Fn>F4 not working.

Post by rjsrjs »

Hello everyone:
It seems that Function F4 to put my Lenovo T430 running Linux Mint 19.3 with compiz windows manager, in standby, suspend mode isn't working. I can put it in suspend mode via keyboard shortcut and GUI via mouse. Don't know if it's the laptop or Linux Mint causing the problem. I don't know where to start to troubleshoot this problem. Can anyone give me a place to start? Other Function buttons seem to be working OK on the T430. Here is inxi -FxzD info on my Lenovo T430
Thanks:
rjsrjs :)

Code: Select all

Device-1: Intel 7 Series/C216 Family High Definition Audio vendor: Lenovo 
  driver: snd_hda_intel v: kernel bus ID: 00:1b.0 
  Sound Server: ALSA v: k4.15.0-74-generic 
Network:
  Device-1: Intel 82579LM Gigabit Network vendor: Lenovo driver: e1000e 
  v: 3.2.6-k port: 5080 bus ID: 00:19.0 
  IF: enp0s25 state: down mac: <filter> 
  Device-2: Intel Centrino Advanced-N 6205 [Taylor Peak] driver: iwlwifi 
  v: kernel port: efa0 bus ID: 03:00.0 
  IF: wlp3s0 state: up mac: <filter> 
Drives:
  Local Storage: total: 167.68 GiB used: 56.41 GiB (33.6%) 
  ID-1: /dev/sda vendor: Intel model: SSDSC2BW180A3L size: 167.68 GiB 
Partition:
  ID-1: / size: 164.05 GiB used: 56.41 GiB (34.4%) fs: ext4 dev: /dev/sda1 
Sensors:
  System Temperatures: cpu: 44.0 C mobo: N/A 
  Fan Speeds (RPM): cpu: 3222 
Info:
  Processes: 213 Uptime: 1h 00m Memory: 7.52 GiB used: 1.08 GiB (14.3%) 
  Init: systemd runlevel: 5 Compilers: gcc: 7.4.0 Shell: bash v: 4.4.20 
  inxi: 3.0.32 
richhelen@richhelen-ThinkPad-T430:~$ clear

richhelen@richhelen-ThinkPad-T430:~$ !1568
inxi -FxzD
System:
  Host: richhelen-ThinkPad-T430 Kernel: 4.15.0-74-generic x86_64 bits: 64 
  compiler: gcc v: 7.4.0 Desktop: MATE 1.22.2 Distro: Linux Mint 19.3 Tricia 
  base: Ubuntu 18.04 bionic 
Machine:
  Type: Laptop System: LENOVO product: 2347C32 v: ThinkPad T430 
  serial: <filter> 
  Mobo: LENOVO model: 2347C32 serial: <filter> UEFI [Legacy]: LENOVO 
  v: G1ET45WW (1.20 ) date: 08/07/2012 
Battery:
  ID-1: BAT0 charge: 17.4 Wh condition: 18.1/47.5 Wh (38%) 
  model: SANYO 45N1001 status: Unknown 
CPU:
  Topology: Dual Core model: Intel Core i5-3320M bits: 64 type: MT MCP 
  arch: Ivy Bridge rev: 9 L2 cache: 3072 KiB 
  flags: lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 20752 
  Speed: 1197 MHz min/max: 1200/3300 MHz Core speeds (MHz): 1: 1197 2: 1197 
  3: 1197 4: 1197 
Graphics:
  Device-1: Intel 3rd Gen Core processor Graphics vendor: Lenovo 
  driver: i915 v: kernel bus ID: 00:02.0 
  Display: x11 server: X.Org 1.19.6 driver: modesetting unloaded: fbdev,vesa 
  resolution: 1366x768~60Hz 
  OpenGL: renderer: Mesa DRI Intel Ivybridge Mobile v: 4.2 Mesa 19.2.1 
  direct render: Yes 
Audio:
  Device-1: Intel 7 Series/C216 Family High Definition Audio vendor: Lenovo 
  driver: snd_hda_intel v: kernel bus ID: 00:1b.0 
  Sound Server: ALSA v: k4.15.0-74-generic 
Network:
  Device-1: Intel 82579LM Gigabit Network vendor: Lenovo driver: e1000e 
  v: 3.2.6-k port: 5080 bus ID: 00:19.0 
  IF: enp0s25 state: down mac: <filter> 
  Device-2: Intel Centrino Advanced-N 6205 [Taylor Peak] driver: iwlwifi 
  v: kernel port: efa0 bus ID: 03:00.0 
  IF: wlp3s0 state: up mac: <filter> 
Drives:
  Local Storage: total: 167.68 GiB used: 56.41 GiB (33.6%) 
  ID-1: /dev/sda vendor: Intel model: SSDSC2BW180A3L size: 167.68 GiB 
Partition:
  ID-1: / size: 164.05 GiB used: 56.41 GiB (34.4%) fs: ext4 dev: /dev/sda1 
Sensors:
  System Temperatures: cpu: 44.0 C mobo: N/A 
  Fan Speeds (RPM): cpu: 3219 
Info:
  Processes: 213 Uptime: 1h 00m Memory: 7.52 GiB used: 1.08 GiB (14.3%) 
  Init: systemd runlevel: 5 Compilers: gcc: 7.4.0 Shell: bash v: 4.4.20 
  inxi: 3.0.32 
Last edited by rjsrjs on Thu Jan 23, 2020 11:13 am, edited 1 time in total.

gittiest personITW
Level 6
Level 6
Posts: 1200
Joined: Tue May 28, 2019 4:27 pm

Re: Fn>F4 not working.

Post by gittiest personITW »

You Could see in System Settings / Keyboard to see if you can play around with a shortcut in there but just skimming through it I didn't find a Suspend shortcut option.

rjsrjs
Level 3
Level 3
Posts: 132
Joined: Sun Mar 17, 2019 6:47 pm
Location: Florida

Re: Fn>F4 not working.

Post by rjsrjs »

Here is Power management general tab I have set.
Suspend.png

gittiest personITW
Level 6
Level 6
Posts: 1200
Joined: Tue May 28, 2019 4:27 pm

Re: Fn>F4 not working.

Post by gittiest personITW »

Does that work for the power button and the suspend button?

gm10
Level 20
Level 20
Posts: 11000
Joined: Thu Jun 21, 2018 5:11 pm

Re: Fn>F4 not working.

Post by gm10 »

rjsrjs wrote:
Mon Jan 20, 2020 9:11 am
It seems that Function F4 to put my Lenovo T430 running Linux Mint 19.3 with compiz windows manager, in standby, suspend mode isn't working. I can put it in suspend mode via keyboard shortcut and GUI via mouse. Don't know if it's the laptop or Linux Mint causing the problem.
Does Fn+F4 work with other operating systems? Is Fn+F4 the intended sleep mode key (i.e. is there anything printed on it)? Try to bind Fn+F4 to a custom keyboard shortcut to see if the combination is recognized at all. If it is, just create one for systemctl suspend and bind it to that.
Tune up your LM 19+: ppa:gm10/linuxmint-tools

rjsrjs
Level 3
Level 3
Posts: 132
Joined: Sun Mar 17, 2019 6:47 pm
Location: Florida

Re: Fn>F4 not working.

Post by rjsrjs »

gm10: The f4 key has an icon of a quarter moon imprinted on it. It has worked before occasionally on and off but I never used it that way too much. So I made a keyboard shortcut "Crtl>Alt>S" and that works every time I press it. It's not a big thing, I'm just curious as to if it's the Laptop or operating system Linux Mint 19.3.
Thanks for all the replys
rjsrjs

rjsrjs
Level 3
Level 3
Posts: 132
Joined: Sun Mar 17, 2019 6:47 pm
Location: Florida

Re: Fn>F4 not working.

Post by rjsrjs »

To gittiest personITW:

I'm assuming it works just for the sleep, suspend button(F4). I have to press the power button to bring it out of suspend.
Thanks for the replys
rjsrjs
Last edited by rjsrjs on Fri Jan 24, 2020 9:49 am, edited 1 time in total.

gm10
Level 20
Level 20
Posts: 11000
Joined: Thu Jun 21, 2018 5:11 pm

Re: Fn>F4 not working.

Post by gm10 »

rjsrjs wrote:
Tue Jan 21, 2020 10:18 am
I'm just curious as to if it's the Laptop or operating system Linux Mint 19.3.
You skipped this part of my post:
gm10 wrote:
Tue Jan 21, 2020 10:09 am
Try to bind Fn+F4 to a custom keyboard shortcut to see if the combination is recognized at all. If it is, just create one for systemctl suspend and bind it to that.
If the combination isn't recognized, you may have to select a different keyboard model in the keyboard settings.
Tune up your LM 19+: ppa:gm10/linuxmint-tools

rjsrjs
Level 3
Level 3
Posts: 132
Joined: Sun Mar 17, 2019 6:47 pm
Location: Florida

Re: Fn>F4 not working.

Post by rjsrjs »

Here is my logind.conf file.

Code: Select all

[Login]
#NAutoVTs=6
#ReserveVT=6
#KillUserProcesses=no
#KillOnlyUsers=
#KillExcludeUsers=root
#InhibitDelayMaxSec=5
#HandlePowerKey=poweroff
HandleSuspendKey=suspend
#HandleHibernateKey=hibernate
HandleLidSwitch=suspend
HandleLidSwitchDocked=suspend
#PowerKeyIgnoreInhibited=no
#SuspendKeyIgnoreInhibited=no
#HibernateKeyIgnoreInhibited=no
#LidSwitchIgnoreInhibited=yes
#HoldoffTimeoutSec=30s
#IdleAction=ignore
#IdleActionSec=30min
#RuntimeDirectorySize=10%
#RemoveIPC=yes
#InhibitorsMax=8192
#SessionsMax=8192
#UserTasksMax=33%

rjsrjs
Level 3
Level 3
Posts: 132
Joined: Sun Mar 17, 2019 6:47 pm
Location: Florida

Re: Fn>F4 not working.

Post by rjsrjs »

I read the following on http://real-world-systems.com/docs/logind.1.html site. I am running compiz but don't know if it's turning off my logind.conf file.

A different application may disable logind's handling of system power and sleep keys and the lid switch by taking a low-level inhibitor lock (handle-power-key, handle-suspend-key, handle-hibernate-key, handle-lid-switch). This is most commonly used by graphical desktop environments to take over suspend and hibernation handling, and to use their own configuration mechanisms. If a low-level inhibitor lock is taken, logind will not take any action when that key or switch is triggered and the Handle*= settings are irrelevant.

For a little while today the F4 key would suspend if I pressed Fn key the pressed F4 for about 1 or 2 seconds and pressed it a second time quickly and it worked. But now it won't even do that.

I also changed keyboard type to Lenovo/IBM think pad keyboard and it still doesn't work.

rjsrjs
Level 3
Level 3
Posts: 132
Joined: Sun Mar 17, 2019 6:47 pm
Location: Florida

Re: Fn>F4 not working.

Post by rjsrjs »

Just tried booting a flash drive with Linux Mint 19.1 on my Lenovo T430 and the suspend key worked every time I pressed it. That tells me the the laptop keyboard should be fine. But can't figure out why Mint 19.3 on my Laptops SSD won't let the function key work. Any Ideas??

rjsrjs
Level 3
Level 3
Posts: 132
Joined: Sun Mar 17, 2019 6:47 pm
Location: Florida

Re: Fn>F4 not working.

Post by rjsrjs »

Well I went in and made "logind.conf" file on my Mint 19.3 OS and made it the same as on the bootable
flash live drives Mint 19.1 "logind.conf". There were hash tags (pound signs) all the way down the file in the live flash drive. And now the suspend (sleep) key in Mint 19.3 works but with a 6 second delay. On the Mint 19.1 (on the flash drive) Fn>F4 is immediate, like right now. The only thing I changed in Mint ,on my laptop, was adding compiz and deleted Mate screensaver and installed Xscreensaver. Don't know if that was the cause or not. I'm not worried about it, it's not a big thing I was just curious. Thanks for all the reply's.
rjsrjs

rjsrjs
Level 3
Level 3
Posts: 132
Joined: Sun Mar 17, 2019 6:47 pm
Location: Florida

Re: Fn>F4 not working.

Post by rjsrjs »

gm10 wrote:
Tue Jan 21, 2020 12:56 pm
rjsrjs wrote:
Tue Jan 21, 2020 10:18 am
I'm just curious as to if it's the Laptop or operating system Linux Mint 19.3.
You skipped this part of my post:
gm10 wrote:
Tue Jan 21, 2020 10:09 am
Try to bind Fn+F4 to a custom keyboard shortcut to see if the combination is recognized at all. If it is, just create one for systemctl suspend and bind it to that.
If the combination isn't recognized, you may have to select a different keyboard model in the keyboard settings.
To gm10:
Yes I also have a keyboard short cut "Crtl>Alt>S" set up with "systemcrtl suspend" and it works properly . I was just curious as to why "Fn>F4 wasn't working. I did change keyboard model to Lenovo/IBM. Now I find it might have been working but with a 6 second delay. I just didn't give it enough time to execute. The 6 second delay threw me off because "Crtl.Alt>S" has no delay at all. Anyway I consider this thread [Solved] and thanks to all for your replys.
Thanks:

Post Reply

Return to “Hardware Support”