Disks utility showing SSD at 100° C / 212° F

Questions about hardware,drivers and peripherals
Forum rules
Before you post please read how to get help
Post Reply
MEA707
Level 1
Level 1
Posts: 45
Joined: Sat Jan 18, 2020 2:33 pm

Disks utility showing SSD at 100° C / 212° F

Post by MEA707 »

I installed an SSD last week and Linux Mint 19.3 is showing the temperature as 100° C / 212° F which is clearly off in the Disks Utility (Gnome Disks).

If I type hddtemp in the terminal, it shows it as 33° C which while much more reasonable, I don't think is right either, as this is just when I first turn on the PC and the room temperature is around 20° C.

Anyone know what could be the cause of inaccurate temperature readings?
Lenovo ThinkPad T440p | Intel Core i7-4800MQ 2.70 GHz | Microsoft Windows 10 Pro 64-bit

Lenovo ThinkPad T61 | Intel Core 2 Duo T9300 2.50 GHz | Linux Mint 19.3 Cinnamon 64-bit

User avatar
MtnDewManiac
Level 6
Level 6
Posts: 1478
Joined: Fri Feb 22, 2013 5:18 pm
Location: United States

Re: Disks utility showing SSD at 100° C / 212° F

Post by MtnDewManiac »

A bit late to the party, but I'm seeing the same thing and readings. PNY CS900 240-gig SSD. I just received it last week; it was a gift and I knew nothing about SSDs prior to getting it. Having read many reviews on the thing over the course of several days... I concluded that the issue was most likely attributable to it being the cheapest SSD the world has ever known. Those values are like the factory gauges in old Fords - might as well be painted on.

Regards,
MDM
Mint 18 Xfce 4.12.

If guns kill people, then pencils misspell words, cars make people drive drunk, and spoons made Rosie O'Donnell fat.

User avatar
thx-1138
Level 8
Level 8
Posts: 2111
Joined: Fri Mar 10, 2017 12:15 pm
Location: Athens, Greece

Re: Disks utility showing SSD at 100° C / 212° F

Post by thx-1138 »

...Drives misreporting smart values are common enough (for all kinds of reasons, being cheap, negligence from the vendor etc).

However, gnome-disks, utilizes the values exposed from libatasmart for returning such info.
libatasmart itself was last updated in...May 2012. So, yeah...what would you expect? :)
It's a relatively known issue with other software utilizing such when having newer SSD drives as well.

smartmontools is your best bet for accurate reading of such.
And if there are still issues, you could try manually updating it's internal database,
(located under /var/lib/smartmontools/drivedb/drivedb.h), with the very latest one.

Post Reply

Return to “Hardware Support”