Lost audio output after update mint 19.1

Questions about hardware,drivers and peripherals
Forum rules
Before you post please read how to get help
hadrien38
Level 1
Level 1
Posts: 12
Joined: Mon May 25, 2020 7:32 am

Re: Lost audio output after update mint 19.1

Post by hadrien38 »

Here it is :

Code: Select all

hadrien@Ava-ordinateur:~$ ls -la /etc/udev/rules.d/
total 8
drwxr-xr-x 2 root root 4096 avril 20  2018 .
drwxr-xr-x 4 root root 4096 mai   25 11:10 ..
hadrien@Ava-ordinateur:~$ 
User avatar
MrEen
Level 20
Level 20
Posts: 11803
Joined: Mon Jun 12, 2017 8:39 pm

Re: Lost audio output after update mint 19.1

Post by MrEen »

Dayyyum! Nothing helpful there. How about ls -la /etc/udev and cat /etc/udev/udev.conf
hadrien38
Level 1
Level 1
Posts: 12
Joined: Mon May 25, 2020 7:32 am

Re: Lost audio output after update mint 19.1

Post by hadrien38 »

Yeah, here is the result for those :

Code: Select all

hadrien@Ava-ordinateur:~$ ls -la /etc/udev
total 28
drwxr-xr-x   4 root root  4096 mai   25 11:10 .
drwxr-xr-x 156 root root 12288 juin   3 23:06 ..
drwxr-xr-x   2 root root  4096 avril 20  2018 hwdb.d
drwxr-xr-x   2 root root  4096 avril 20  2018 rules.d
-rw-r--r--   1 root root   153 avril 20  2018 udev.conf
hadrien@Ava-ordinateur:~$ cat /etc/udev/udev.conf
# see udev.conf(5) for details
#
# udevd is started in the initramfs, so when this file is modified the
# initramfs should be rebuilt.

#udev_log="info"
hadrien@Ava-ordinateur:~$ 
User avatar
MrEen
Level 20
Level 20
Posts: 11803
Joined: Mon Jun 12, 2017 8:39 pm

Re: Lost audio output after update mint 19.1

Post by MrEen »

Maybe we're getting close. What's the output of ls -l /etc/udev/hwdb.d. If there's only one file in there, use cat to get it's content as well.
hadrien38
Level 1
Level 1
Posts: 12
Joined: Mon May 25, 2020 7:32 am

Re: Lost audio output after update mint 19.1

Post by hadrien38 »

Arf, unfortunately, nothing here :

Code: Select all

hadrien@Ava-ordinateur:~$ ls -l /etc/udev/hwdb.d
total 0
hadrien@Ava-ordinateur:~$ 
User avatar
MrEen
Level 20
Level 20
Posts: 11803
Joined: Mon Jun 12, 2017 8:39 pm

Re: Lost audio output after update mint 19.1

Post by MrEen »

This is nuts. We've looked everywhere that I can think of to find where the card might be blacklisted.

Actually, one exception to that, but it's not an area I'm skilled at. There might be something relating to your video cards. Your built-in audio card might also have HDMI options, and you have 3 other HDMI cards capable of audio. Maybe there's a setting somewhere in the Video/graphics options that has blacklisted the card you want working, but I have no idea where to look.

One place to look is /var/log/apt/history.log (or the .gz files that follow) to see what update might have caused this. Hopefully you'll be able to figure out the date the updates borked your sound, and can find the list of updates that occurred that day. That should help us figure out how to solve this.
Post Reply

Return to “Hardware Support”