Cannot get wifi to work even with new wireless adapter

Questions about hardware,drivers and peripherals
Forum rules
Before you post please read how to get help
Post Reply
douloscristou
Level 1
Level 1
Posts: 3
Joined: Mon Jun 01, 2020 12:32 pm

Cannot get wifi to work even with new wireless adapter

Post by douloscristou »

I have a Linux Mint HP Pavilion dv6 laptop which will not connect wirelessly.

I thought the wifi card was just bad, so I bought a USB WiFi adapter that I read works well with Ubuntu (Panda PAU05). The drivers do appear to be installed as when I plug it in it shows right up, but it is still not working. Reading some questions/answers on askubuntu.com, I learned enough to run the iwconfig command and the rfkill list all command to get more information. Here is what that shows:

Code: Select all

user@user-HP-Pavilion-dv6-Notebook-PC ~ $ iwconfig
wlx9cefd5fb7ff6  IEEE 802.11  ESSID:off/any  
          Mode:Managed  Access Point: Not-Associated   Tx-Power=0 dBm   
          Retry short  long limit:2   RTS thr:off   Fragment thr:off
          Power Management:off

lo        no wireless extensions.

wlo1      IEEE 802.11  ESSID:off/any  
          Mode:Managed  Access Point: Not-Associated   Tx-Power=off   
          Retry short limit:7   RTS thr=2347 B   Fragment thr:off
          Power Management:on

eno1      no wireless extensions.

user@user-HP-Pavilion-dv6-Notebook-PC ~ $ rfkill list all
0: phy0: Wireless LAN
    Soft blocked: no
    Hard blocked: yes
1: phy1: Wireless LAN
    Soft blocked: no
    Hard blocked: no
I believe but am not certain that the ESSID: off/any means that the the wifi adapter is off. I tried several things that I saw suggested:
  • sudo rfkill unblock all
  • sudo systemctl restart NetworkManager
  • sudo rm /dev/rfkill && sudo reboot
None of these commands appear to have made a difference. I have also tried with ethernet unplugged, as I heard that some computers are setup to ignore wifi when ethernet is present. I mistakenly posted this question on askubuntu but was told that Ubuntu & Mint have siginificant differences and that I should come over here to pose the question. In the comments though they asked me to make sure there was not a wifi switch that was turned off. This laptop does not have a physical switch for wifi. There is a function key (fn F12) that turns wifi off and on, but pressing that does nothing.

I'm not really sure where to go from here and any point in the right direction would be greatly appreciated. Thanks!

sleeper12
Level 10
Level 10
Posts: 3277
Joined: Thu May 25, 2017 3:22 pm

Re: Cannot get wifi to work even with new wireless adapter

Post by sleeper12 »

Your wifi is hard blocked. See if you can turn wifi on in Bios or reset Bios defaults.

douloscristou
Level 1
Level 1
Posts: 3
Joined: Mon Jun 01, 2020 12:32 pm

Re: Cannot get wifi to work even with new wireless adapter

Post by douloscristou »

Wifi was not an option in BIOS but resetting BIOS defaults did the trick. Thank you! It looks like I can repurpose the USB Wifi Adapter, as both devices began working when the BIOS defaults were reset.
Last edited by douloscristou on Mon Jun 01, 2020 5:12 pm, edited 1 time in total.

sleeper12
Level 10
Level 10
Posts: 3277
Joined: Thu May 25, 2017 3:22 pm

Re: Cannot get wifi to work even with new wireless adapter

Post by sleeper12 »

Ok, great. :D

douloscristou
Level 1
Level 1
Posts: 3
Joined: Mon Jun 01, 2020 12:32 pm

Re: Cannot get wifi to work even with new wireless adapter

Post by douloscristou »

I'm new to the forum. Is there a way for me to confirm that you solved my issue?

sleeper12
Level 10
Level 10
Posts: 3277
Joined: Thu May 25, 2017 3:22 pm

Re: Cannot get wifi to work even with new wireless adapter

Post by sleeper12 »

Sure, just click the Edit (pencil) button on the right in your first post here and add "Solved' to the Subject line. Thanks.

Post Reply

Return to “Hardware Support”