[keyboard] Two punctuation keys don't behave as they should.

Questions about hardware,drivers and peripherals
Forum rules
Before you post please read how to get help
Post Reply
Duysterwald
Level 1
Level 1
Posts: 24
Joined: Sun Aug 23, 2009 4:39 am
Location: The Netherlands
Contact:

[keyboard] Two punctuation keys don't behave as they should.

Post by Duysterwald »

Before I go any further, I would like to say that I wasn't sure whether I should place this thread in this subforum, or in the Other Topics subforum. I ultimately decided on the former (obviously), but if this thread doesn't belong here, then I apologise - feel free to move it to the proper subforum. :)

I installed the 64-bit version of Linux Mint 7 "Gloria" (with Gnome) a little over a week ago, and ever since, I found that there was a slight problem with my keyboard (which is part of the Logitech Cordless Desktop MX 3100). During the installation process of Linux Mint, I had chosen US International (with dead keys) as the layout for my keyboard, since my keyboard has always been US International by default in Windows XP (and I *never* had any problems with that, even if I didn't install the Logitech software in Windows XP). In Linux Mint, however, there are two keys that don't yield the characters that they normally should: the key for the apostrophe, and the key for the double quotation mark. Please see the following two examples to see what I mean:

Apostrophe
Image

Double quotation mark
Image

It's a bit unsettling to see the wrong characters while typing, and it unfortunately is too roundabout and time-consuming to keep copying and pasting the right characters out of Open Office all the time whenever I have to write something. I've tried going to the Control Center and selecting different keyboard layouts in the Keyboard section, but the problem is present in each and every one of the possible keyboard layouts. :? I am aware that it is possible to customise a keyboard layout in Linux Mint, at least to a certain degree - but I wouldn't know how to change the properties of the two keys that I mentioned (and as a newbie to Linux Mint I'd rather not blindly fiddle with the keyboard layout and only make things worse). :|

I tried hitting the Num Lock key, by the way - that made the dead keys on the right of the keyboard disappear, but the problem with the aforementioned two keys still persists, unfortunately. :(

So, in short, does someone here happen to know a solution to this problem? I really hope so, seeing as I haven't been able to find a similar thread on this forum. :? But, thank you very much in advance for your time! :D 8)
Muzer
Level 4
Level 4
Posts: 220
Joined: Thu Aug 27, 2009 2:09 pm

Re: [keyboard] Two punctuation keys don't behave as they should.

Post by Muzer »

What, you say it still fails even with the standard US layout? That's rather strange.
Duysterwald
Level 1
Level 1
Posts: 24
Joined: Sun Aug 23, 2009 4:39 am
Location: The Netherlands
Contact:

Re: [keyboard] Two punctuation keys don't behave as they should.

Post by Duysterwald »

Muzer wrote:What, you say it still fails even with the standard US layout? That's rather strange.
Yes, I have tried all of the featured US layouts and the problem still persists with each of them. There is a slight possibility that the fact that I could not select my own keyboard model in the list of possible keyboards - I had to select "Logitech Cordless Desktop (alternative option)" - might contribute to the problem. But I doubt it, because the problem persists even if I choose other Logitech keyboard models in the list.
User avatar
DrHu
Level 17
Level 17
Posts: 7522
Joined: Wed Jun 17, 2009 8:20 pm

Re: [keyboard] Two punctuation keys don't behave as they should.

Post by DrHu »

Duysterwald wrote:I had to select "Logitech Cordless Desktop (alternative option)" - might contribute to the problem. But I doubt it, because the problem persists even if I choose other Logitech keyboard models in the list
http://linux.seindal.dk/2005/06/04/logi ... top-lx700/
  • Evan Says: July 4th, 2005 at 2:50 am
    Slight change to the setkeycodes for MX3100 thanks to Sheldon from lineak for his help.
    setkeycodes e014 189 e013 221 e015 202 e055 157 e011 203 e075 217 e074 212
Despite the fact that it is a wireless keyboard, probably any Logitech keyboard selection will work, including generic 105 keyboard (a wired model)
--there are lots of wireless keyboard models to try; why not add them all and then go through each one (wireless models), to see what the usa keyboard layout offers; as well you can adjust some settings in that layout selection..

Your first post the punctuation you show, looks like international keyboard layout version: typographic (that's mine with a generic 105 keyboard (wired), and I also don't get t use my keyboards name Omnikey ultra ", ' )) marks..instead of the usa style (layout) that matches the keyboard markings on the usa keyboards..
Duysterwald
Level 1
Level 1
Posts: 24
Joined: Sun Aug 23, 2009 4:39 am
Location: The Netherlands
Contact:

Re: [keyboard] Two punctuation keys don't behave as they should.

Post by Duysterwald »

DrHu wrote:
Duysterwald wrote:I had to select "Logitech Cordless Desktop (alternative option)" - might contribute to the problem. But I doubt it, because the problem persists even if I choose other Logitech keyboard models in the list
http://linux.seindal.dk/2005/06/04/logi ... top-lx700/
  • Evan Says: July 4th, 2005 at 2:50 am
    Slight change to the setkeycodes for MX3100 thanks to Sheldon from lineak for his help.
    setkeycodes e014 189 e013 221 e015 202 e055 157 e011 203 e075 217 e074 212
Despite the fact that it is a wireless keyboard, probably any Logitech keyboard selection will work, including generic 105 keyboard (a wired model)
--there are lots of wireless keyboard models to try; why not add them all and then go through each one (wireless models), to see what the usa keyboard layout offers; as well you can adjust some settings in that layout selection..

Your first post the punctuation you show, looks like international keyboard layout version: typographic (that's mine with a generic 105 keyboard (wired), and I also don't get t use my keyboards name Omnikey ultra ", ' )) marks..instead of the usa style (layout) that matches the keyboard markings on the usa keyboards..
Thank you for the link, it seems very useful - but for me as a newbie to Linux Mint (and someone who has never before needed to make any of her keyboard keys work manually), it all looks rather complicated and is nearly gibberish to me. :oops: I'm going to have to find me someone who can explain the whole thing to me in a way that even a toddler would understand, LOL. :P ;) I don't need *all* of the extra keys to work (seeing as I barely used them, anyway), though, I just want the ones for the apostrophe and double quotation mark to work. :)
mihaly
Level 1
Level 1
Posts: 6
Joined: Thu Feb 09, 2012 11:10 pm

Re: [keyboard] Two punctuation keys don't behave as they sho

Post by mihaly »

Right, Now I have this problem on my ACER Aspire 1700 Desktop portable. The problem as I understand it arose when I chose to use the USA Int'l keyboard choice on installation, but realised it was the wrong "layout" and so when I hit the apostrophe key ' what I got was nothing, but the next key I hit afterwards gave me an acute or grave on the letter. This NOT being what I wanted (particularly annoying in terminals), I realised I could get a LAYOUT for the standard USA keymap, which, when selected would give me the desired behaviour - that when I hit apostrophe, I get an apaostrophe ' .

It has been mentioned elsewhere that there is a resulting problem which I now have: When you reboot, for some reason you go back to the earlier behaviour. Even though I have removed the entry for the Int'l keymap, it seems to somehow sneak back and will be the default keyboard layout when I next reboot (or even just log out and log back in.

Fine, you may suggest it's in the configuration files, so I look for /etc/default/kbd ... No such file exists. I can't be sure where it's picking up the keyboard layout, I'm guessing it's built into one of the config files associated with the particular config tools. Since I'm reluctant to mess about with those, I'm asking for some advice.

Specifically: Why does the keymap reappear after reloading X/rebooting the Mint system? How can I permanently remove the incorrect setting? I have seen the LAYOUT options, the various options don't seem to be the specific setting I need.

Someone has mentioned using apt-get commandline commands, but I need the specifics of what such a command will do, because some say you use dpkg, others say apt-get reinstall, some reference a file I don't actually have in the /etc/ directory. I'd rather a careful response with explanations about what I am actually doing exactly before I start trying them out because if there isn't a GUI tool, or it's broken somehow you need that info for the community.

I understand the rudiments of apt and package stuff, my package manager says nothings broken, so if I have to use a commandline to force something, I'd like to know how to reverse it - in case I inevitably get the syntax wrong and have to undo it.

I don't wish to sound like I am being rude here, but so often it happens that people tell you to just do this command, and it ISN'T what they meant, or what they think is correct but isn't for your specific situation and I haven't explained it clearly enough to get across what I actually want to achieve.

So please bear with my question, and if it has been answered elsewhere, I apologise. But as far as I can see it hasn't addressed the specifics of what I am experiencing, or hasn't addressed the specifics of my situation.

Thanks in advance,
Mihaly.
Post Reply

Return to “Hardware Support”