Bluetooth dongle works but can't search devices

Questions about hardware,drivers and peripherals
Forum rules
Before you post please read how to get help
Post Reply
nitish159
Level 1
Level 1
Posts: 2
Joined: Sat Apr 20, 2019 3:49 pm

Bluetooth dongle works but can't search devices

Post by nitish159 »

Hi, I am running Linux Mint 20.04 and I am trying to add my bluetooth headphones to work with it but it is stuck at searching for devices. I even tried blueman but it didn't work. When using lsusb, I get the following output:

Code: Select all

Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 001 Device 005: ID 148f:5372 Ralink Technology, Corp. RT5372 Wireless Adapter
Bus 001 Device 004: ID 0c45:7603 Microdia USB Keyboard
Bus 001 Device 003: ID 046d:c07e Logitech, Inc. G402 Gaming Mouse
Bus 001 Device 002: ID 0a12:0001 Cambridge Silicon Radio, Ltd Bluetooth Dongle (HCI mode)
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
hciconfig gives the following output:

Code: Select all

hci0:	Type: Primary  Bus: USB
	BD Address: 00:1A:7D:DA:71:10  ACL MTU: 640:4  SCO MTU: 64:8
	UP RUNNING PSCAN ISCAN 
	RX bytes:721 acl:0 sco:0 events:51 errors:0
	TX bytes:2696 acl:0 sco:0 commands:52 errors:0
and

Code: Select all

lspci -nnk|grep -iA3 net; lsusb; rfkill list all; dmesg|egrep -i 'blue|firm'; hciconfig -a
gives the following output:

Code: Select all

07:00.0 Ethernet controller [0200]: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller [10ec:8168] (rev 15)
	Subsystem: ASUSTeK Computer Inc. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller [1043:8677]
	Kernel driver in use: r8169
	Kernel modules: r8169
Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 001 Device 005: ID 148f:5372 Ralink Technology, Corp. RT5372 Wireless Adapter
Bus 001 Device 004: ID 0c45:7603 Microdia USB Keyboard
Bus 001 Device 003: ID 046d:c07e Logitech, Inc. G402 Gaming Mouse
Bus 001 Device 002: ID 0a12:0001 Cambridge Silicon Radio, Ltd Bluetooth Dongle (HCI mode)
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
0: hci0: Bluetooth
	Soft blocked: no
	Hard blocked: no
1: phy0: Wireless LAN
	Soft blocked: no
	Hard blocked: no
[    0.141378] Spectre V2 : Enabling Restricted Speculation for firmware calls
[    4.222483] Bluetooth: Core ver 2.22
[    4.222490] Bluetooth: HCI device and connection manager initialized
[    4.222492] Bluetooth: HCI socket layer initialized
[    4.222495] Bluetooth: L2CAP socket layer initialized
[    4.222498] Bluetooth: SCO socket layer initialized
[    5.056371] Bluetooth: BNEP (Ethernet Emulation) ver 1.3
[    5.056372] Bluetooth: BNEP filters: protocol multicast
[    5.056375] Bluetooth: BNEP socket layer initialized
[    5.461797] ieee80211 phy0: rt2x00lib_request_firmware: Info - Loading firmware file 'rt2870.bin'
[    5.462423] ieee80211 phy0: rt2x00lib_request_firmware: Info - Firmware detected - version: 0.36
[    9.972019] Bluetooth: RFCOMM TTY layer initialized
[    9.972026] Bluetooth: RFCOMM socket layer initialized
[    9.972031] Bluetooth: RFCOMM ver 1.11
[   11.986502] Bluetooth: hci0: command 0x0c24 tx timeout
[   14.002529] Bluetooth: hci0: command 0x0c52 tx timeout
[   18.003023] Bluetooth: hci0: setting interface failed (110)
[  127.540115] Bluetooth: hci0: command 0x0409 tx timeout
hci0:	Type: Primary  Bus: USB
	BD Address: 00:1A:7D:DA:71:10  ACL MTU: 640:4  SCO MTU: 64:8
	UP RUNNING PSCAN ISCAN 
	RX bytes:721 acl:0 sco:0 events:51 errors:0
	TX bytes:2696 acl:0 sco:0 commands:52 errors:0
	Features: 0xff 0xff 0x8f 0xfa 0xdb 0xff 0x5b 0x87
	Packet type: DM1 DM3 DM5 DH1 DH3 DH5 HV1 HV2 HV3 
	Link policy: RSWITCH HOLD SNIFF PARK 
	Link mode: SLAVE ACCEPT 
Can't read local name on hci0: Connection timed out (110)
I tried searching on forums, but no solution worked for me. Hoping for some assistance from you all. :D
sleeper12
Level 11
Level 11
Posts: 3675
Joined: Thu May 25, 2017 3:22 pm

Re: Bluetooth dongle works but can't search devices

Post by sleeper12 »

Maybe you need to turn secure boot off in Bios?

Code: Select all

 mokutil --sb-state 
joubertvasc
Level 1
Level 1
Posts: 1
Joined: Mon Jul 06, 2020 8:37 am

Re: Bluetooth dongle works but can't search devices

Post by joubertvasc »

Same here. I updated from 19.3 with hope to fix this problem, but nothing. In my case the adapter is a Cambridge Silicon Radio working fine using other OS.
relayer2all
Level 1
Level 1
Posts: 5
Joined: Tue Jul 14, 2020 8:45 am

Re: Bluetooth dongle works but can't search devices

Post by relayer2all »

I am having the same issue with the following dongle;
Bus 001 Device 004: ID 0a12:0001 Cambridge Silicon Radio, Ltd Bluetooth Dongle (HCI mode)
has anyone cracked the issue yet?
Post Reply

Return to “Hardware Support”