Page 1 of 1

Touchpad only partially working on Mint 19.3 & 20 XFCE - SOLVED

Posted: Sat Jun 27, 2020 8:52 pm
by lachelp
Hi guys,

I am having troubles during USB boots - in 19.3 xfce 64-bit my touchpad does not register clicks or double-clicks of the pad (but using the touchpad's buttons or a mouse works fine.)

I have found that the touchpad used libinput v1.10 while the LMDE 19.3 64-bit uses libinput v1.12 and on that version of LM the touchpad works fine. I used this command in a terminal to find this out:
grep -i "using input driver" /var/log/Xorg.0.log

Can any offer a suggestion as to how to upgrade libinput so we can see if this fixes the problem?

Re: Touchpad only partially working on Mint 19.3 XFCE

Posted: Sun Jun 28, 2020 12:37 am
by xenopeek
Try Linux Mint 20 Xfce? It has libinput 1.15.

Re: Touchpad only partially working on Mint 19.3 XFCE

Posted: Mon Jun 29, 2020 4:39 am
by lachelp
D*mn... And I just d/l-ed and installed 19.3 thinking it was the latest/greatest. Erg!

Re: Touchpad only partially working on Mint 19.3 XFCE

Posted: Mon Jun 29, 2020 7:47 pm
by lachelp
xenopeek wrote:
Sun Jun 28, 2020 12:37 am
Try Linux Mint 20 Xfce? It has libinput 1.15.
That was a bust xenopeek. LM 20 XFCE 64-bit version has the same problem - no touchpad tapping going on.

My machine is a rather ancient Gateway L22, 2GB notebook but I don't have that problem with LMDE 19, Zorin, AntiX, BionicPuppy, etc..

Does anyone know of a setting that could cause this?

Re: Touchpad only partially working on Mint 19.3 XFCE

Posted: Tue Jun 30, 2020 12:01 am
by denverjim
I switched to synaptics driver and works much better.

apt install xserver-xorg-input-synaptics
then logout and log back in.

If it makes the problem worse, then uninstall via: apt remove xserver-xorg-input-synaptics

Re: Touchpad only partially working on Mint 19.3 XFCE

Posted: Tue Jun 30, 2020 11:49 pm
by lachelp
I found the painless solution.

In XFCE go to Menu, Settings, Mouse and Touchpad.

On the Devices tab, Hit the Device 'drop-down' and choose your touchpad.

Below that, chose the Touchpad tab and under General click "Tap touchpad to click" and you might also want to select your favorite scroll method...

That's it.

It appears to me that someone in LM development wants to slow the acceptance of LM with this unusual setting, but there it is. Simple in the end.