Asus TUF A15 doesn't run Ulyana :( [SOLVED]

Questions about hardware,drivers and peripherals
Forum rules
Before you post please read how to get help
Post Reply
kingwins
Level 1
Level 1
Posts: 9
Joined: Sun Jun 28, 2020 2:12 am

Asus TUF A15 doesn't run Ulyana :( [SOLVED]

Post by kingwins »

Ryzen 7 4800H, RTX 2060, I just downloaded Linux Mint Cinnamon 20 and booting from pendrive
It starts in compatibility mode but in normal mode it shows errors:

https://imgshare.io/image/indeks.NbxI1u

I'm affraid to install it because I got working OpenSuse on the machine and there is no option to install Mint beside this one, just to format whole partition :/

EDIT:
I think my problem is related to:
nouveau 000:01:00.0 tmr: stalled at ffff
So it's NVIDIA Graphics Card problem, dunno how to solve it though :(
Last edited by kingwins on Mon Dec 21, 2020 10:42 am, edited 1 time in total.
User avatar
ernie dingbat
Level 2
Level 2
Posts: 74
Joined: Fri Aug 31, 2012 10:02 am

Re: Asus TUF A15 doesn't run Ulyana :(

Post by ernie dingbat »

kingwins wrote:
Sun Jun 28, 2020 2:29 am
Ryzen 7 4800H, RTX 2060, I just downloaded Linux Mint Cinnamon 20 and booting from pendrive
It starts in compatibility mode but in normal mode it shows errors:
Hi, kingwins

If you read the release notes you'll see that you should start in compatibility mode with that video card. It's ok to then install while in that mode.

Read here: https://linuxmint.com/rel_ulyana_cinnamon.php

You need to follow the instructions under the heading Solving freezes during the boot sequence

I had to install that way and I had no issues at all.

Ernie
kingwins
Level 1
Level 1
Posts: 9
Joined: Sun Jun 28, 2020 2:12 am

Re: Asus TUF A15 doesn't run Ulyana :(

Post by kingwins »

Thx Ernie for response
I installed it from compatibility mode, after reboot I get this error:

Code: Select all

ucsi_acpi USBC000:00: PPM init failed (-110)
User avatar
ernie dingbat
Level 2
Level 2
Posts: 74
Joined: Fri Aug 31, 2012 10:02 am

Re: Asus TUF A15 doesn't run Ulyana :(

Post by ernie dingbat »

kingwins wrote:
Sun Jun 28, 2020 5:19 am
Thx Ernie for response
I installed it from compatibility mode, after reboot I get this error:

Code: Select all

ucsi_acpi USBC000:00: PPM init failed (-110)
Hi, kingwins

Did you install the nvidia driver yet? Also, post the terminal output of inxi -Fxz. It would be helpful if you used code tags around the output by clicking the </> icon when you reply.

Ernie
kingwins
Level 1
Level 1
Posts: 9
Joined: Sun Jun 28, 2020 2:12 am

Re: Asus TUF A15 doesn't run Ulyana :(

Post by kingwins »

No, I haven't installed Nvidia driver yet because I cannot get into Linux after installation, getting this usb error like I posted before, here is my inxi -Fxz:

Code: Select all

System:
  Kernel: 5.4.0-26-generic x86_64 bits: 64 compiler: gcc v: 9.3.0 
  Desktop: Cinnamon 4.6.6 Distro: Linux Mint 20 Ulyana 
  base: Ubuntu 20.04 focal 
Machine:
  Type: Laptop System: ASUSTeK product: TUF Gaming FA506IV_FA506IV v: 1.0 
  serial: <filter> 
  Mobo: ASUSTeK model: FA506IV v: 1.0 serial: <filter> 
  UEFI: American Megatrends v: FA506IV.302 date: 03/04/2020 
Battery:
  ID-1: BAT1 charge: 46.1 Wh condition: 46.1/48.1 Wh (96%) 
  model: ASUS A32-K55 status: Full 
CPU:
  Topology: 8-Core model: AMD Ryzen 7 4800H with Radeon Graphics bits: 64 
  type: MT MCP arch: Zen rev: 1 L2 cache: 4096 KiB 
  flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm 
  bogomips: 92624 
  Speed: 1345 MHz min/max: 1400/2900 MHz Core speeds (MHz): 1: 1211 2: 1214 
  3: 1839 4: 1907 5: 4112 6: 3389 7: 1618 8: 1592 9: 1211 10: 1211 11: 1697 
  12: 1690 13: 1209 14: 1208 15: 1909 16: 1905 
Graphics:
  Device-1: NVIDIA TU106 [GeForce RTX 2060] vendor: ASUSTeK driver: N/A 
  bus ID: 01:00.0 
  Device-2: AMD Renoir vendor: ASUSTeK driver: N/A bus ID: 05:00.0 
  Display: x11 server: X.Org 1.20.8 driver: ati,fbdev 
  unloaded: modesetting,radeon,vesa resolution: 1920x1080~77Hz 
  OpenGL: renderer: llvmpipe (LLVM 9.0.1 128 bits) v: 3.3 Mesa 20.0.4 
  direct render: Yes 
Audio:
  Device-1: NVIDIA TU106 High Definition Audio vendor: ASUSTeK 
  driver: snd_hda_intel v: kernel bus ID: 01:00.1 
  Device-2: AMD vendor: ASUSTeK driver: snd_hda_intel v: kernel 
  bus ID: 05:00.1 
  Device-3: AMD Raven/Raven2/FireFlight/Renoir Audio Processor driver: N/A 
  bus ID: 05:00.5 
  Device-4: AMD Family 17h HD Audio vendor: ASUSTeK driver: snd_hda_intel 
  v: kernel bus ID: 05:00.6 
  Sound Server: ALSA v: k5.4.0-26-generic 
Network:
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet 
  vendor: ASUSTeK driver: r8169 v: kernel port: e000 bus ID: 02:00.0 
  IF: enp2s0 state: down mac: <filter> 
  Device-2: Realtek RTL8822CE 802.11ac PCIe Wireless Network Adapter 
  vendor: AzureWave driver: rtw_pci v: N/A port: d000 bus ID: 03:00.0 
  IF: wlp3s0 state: up mac: <filter> 
Drives:
  Local Storage: total: 480.74 GiB used: 10.29 GiB (2.1%) 
  ID-1: /dev/nvme0n1 vendor: A-Data model: SX8200PNP size: 476.94 GiB 
  ID-2: /dev/sda type: USB model: 090c 1000 size: 3.80 GiB 
Partition:
  ID-1: / size: 15.40 GiB used: 119.8 MiB (0.8%) fs: overlay source: ERR-102 
Sensors:
  Message: No sensors data was found. Is sensors configured? 
Info:
  Processes: 320 Uptime: 9m Memory: 30.79 GiB used: 2.27 GiB (7.4%) 
  Init: systemd runlevel: 5 Compilers: gcc: 9.3.0 Shell: bash v: 5.0.16 
  inxi: 3.0.38 
kingwins
Level 1
Level 1
Posts: 9
Joined: Sun Jun 28, 2020 2:12 am

Re: Asus TUF A15 doesn't run Ulyana :(

Post by kingwins »

Problem Solved, I'll make little tutorial for other noobs:
  • Install Linux Mint from Compatibility Mode, reboot
  • HOLD SHIFT while booting, the menu will show up, pick Advanced Options (or sth like that), you will get into sth like Windows safe mode
  • Open menu > administration > driver manager, choose NVIDIA driver instead of opensource one (it will show up)
That's it, thx Ernie for help, I just didn't know to hold shift while booting :)
kingwins
Level 1
Level 1
Posts: 9
Joined: Sun Jun 28, 2020 2:12 am

Re: Asus TUF A15 doesn't run Ulyana :(

Post by kingwins »

There is another problem though...

Every time I start system now it's prompting me that it's working without acceleration and to check driver, driver is nvidia 440 sth....

When I close my laptop lid it gets into suspend mode, open it up - screen stays black :(

edit:
ctrl-alt-f1, ctrl-alt-f7 doesn't help
User avatar
Noto
Level 1
Level 1
Posts: 18
Joined: Wed Jan 22, 2020 1:57 pm

Re: Asus TUF A15 doesn't run Ulyana :(

Post by Noto »

Hi, if you try to log in (blinded) the screen wake up?
kingwins
Level 1
Level 1
Posts: 9
Joined: Sun Jun 28, 2020 2:12 am

Re: Asus TUF A15 doesn't run Ulyana :(

Post by kingwins »

Noto wrote:
Sun Jun 28, 2020 1:24 pm
Hi, if you try to log in (blinded) the screen wake up?
nope, it won't wake up
User avatar
Dark Owl
Level 4
Level 4
Posts: 313
Joined: Sat May 02, 2020 7:43 am
Location: Brit

Re: Asus TUF A15 doesn't run Ulyana :(

Post by Dark Owl »

kingwins wrote:
Sun Jun 28, 2020 6:36 am
Problem Solved, I'll make little tutorial for other noobs:
  • Install Linux Mint from Compatibility Mode, reboot
  • HOLD SHIFT while booting, the menu will show up, pick Advanced Options (or sth like that), you will get into sth like Windows safe mode
  • Open menu > administration > driver manager, choose NVIDIA driver instead of opensource one (it will show up)
That's it, thx Ernie for help, I just didn't know to hold shift while booting :)
My install has the grub menu up for 30 seconds (before it defaults to normal boot), during which I can select compatibility mode. No need for holding shift. Having installed from compatibility mode, then booted the install in compatibility mode, it's been fine since installing the Nvidia drivers - but it's a desktop and I'm not suspending it.

The kernel version changed at 19.3, and my system only boots direct from iso without compatibility mode (or drivers) with 19.2 and below.
Currently: Linux Mint 20 Cinnamon 64-bit 4.6.6, AMD Ryzen5 + Geforce GT 710
Previously: LM20β, LM18.2
User avatar
B4RTL3TT
Level 1
Level 1
Posts: 5
Joined: Tue Aug 18, 2020 9:49 pm

Re: Asus TUF A15 doesn't run Ulyana :(

Post by B4RTL3TT »

kingwins wrote:
Sun Jun 28, 2020 5:19 am
Thx Ernie for response
I installed it from compatibility mode, after reboot I get this error:

Code: Select all

ucsi_acpi USBC000:00: PPM init failed (-110)
Thanks kingswins for the post, it pointed me enough in the right direction to get this working. I ran into this error or something very similar when I hadn't disabled Secure Boot yet.
Currently: Linux Mint 20 Cinnamon 64-bit 4.8.1, AMD Ryzen7 + Geforce RTX 2060
Previously: LM17.3
kiril
Level 1
Level 1
Posts: 1
Joined: Tue Oct 13, 2020 3:38 pm

Re: Asus TUF A15 doesn't run Ulyana :(

Post by kiril »

kingwins wrote:
Sun Jun 28, 2020 7:22 am
There is another problem though...

Every time I start system now it's prompting me that it's working without acceleration and to check driver, driver is nvidia 440 sth....

When I close my laptop lid it gets into suspend mode, open it up - screen stays black :(

edit:
ctrl-alt-f1, ctrl-alt-f7 doesn't help
Hi Kingwins, I have the same problem. Did you manage to get rid of it.
kingwins
Level 1
Level 1
Posts: 9
Joined: Sun Jun 28, 2020 2:12 am

Re: Asus TUF A15 doesn't run Ulyana :(

Post by kingwins »

kiril wrote:
Tue Oct 13, 2020 3:42 pm
Hi Kingwins, I have the same problem. Did you manage to get rid of it.
I've managed to overcome most of those problems by upgrading the kernel to 5.71
User avatar
SMG
Level 11
Level 11
Posts: 3724
Joined: Sun Jul 26, 2020 6:15 pm
Location: USA

Re: Asus TUF A15 doesn't run Ulyana :(

Post by SMG »

kingwins wrote:
Sun Dec 20, 2020 4:40 pm
kiril wrote:
Tue Oct 13, 2020 3:42 pm
Hi Kingwins, I have the same problem. Did you manage to get rid of it.
I've managed to overcome most of those problems by upgrading the kernel to 5.71
Kernel 5.8 is available in Update Manager. Select View > Linux Kernels and click Continue. Make sure 5.8 is selected on the left and then click the top-most option on the right. An "Install" button will appear. Install and reboot. Because the 5.8.0 kernel is in the support list, you will receive notices about updates to it.
LM20.1 Cinnamon
kingwins
Level 1
Level 1
Posts: 9
Joined: Sun Jun 28, 2020 2:12 am

Re: Asus TUF A15 doesn't run Ulyana :(

Post by kingwins »

SMG wrote:
Sun Dec 20, 2020 6:24 pm
kingwins wrote:
Sun Dec 20, 2020 4:40 pm
kiril wrote:
Tue Oct 13, 2020 3:42 pm
Hi Kingwins, I have the same problem. Did you manage to get rid of it.
I've managed to overcome most of those problems by upgrading the kernel to 5.71
Kernel 5.8 is available in Update Manager. Select View > Linux Kernels and click Continue. Make sure 5.8 is selected on the left and then click the top-most option on the right. An "Install" button will appear. Install and reboot. Because the 5.8.0 kernel is in the support list, you will receive notices about updates to it.
thank you, works perfectly :)
Post Reply

Return to “Hardware Support”