<SOLVED> No sound on new install of Mint 20 Cinnamon on zenbook 14 from headphones or speakers; sound cards are detected

Questions about hardware,drivers and peripherals
Forum rules
Before you post please read how to get help
Post Reply
bubbus
Level 2
Level 2
Posts: 51
Joined: Mon Jul 06, 2020 3:10 pm

<SOLVED> No sound on new install of Mint 20 Cinnamon on zenbook 14 from headphones or speakers; sound cards are detected

Post by bubbus »

Hello
I recently installed Linux Mint 20 Cinnamon on my brand new Asus ZenBook UM433D, dual booting with Windows 10. I get no sound through speakers or headphones. I've looked at three or four different troubleshooting tutorials online but nothing seems to really be working. inxi -Fxxxrz gives:

Code: Select all

System:
  Kernel: 5.4.0-40-generic x86_64 bits: 64 compiler: gcc v: 9.3.0 
  Desktop: Cinnamon 4.6.6 wm: muffin 4.6.2 dm: LightDM 1.30.0 
  Distro: Linux Mint 20 Ulyana base: Ubuntu 20.04 focal 
Machine:
  Type: Laptop System: ASUSTeK product: ZenBook UX434DA_UM433DA v: 1.0 
  serial: <filter> 
  Mobo: ASUSTeK model: UX434DA v: 1.0 serial: <filter> 
  UEFI: American Megatrends v: UX434DA_UM433DA.302 date: 09/05/2019 
Battery:
  ID-1: BAT0 charge: 50.6 Wh condition: 50.6/50.0 Wh (101%) volts: 11.9/11.9 
  model: ASUSTeK ASUS Battery type: Li-ion serial: <filter> 
  status: Not charging cycles: 1 
CPU:
  Topology: Quad Core model: AMD Ryzen 7 3700U with Radeon Vega Mobile Gfx 
  bits: 64 type: MT MCP arch: Zen+ rev: 1 L2 cache: 2048 KiB 
  flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm 
  bogomips: 36731 
  Speed: 1381 MHz min/max: 1400/2300 MHz boost: enabled Core speeds (MHz): 
  1: 1223 2: 1224 3: 1275 4: 1223 5: 1239 6: 1348 7: 1270 8: 1389 
Graphics:
  Device-1: AMD Picasso vendor: ASUSTeK driver: amdgpu v: kernel 
  bus ID: 03:00.0 chip ID: 1002:15d8 
  Display: x11 server: X.Org 1.20.8 driver: amdgpu,ati 
  unloaded: fbdev,modesetting,vesa resolution: 1920x1080~60Hz 
  OpenGL: renderer: AMD RAVEN (DRM 3.35.0 5.4.0-40-generic LLVM 10.0.0) 
  v: 4.6 Mesa 20.0.8 direct render: Yes 
Audio:
  Device-1: AMD Raven/Raven2/Fenghuang HDMI/DP Audio driver: snd_hda_intel 
  v: kernel bus ID: 03:00.1 chip ID: 1002:15de 
  Device-2: AMD Raven/Raven2/FireFlight/Renoir Audio Processor 
  driver: snd_rn_pci_acp3x v: kernel bus ID: 03:00.5 chip ID: 1022:15e2 
  Device-3: AMD Family 17h HD Audio vendor: ASUSTeK driver: snd_hda_intel 
  v: kernel bus ID: 03:00.6 chip ID: 1022:15e3 
  Sound Server: ALSA v: k5.4.0-40-generic 
Network:
  Device-1: Intel Wireless 8265 / 8275 driver: iwlwifi v: kernel 
  bus ID: 01:00.0 chip ID: 8086:24fd 
  IF: wlp1s0 state: up mac: <filter> 
Drives:
  Local Storage: total: 953.87 GiB used: 211.32 GiB (22.2%) 
  ID-1: /dev/nvme0n1 vendor: Samsung model: MZVLB1T0HALR-00000 
  size: 953.87 GiB speed: 31.6 Gb/s lanes: 4 serial: <filter> rev: EXA7301Q 
  scheme: GPT 
Partition:
  ID-1: / size: 18.21 GiB used: 12.57 GiB (69.0%) fs: ext4 
  dev: /dev/nvme0n1p5 
  ID-2: /home size: 624.19 GiB used: 198.72 GiB (31.8%) fs: ext4 
  dev: /dev/nvme0n1p7 
  ID-3: swap-1 size: 29.80 GiB used: 0 KiB (0.0%) fs: swap 
  dev: /dev/nvme0n1p6 
Sensors:
  System Temperatures: cpu: 55.6 C mobo: N/A gpu: amdgpu temp: 55 C 
  Fan Speeds (RPM): cpu: 2400 
Repos:
  No active apt repos in: /etc/apt/sources.list 
  Active apt repos in: /etc/apt/sources.list.d/official-package-repositories.list 
  1: deb http://packages.linuxmint.com ulyana main upstream import backport #id:linuxmint_main
  2: deb http://archive.ubuntu.com/ubuntu focal main restricted universe multiverse
  3: deb http://archive.ubuntu.com/ubuntu focal-updates main restricted universe multiverse
  4: deb http://archive.ubuntu.com/ubuntu focal-backports main restricted universe multiverse
  5: deb http://security.ubuntu.com/ubuntu/ focal-security main restricted universe multiverse
  6: deb http://archive.canonical.com/ubuntu/ focal partner
Info:
  Processes: 259 Uptime: 29m Memory: 13.68 GiB used: 2.41 GiB (17.6%) 
  Init: systemd v: 245 runlevel: 5 Compilers: gcc: 9.3.0 alt: 9 Shell: bash 
  v: 5.0.16 running in: gnome-terminal inxi: 3.0.38 

I have tried force reloading and reinstalling ALSA, which did not work. I opened up alsamixer, and the default detected card (card index 0) was an HD-audio-generic card (chip: ATI R6xx HDMI) that doesn't actually seem to have a volume control, just a single box with S/PDIF under it. If I navigate to card 1 (also HD-audio-generic, chip: Realtec ALC294), I see all the sound bars, but nothing is muted besides the headphone channel when they're unplugged and the speaker channel when headphones are plugged in. I have tried the sound settings tool, which detects Family 17h (Models 10h-1fh) HD Audio Controller speakers and my headphones when I plug them in, but no sound comes out in either case. I have also tried PulseAudio volume control which detects all 3 sound cards. Again, nothing is muted and the Family 17h card is set to Analog Stereo Output under the Configuration tab.

About the only thing I've seen in tutorials that I haven't tried is disabling speech-dispatcher. Stuff I've looked at says to use

Code: Select all

sudo gedit /etc/default/speech-dispatcher
and change RUN=yes to RUN=no, but when I put the code in terminal I get a blank .txt file. Not really sure how I would go about disabling it besides that.

Basically, everything tutorials have told me should be broken/not working in the case of not having sound seems to be working fine (although it is possible I'm missing something) yet I still have no sound.

Thanks in advance!
Last edited by bubbus on Sat Jul 11, 2020 9:24 pm, edited 1 time in total.
User avatar
MrEen
Level 20
Level 20
Posts: 11790
Joined: Mon Jun 12, 2017 8:39 pm

Re: No sound on new install of Mint 20 Cinnamon on zenbook 14 from headphones or speakers; sound cards are detected

Post by MrEen »

Hi bubbus, and welcome to the forum.

You're the second user I've seen with this brand new audio thingamajig:

Code: Select all

  Device-2: AMD Raven/Raven2/FireFlight/Renoir Audio Processor 
  driver: snd_rn_pci_acp3x v: kernel bus ID: 03:00.5 chip ID: 1022:15e2
Still hoping to help the other user get their sound working. For yours, the prospects look brighter because of this:

Code: Select all

  Device-3: AMD Family 17h HD Audio vendor: ASUSTeK driver: snd_hda_intel 
  v: kernel bus ID: 03:00.6 chip ID: 1022:15e3 
Run this then paste the output so I can get a look at your sound setup:

Code: Select all

curl https://gitlab.freedesktop.org/pulseaudio/pulseaudio/raw/master/src/utils/pa-info?inline=false | bash | nc termbin.com 9999
The last line will have a URL pointing to the info.
bubbus
Level 2
Level 2
Posts: 51
Joined: Mon Jul 06, 2020 3:10 pm

Re: No sound on new install of Mint 20 Cinnamon on zenbook 14 from headphones or speakers; sound cards are detected

Post by bubbus »

Wow thanks for that quick reply! Here's what I got:

Code: Select all

ter/src/utils/pa-info?inline=false | bash | nc termbin.com 9999
  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed
100  2039  100  2039    0     0   4973      0 --:--:-- --:--:-- --:--:--  4973
lsof: WARNING: can't stat() fuse file system /root/.cache/doc
      Output information may be incomplete.
lsof: WARNING: can't stat() fuse.gvfsd-fuse file system /root/.cache/gvfs
      Output information may be incomplete.
cat: '/sys/module/acp3x_rn/parameters/*': No such file or directory
https://termbin.com/qtf3
User avatar
MrEen
Level 20
Level 20
Posts: 11790
Joined: Mon Jun 12, 2017 8:39 pm

Re: No sound on new install of Mint 20 Cinnamon on zenbook 14 from headphones or speakers; sound cards are detected

Post by MrEen »

Well, my reply may have been quick, but I believe it's going to be some work to get you properly set up for sound. As that first audio driver is something very new, that I hadn't ever seen before this weekend, I think we're going to try to focus on getting the next driver working properly.

First, run pavucontrol and change the Profiles so that one is set to Analog Stereo Duplex, and the other two are set to Off. Test the output after that (I don't expect input to work yet) and assuming there's still no sound give this a try:

Code: Select all

aplay -D hw:1,0 /usr/share/sounds/alsa/Front_Center.wav
Does that produce sound?
User avatar
MrEen
Level 20
Level 20
Posts: 11790
Joined: Mon Jun 12, 2017 8:39 pm

Re: No sound on new install of Mint 20 Cinnamon on zenbook 14 from headphones or speakers; sound cards are detected

Post by MrEen »

I'm going to assume the above didn't work, and want you to run these commands on a hunch:

Code: Select all

sudo su
Enter your password and hit enter:

Code: Select all

echo 1 > /sys/module/snd_hda_codec/parameters/dump_coef

Code: Select all

exit

Code: Select all

wget http://www.alsa-project.org/alsa-info.sh -O alsa-info.sh && bash alsa-info.sh
The last line will start another script running that will ask if you want to upload or save locally. Please choose the upload option and paste the link it'll give you when it finishes.
bubbus
Level 2
Level 2
Posts: 51
Joined: Mon Jul 06, 2020 3:10 pm

Re: No sound on new install of Mint 20 Cinnamon on zenbook 14 from headphones or speakers; sound cards are detected

Post by bubbus »

Running the former code gave me

Code: Select all

ALSA lib pcm.c:2642:(snd_pcm_open_noupdate) Unknown PCM hw1,0
aplay: main:830: audio open error: No such file or directory
Link from the second round of code: http://alsa-project.org/db/?f=fe769f1bf ... 7c37fb7611
User avatar
MrEen
Level 20
Level 20
Posts: 11790
Joined: Mon Jun 12, 2017 8:39 pm

Re: No sound on new install of Mint 20 Cinnamon on zenbook 14 from headphones or speakers; sound cards are detected

Post by MrEen »

Okay, this is a wild guess, but it might at least get the output working. Install alsa-tools so you can run these two commands:

Code: Select all

sudo hda-verb /dev/snd/hwC0D0 0x20 0x500 0x0f

Code: Select all

sudo hda-verb /dev/snd/hwC0D0 0x20 0x477 0x74
Then test the sound. Check for mute/volume level if there's no sound at first.
bubbus
Level 2
Level 2
Posts: 51
Joined: Mon Jul 06, 2020 3:10 pm

Re: No sound on new install of Mint 20 Cinnamon on zenbook 14 from headphones or speakers; sound cards are detected

Post by bubbus »

Still nothing, unfortunately. Here's the code and output:

Code: Select all

karl@Bibbus:~$ sudo hda-verb /dev/snd/hwC0D0 0x20 0x500 0x0f
[sudo] password for karl:            
nid = 0x20, verb = 0x500, param = 0xf
value = 0x0
karl@Bibbus:~$ sudo hda-verb /dev/snd/hwC0D0 0x20 0x477 0x74
nid = 0x20, verb = 0x477, param = 0x74
value = 0x0
User avatar
MrEen
Level 20
Level 20
Posts: 11790
Joined: Mon Jun 12, 2017 8:39 pm

Re: No sound on new install of Mint 20 Cinnamon on zenbook 14 from headphones or speakers; sound cards are detected

Post by MrEen »

Okay, I just found another that might help:

Code: Select all

sudo hda-verb /dev/snd/hwC0D0 0x20 0x500 0x46

Code: Select all

sudo hda-verb /dev/snd/hwC0D0 0x20 0x477 0x0404
User avatar
MrEen
Level 20
Level 20
Posts: 11790
Joined: Mon Jun 12, 2017 8:39 pm

Re: No sound on new install of Mint 20 Cinnamon on zenbook 14 from headphones or speakers; sound cards are detected

Post by MrEen »

And another in case that wasn't enough:

Code: Select all

sudo hda-verb /dev/snd/hwC0D0 0x20 0x500 0x49

Code: Select all

hda-verb /dev/snd/hwC0D0 0x20 0x477 0x0049
User avatar
MrEen
Level 20
Level 20
Posts: 11790
Joined: Mon Jun 12, 2017 8:39 pm

Re: No sound on new install of Mint 20 Cinnamon on zenbook 14 from headphones or speakers; sound cards are detected

Post by MrEen »

And one more:

Code: Select all

sudo hda-verb /dev/snd/hwC0D0 0x20 0x500 0x66

Code: Select all

hda-verb /dev/snd/hwC0D0 0x20 0x477 0x1881
User avatar
MrEen
Level 20
Level 20
Posts: 11790
Joined: Mon Jun 12, 2017 8:39 pm

Re: No sound on new install of Mint 20 Cinnamon on zenbook 14 from headphones or speakers; sound cards are detected

Post by MrEen »

Those are the verbs another zenbook (different model than yours) user had, that got working sound after making a couple of changes. After the last one I posted, your verbs will be identical to his/hers.

If still nothing, we'll need to go in another direction and hope your verbs are fine for your model. Unless you still have Windows on that machine, then we could try to get the Windows verbs to see if other changes are necessary.
bubbus
Level 2
Level 2
Posts: 51
Joined: Mon Jul 06, 2020 3:10 pm

Re: No sound on new install of Mint 20 Cinnamon on zenbook 14 from headphones or speakers; sound cards are detected

Post by bubbus »

Darn, still nothing.

I am dual booting with Windows 10!
User avatar
MrEen
Level 20
Level 20
Posts: 11790
Joined: Mon Jun 12, 2017 8:39 pm

Re: No sound on new install of Mint 20 Cinnamon on zenbook 14 from headphones or speakers; sound cards are detected

Post by MrEen »

bubbus wrote:
Mon Jul 06, 2020 6:30 pm
Darn, still nothing.

I am dual booting with Windows 10!
Okay, I need to find the file that you need to run in Windows. Shouldn't take more than a few minutes.
User avatar
MrEen
Level 20
Level 20
Posts: 11790
Joined: Mon Jun 12, 2017 8:39 pm

Re: No sound on new install of Mint 20 Cinnamon on zenbook 14 from headphones or speakers; sound cards are detected

Post by MrEen »

Found it. Go here and grab the .zip file in the post. Run that in Windows, and find a pasting site like pastebin.com to upload the results to and share the link.
bubbus
Level 2
Level 2
Posts: 51
Joined: Mon Jul 06, 2020 3:10 pm

Re: No sound on new install of Mint 20 Cinnamon on zenbook 14 from headphones or speakers; sound cards are detected

Post by bubbus »

Here ya go: https://pastebin.com/MWLZsV2c

To verify, the speakers and headphones do work well in Windows.
User avatar
MrEen
Level 20
Level 20
Posts: 11790
Joined: Mon Jun 12, 2017 8:39 pm

Re: No sound on new install of Mint 20 Cinnamon on zenbook 14 from headphones or speakers; sound cards are detected

Post by MrEen »

bubbus wrote:
Mon Jul 06, 2020 6:59 pm
To verify, the speakers and headphones do work well in Windows.
Of course they do! The machine was made with Windows in mind. :D

I'm going to start looking through the output now to find the differences between what your Windows uses and what Mint is showing.

However, I should have mentioned to also try shutting down from within Windows before booting into Mint. Sometimes that's enough to get working sound. Also, while in Windows, ensure Fast Startup is turned off. If it wasn't, that might be the whole issue.
User avatar
MrEen
Level 20
Level 20
Posts: 11790
Joined: Mon Jun 12, 2017 8:39 pm

Re: No sound on new install of Mint 20 Cinnamon on zenbook 14 from headphones or speakers; sound cards are detected

Post by MrEen »

Okay, those hda-verb commands are undone with a reboot, which you've obviously had since running the thing in Windows. It's usually not necessary to change everything that is different, and I did notice a couple of specific entries that reminded me of the other thread where the same thing worked so I'll mention them first before looking through the entire output.

Code: Select all

sudo hda-verb /dev/snd/hwC0D0 0x20 0x500 0x1b

Code: Select all

sudo hda-verb /dev/snd/hwC0D0 0x20 0x477 0x4e4b
And

Code: Select all

sudo hda-verb /dev/snd/hwC0D0 0x20 0x500 0x0f

Code: Select all

sudo hda-verb /dev/snd/hwC0D0 0x20 0x477 0x7778
I'm really hoping that might be enough to get the output working.

I don't have time to parse the files tonight then diff them, so I'll show you what I'm working on.

Your Windows list:

Code: Select all

Index 0x00  0x3004
Index 0x01  0xAAAA
Index 0x02  0x88AA
Index 0x03  0x0002
Index 0x04  0xAA09
Index 0x05  0x0700
Index 0x06  0x6110
Index 0x07  0x0200
Index 0x08  0xA807
Index 0x09  0x0021
Index 0x0A  0x7770
Index 0x0B  0x7778
Index 0x0C  0x802B
Index 0x0D  0xA420
Index 0x0E  0x65C0
Index 0x0F  0x7778
Index 0x10  0xC420
Index 0x11  0x7418
Index 0x12  0x6BD0
Index 0x13  0x645F
Index 0x14  0x0400
Index 0x15  0x8CCC
Index 0x16  0x4C50
Index 0x17  0xFF00
Index 0x18  0x0003
Index 0x19  0x2C11
Index 0x1A  0x830B
Index 0x1B  0x4E4B
Index 0x1C  0x0000
Index 0x1D  0x0000
Index 0x1E  0x0000
Index 0x1F  0x0000
Index 0x20  0x51FF
Index 0x21  0x8000
Index 0x22  0x8F00
Index 0x23  0x88F4
Index 0x24  0x0000
Index 0x25  0x0000
Index 0x26  0x0000
Index 0x27  0x0000
Index 0x28  0x0000
Index 0x29  0x3000
Index 0x2A  0x0000
Index 0x2B  0x0000
Index 0x2C  0x0F00
Index 0x2D  0x1F4F
Index 0x2E  0x2902
Index 0x2F  0xE280
Index 0x30  0x1000
Index 0x31  0x8400
Index 0x32  0x5AAA
Index 0x33  0x8423
Index 0x34  0xA20C
Index 0x35  0x096A
Index 0x36  0x5757
Index 0x37  0xFE05
Index 0x38  0x4901
Index 0x39  0x110A
Index 0x3A  0x0010
Index 0x3B  0x60D9
Index 0x3C  0xF214
Index 0x3D  0xC2BA
Index 0x3E  0xA928
Index 0x3F  0x0000
Index 0x40  0x8800
Index 0x41  0x0000
Index 0x42  0x2000
Index 0x43  0x3D90
Index 0x44  0x4900
Index 0x45  0xD689
Index 0x46  0x0404
Index 0x47  0xA47A
Index 0x48  0xD049
Index 0x49  0x0349
Index 0x4A  0x203B
Index 0x4B  0x0777
Index 0x4C  0x065C
Index 0x4D  0x7FFF
Index 0x4E  0x7FFF
Index 0x4F  0x0000
Index 0x50  0x0000
Index 0x51  0x0000
Index 0x52  0xBF5F
Index 0x53  0x3320
Index 0x54  0xCC00
Index 0x55  0x0000
Index 0x56  0x3F00
Index 0x57  0x0000
Index 0x58  0x0000
Index 0x59  0x0000
Index 0x5A  0x1300
Index 0x5B  0x005F
Index 0x5C  0x0000
Index 0x5D  0x1001
Index 0x5E  0x1000
Index 0x5F  0x0000
Index 0x60  0x5554
Index 0x61  0xFFC0
Index 0x62  0xA007
Index 0x63  0xD010
Index 0x64  0x0000
Index 0x65  0x3FB1
Index 0x66  0x1899
Index 0x67  0xC810
Index 0x68  0x2000
Index 0x69  0xFFF0
Index 0x6A  0x0300
Index 0x6B  0x5070
Index 0x6C  0x0000
Index 0x6D  0x0000
Index 0x6E  0x0C25
Index 0x6F  0x0C0B
Index 0x70  0x8000
Index 0x71  0x4008
Index 0x72  0x0000
Index 0x73  0x0800
Index 0x74  0xA28F
Index 0x75  0xA050
Index 0x76  0x7FE8
Index 0x77  0xDB8C
Index 0x78  0x0000
Index 0x79  0x0000
Index 0x7A  0x2A96
Index 0x7B  0x800F
Index 0x7C  0x0200
Index 0x7D  0x1600
Index 0x7E  0x0000
Index 0x7F  0x0000
Index 0x80  0x0000
Index 0x81  0x0000
Your Mint list:

Code: Select all

    Coeff 0x00: 0x3004
    Coeff 0x01: 0xaaaa
    Coeff 0x02: 0x88aa
    Coeff 0x03: 0x0002
    Coeff 0x04: 0xaa09
    Coeff 0x05: 0x0700
    Coeff 0x06: 0x6110
    Coeff 0x07: 0x0200
    Coeff 0x08: 0xa807
    Coeff 0x09: 0x0021
    Coeff 0x0a: 0x7770
    Coeff 0x0b: 0x7778
    Coeff 0x0c: 0x802b
    Coeff 0x0d: 0xa420
    Coeff 0x0e: 0x65c0
    Coeff 0x0f: 0x7774
    Coeff 0x10: 0x0420
    Coeff 0x11: 0x7418
    Coeff 0x12: 0x6bd0
    Coeff 0x13: 0x645f
    Coeff 0x14: 0x0400
    Coeff 0x15: 0x8ccc
    Coeff 0x16: 0x4c50
    Coeff 0x17: 0xff00
    Coeff 0x18: 0x0003
    Coeff 0x19: 0x2c11
    Coeff 0x1a: 0x830b
    Coeff 0x1b: 0x4a4b
    Coeff 0x1c: 0x0000
    Coeff 0x1d: 0x0000
    Coeff 0x1e: 0x0000
    Coeff 0x1f: 0x0000
    Coeff 0x20: 0x51ff
    Coeff 0x21: 0x8000
    Coeff 0x22: 0x8f00
    Coeff 0x23: 0x88f4
    Coeff 0x24: 0x0000
    Coeff 0x25: 0x0000
    Coeff 0x26: 0x0000
    Coeff 0x27: 0x0000
    Coeff 0x28: 0x0000
    Coeff 0x29: 0x3000
    Coeff 0x2a: 0x0000
    Coeff 0x2b: 0x0000
    Coeff 0x2c: 0x0f00
    Coeff 0x2d: 0x1f4f
    Coeff 0x2e: 0x2902
    Coeff 0x2f: 0xe280
    Coeff 0x30: 0x1000
    Coeff 0x31: 0x8400
    Coeff 0x32: 0x5aaa
    Coeff 0x33: 0x8423
    Coeff 0x34: 0xa20c
    Coeff 0x35: 0x096a
    Coeff 0x36: 0x5757
    Coeff 0x37: 0xfe05
    Coeff 0x38: 0x4901
    Coeff 0x39: 0x110a
    Coeff 0x3a: 0x0010
    Coeff 0x3b: 0x60d9
    Coeff 0x3c: 0xf214
    Coeff 0x3d: 0xc2ba
    Coeff 0x3e: 0xa928
    Coeff 0x3f: 0x0000
    Coeff 0x40: 0x8800
    Coeff 0x41: 0x0000
    Coeff 0x42: 0x2000
    Coeff 0x43: 0x3d90
    Coeff 0x44: 0x4900
    Coeff 0x45: 0x5289
    Coeff 0x46: 0x0404
    Coeff 0x47: 0xa47a
    Coeff 0x48: 0xd049
    Coeff 0x49: 0x0349
    Coeff 0x4a: 0x200b
    Coeff 0x4b: 0x0777
    Coeff 0x4c: 0x065c
    Coeff 0x4d: 0x7fff
    Coeff 0x4e: 0x7fff
    Coeff 0x4f: 0x0000
    Coeff 0x50: 0x0000
    Coeff 0x51: 0x0000
    Coeff 0x52: 0xbf5f
    Coeff 0x53: 0x3320
    Coeff 0x54: 0xcc00
    Coeff 0x55: 0x0000
    Coeff 0x56: 0x3f00
    Coeff 0x57: 0x0000
    Coeff 0x58: 0x0000
    Coeff 0x59: 0x0000
    Coeff 0x5a: 0x1300
    Coeff 0x5b: 0x005f
    Coeff 0x5c: 0x0000
    Coeff 0x5d: 0x1001
    Coeff 0x5e: 0x1000
    Coeff 0x5f: 0x0000
    Coeff 0x60: 0x5554
    Coeff 0x61: 0xffc0
    Coeff 0x62: 0xa000
    Coeff 0x63: 0xd010
    Coeff 0x64: 0x0000
    Coeff 0x65: 0x3fb1
    Coeff 0x66: 0x1899
    Coeff 0x67: 0xc810
    Coeff 0x68: 0x2000
    Coeff 0x69: 0xfff0
    Coeff 0x6a: 0x0300
    Coeff 0x6b: 0x5078
    Coeff 0x6c: 0x0000
    Coeff 0x6d: 0x0000
    Coeff 0x6e: 0x0c25
    Coeff 0x6f: 0x0c0b
    Coeff 0x70: 0x8000
    Coeff 0x71: 0x4008
    Coeff 0x72: 0x0000
    Coeff 0x73: 0x0800
    Coeff 0x74: 0xa28f
    Coeff 0x75: 0xa050
    Coeff 0x76: 0x7fe8
    Coeff 0x77: 0xdb8c
    Coeff 0x78: 0x0000
    Coeff 0x79: 0x0000
    Coeff 0x7a: 0x2a96
    Coeff 0x7b: 0x800f
    Coeff 0x7c: 0x0200
    Coeff 0x7d: 0x1600
    Coeff 0x7e: 0x0000
    Coeff 0x7f: 0x0000
    Coeff 0x80: 0x0000
    Coeff 0x81: 0x0000
What we do is find the differences, such as 0x1b is 0x4E4B in Windows, but Mint has it as 0x4a4b. The two commands for each difference are first the coeff we want to change:

Code: Select all

sudo hda-verb /dev/snd/hwC0D0 0x20 0x500 0x1b
Then the new value to use:

Code: Select all

sudo hda-verb /dev/snd/hwC0D0 0x20 0x477 0x4e4b
It's also more complicated by the fact Windows uses caps for letters, while Linux doesn't. It might not make a difference, but I know the lower case works when the values are correct.

I'll check in tomorrow and if necessary, output the code for all the changes to match up with the Windows output. Again, a reboot undoes it all. If we find a working config, we'll script something up to automate the task on each boot.
User avatar
MrEen
Level 20
Level 20
Posts: 11790
Joined: Mon Jun 12, 2017 8:39 pm

Re: No sound on new install of Mint 20 Cinnamon on zenbook 14 from headphones or speakers; sound cards are detected

Post by MrEen »

My command fu is improving and as a result I have the list of all that might need changes besides the 2 I mentioned in the last post. Here're the others:

Code: Select all

0x10 0xc420
0x45 0xd689
0x4a 0x203b
0x62 0xa007
0x6b 0x5070
So the sequence is:

Code: Select all

sudo hda-verb /dev/snd/hwC0D0 0x20 0x500 0x10

Code: Select all

sudo hda-verb /dev/snd/hwC0D0 0x20 0x477 0xc420
Then:

Code: Select all

sudo hda-verb /dev/snd/hwC0D0 0x20 0x500 0x45

Code: Select all

sudo hda-verb /dev/snd/hwC0D0 0x20 0x477 0xd689
Then:

Code: Select all

sudo hda-verb /dev/snd/hwC0D0 0x20 0x500 0x4a

Code: Select all

sudo hda-verb /dev/snd/hwC0D0 0x20 0x477 0x203b
Then:

Code: Select all

sudo hda-verb /dev/snd/hwC0D0 0x20 0x500 0x62

Code: Select all

sudo hda-verb /dev/snd/hwC0D0 0x20 0x477 0xa007
And finally:

Code: Select all

sudo hda-verb /dev/snd/hwC0D0 0x20 0x500 0x6b

Code: Select all

sudo hda-verb /dev/snd/hwC0D0 0x20 0x477 0x5070
I do hope some combination of these gets your sound working!

Off to bed now. I'll check in after work tomorrow.
bubbus
Level 2
Level 2
Posts: 51
Joined: Mon Jul 06, 2020 3:10 pm

Re: No sound on new install of Mint 20 Cinnamon on zenbook 14 from headphones or speakers; sound cards are detected

Post by bubbus »

Morning! I tried all the value changes and still nothing, unfortunately. I went through the two lists as well and did not find any differences besides the ones you'd already shown.

One thing I noticed is that on all of the outputs for the commands, it shows value=0x0. For example, for

Code: Select all

sudo hda-verb /dev/snd/hwC0D0 0x20 0x477 0x4e4b
I get

Code: Select all

nid = 0x20, verb = 0x477, param = 0x4e4b
value = 0x0
This is the case after all command inputs. Not sure if it's actually an issue, just seemed weird to me if I am trying to change the value at the given position.
Post Reply

Return to “Hardware Support”