<SOLVED> No sound on new install of Mint 20 Cinnamon on zenbook 14 from headphones or speakers; sound cards are detected

Questions about hardware,drivers and peripherals
Forum rules
Before you post please read how to get help
bubbus
Level 2
Level 2
Posts: 51
Joined: Mon Jul 06, 2020 3:10 pm

Re: No sound on new install of Mint 20 Cinnamon on zenbook 14 from headphones or speakers; sound cards are detected

Post by bubbus »

woops. still no sound after the correct code though
asinoro
Level 5
Level 5
Posts: 896
Joined: Mon Feb 12, 2018 11:43 am

Re: No sound on new install of Mint 20 Cinnamon on zenbook 14 from headphones or speakers; sound cards are detected

Post by asinoro »

You continue the troubleshooting with MrEen, and if I find something else I will inform you!
bubbus
Level 2
Level 2
Posts: 51
Joined: Mon Jul 06, 2020 3:10 pm

Re: No sound on new install of Mint 20 Cinnamon on zenbook 14 from headphones or speakers; sound cards are detected

Post by bubbus »

Currently booting from a live USB of Manjaro and still no sound!
User avatar
MrEen
Level 20
Level 20
Posts: 11790
Joined: Mon Jun 12, 2017 8:39 pm

Re: No sound on new install of Mint 20 Cinnamon on zenbook 14 from headphones or speakers; sound cards are detected

Post by MrEen »

I won't bother with the expletive-laced tirade I'd like to type right now!

If you're still running Manjaro when you see this, play a song and run pacmd list-sinks. Paste that output along with the big dmesg one:

Code: Select all

dmesg | grep -C1 -E 'ALSA|HDA|sof|HDMI|snd[_-]|sound|hda.codec|hda.intel'
bubbus
Level 2
Level 2
Posts: 51
Joined: Mon Jul 06, 2020 3:10 pm

Re: No sound on new install of Mint 20 Cinnamon on zenbook 14 from headphones or speakers; sound cards are detected

Post by bubbus »

Haha, sorry it's so frustrating!
pacmd gives

Code: Select all

[manjaro@manjaro ~]$ pacmd list-sinks
1 sink(s) available.
  * index: 0
	name: <alsa_output.pci-0000_03_00.6.analog-stereo>
	driver: <module-alsa-card.c>
	flags: HARDWARE HW_MUTE_CTRL HW_VOLUME_CTRL DECIBEL_VOLUME LATENCY 
	state: RUNNING
	suspend cause: (none)
	priority: 9039
	volume: front-left: 65536 / 100% / 0.00 dB,   front-right: 65536 / 100% / 0.00 dB
	        balance 0.00
	base volume: 65536 / 100% / 0.00 dB
	volume steps: 65537
	muted: no
	current latency: 100.83 ms
	max request: 17 KiB
	max rewind: 17 KiB
	monitor source: 0
	sample spec: s16le 2ch 44100Hz
	channel map: front-left,front-right
	             Stereo
	used by: 1
	linked by: 3
	fixed latency: 100.14 ms
	card: 1 <alsa_card.pci-0000_03_00.6>
	module: 7
	properties:
		alsa.resolution_bits = "16"
		device.api = "alsa"
		device.class = "sound"
		alsa.class = "generic"
		alsa.subclass = "generic-mix"
		alsa.name = "ALC294 Analog"
		alsa.id = "ALC294 Analog"
		alsa.subdevice = "0"
		alsa.subdevice_name = "subdevice #0"
		alsa.device = "0"
		alsa.card = "1"
		alsa.card_name = "HD-Audio Generic"
		alsa.long_card_name = "HD-Audio Generic at 0xfe7c0000 irq 65"
		alsa.driver_name = "snd_hda_intel"
		device.bus_path = "pci-0000:03:00.6"
		sysfs.path = "/devices/pci0000:00/0000:00:08.1/0000:03:00.6/sound/card1"
		device.bus = "pci"
		device.vendor.id = "1022"
		device.vendor.name = "Advanced Micro Devices, Inc. [AMD]"
		device.product.id = "15e3"
		device.product.name = "Family 17h (Models 10h-1fh) HD Audio Controller"
		device.string = "front:1"
		device.buffering.buffer_size = "17664"
		device.buffering.fragment_size = "2944"
		device.access_mode = "mmap"
		device.profile.name = "analog-stereo"
		device.profile.description = "Analog Stereo"
		device.description = "Family 17h (Models 10h-1fh) HD Audio Controller Analog Stereo"
		alsa.mixer_name = "Realtek ALC294"
		alsa.components = "HDA:10ec0294,10431b71,00100004"
		module-udev-detect.discovered = "1"
		device.icon_name = "audio-card-pci"
	ports:
		analog-output-speaker: Speakers (priority 10000, latency offset 0 usec, available: unknown)
			properties:
				device.icon_name = "audio-speakers"
		analog-output-headphones: Headphones (priority 9900, latency offset 0 usec, available: no)
			properties:
				device.icon_name = "audio-headphones"
	active port: <analog-output-speaker>
dmesg gives

Code: Select all

[manjaro@manjaro ~]$ sudo dmesg | grep -C1 -E 'ALSA|HDA|sof|HDMI|snd[_-]|sound|hda.codec|hda.intel'
[    0.626526] ACPI: Added _OSI(Linux-Dell-Video)
[    0.626527] ACPI: Added _OSI(Linux-Lenovo-NV-HDMI-Audio)
[    0.626528] ACPI: Added _OSI(Linux-HPI-Hybrid-Graphics)
--
[    6.342205] random: fast init done
[    6.893448] ISO 9660 Extensions: Microsoft Joliet Level 3
[    6.895882] ISO 9660 Extensions: RRIP_1991A
--
[    9.847729] i2c_hid i2c-ELAN1206:00: i2c-ELAN1206:00 supply vddl not found, using dummy regulator
[    9.913425] snd_pci_acp3x 0000:03:00.5: enabling device (0000 -> 0002)
[    9.914016] snd_pci_acp3x 0000:03:00.5: Invalid ACP audio mode : 2
[    9.914577] input: PC Speaker as /devices/platform/pcspkr/input/input4
--
[   10.052698] audit: type=1400 audit(1594326515.612:11): apparmor="STATUS" operation="profile_load" profile="unconfined" name="/usr/lib/snapd/snap-confine" pid=504 comm="apparmor_parser"
[   10.228772] snd_hda_intel 0000:03:00.1: enabling device (0000 -> 0002)
[   10.228873] snd_hda_intel 0000:03:00.1: Handle vga_switcheroo audio client
[   10.229011] snd_hda_intel 0000:03:00.6: enabling device (0000 -> 0002)
[   10.320802] input: HD-Audio Generic HDMI/DP,pcm=3 as /devices/pci0000:00/0000:00:08.1/0000:03:00.1/sound/card0/input6
[   10.341252] iwlwifi 0000:01:00.0: Found debug destination: EXTERNAL_DRAM
--
[   10.342005] iwlwifi 0000:01:00.0: loaded firmware version 36.79ff3ccf.0 8265-36.ucode op_mode iwlmvm
[   10.389151] snd_hda_codec_realtek hdaudioC1D0: autoconfig for ALC294: line_outs=1 (0x17/0x0/0x0/0x0/0x0) type:speaker
[   10.389154] snd_hda_codec_realtek hdaudioC1D0:    speaker_outs=0 (0x0/0x0/0x0/0x0/0x0)
[   10.389155] snd_hda_codec_realtek hdaudioC1D0:    hp_outs=1 (0x21/0x0/0x0/0x0/0x0)
[   10.389157] snd_hda_codec_realtek hdaudioC1D0:    mono: mono_out=0x0
[   10.389158] snd_hda_codec_realtek hdaudioC1D0:    inputs:
[   10.389159] snd_hda_codec_realtek hdaudioC1D0:      Headset Mic=0x19
[   10.389161] snd_hda_codec_realtek hdaudioC1D0:      Internal Mic=0x12
[   10.391049] kvm: Nested Virtualization enabled
--
[   10.787200] EDAC amd64: Node 0: DRAM ECC disabled.
[   10.787244] input: HD-Audio Generic Headset Mic as /devices/pci0000:00/0000:00:08.1/0000:03:00.6/sound/card1/input11
[   10.787305] input: HD-Audio Generic Headphone as /devices/pci0000:00/0000:00:08.1/0000:03:00.6/sound/card1/input12
[   10.820596] EDAC amd64: F17h_M10h detected (node 0).
--
[   11.323844] [drm] Display Core initialized with v3.2.69!
[   11.341544] snd_hda_intel 0000:03:00.1: bound 0000:03:00.0 (ops amdgpu_dm_audio_component_bind_ops [amdgpu])
[   11.351328] [drm] Supports vblank timestamp caching Rev 2 (21.10.2013).
--
[   12.115646] uvcvideo: Found UVC 1.50 device USB2.0 HD IR UVC WebCam (13d3:56cb)
[   12.124674] uvcvideo 3-2:1.0: Entity type for entity Microsoft Extended Controls Uni was not initialized!
[   12.124679] uvcvideo 3-2:1.0: Entity type for entity Realtek Extended Controls Unit was not initialized!
--
[   12.126147] uvcvideo: Found UVC 1.50 device USB2.0 HD IR UVC WebCam (13d3:56cb)
[   12.129670] uvcvideo 3-2:1.2: Entity type for entity Microsoft Extended Controls Uni was not initialized!
[   12.129674] uvcvideo 3-2:1.2: Entity type for entity Extension 9 was not initialized!
One difference I noticed was that in the Manjaro volume control (which looks to basically just be the same as pavucontrol in Mint) there are only 2 sound cards detected compared to the 3 in Mint.

By the way, thanks for all the help!!
User avatar
MrEen
Level 20
Level 20
Posts: 11790
Joined: Mon Jun 12, 2017 8:39 pm

Re: No sound on new install of Mint 20 Cinnamon on zenbook 14 from headphones or speakers; sound cards are detected

Post by MrEen »

bubbus wrote:
Thu Jul 09, 2020 4:39 pm

One difference I noticed was that in the Manjaro volume control (which looks to basically just be the same as pavucontrol in Mint) there are only 2 sound cards detected compared to the 3 in Mint.

By the way, thanks for all the help!!
You're quite welcome. I learn stuff as well helping with this so I never consider it a waste of time.

Strange that Manjaro is only listing 2 devices, when the dmesg output shows stuff for all 3 just like Mint does. Maybe the ACP error causes it to not show that one? Just guessing.

I'm afraid that whole test wasn't helpful at all. We got nothing new to hopefully be able to work with.

I'm going to have to find something sneaky to try, but it'll be back on Mint, so whenever you're done playing with Manjaro, you can shut it down. It'll probably be an hour or two before I come up with a new tactic.
bubbus
Level 2
Level 2
Posts: 51
Joined: Mon Jul 06, 2020 3:10 pm

Re: No sound on new install of Mint 20 Cinnamon on zenbook 14 from headphones or speakers; sound cards are detected

Post by bubbus »

*thumbs up emoji*
User avatar
MrEen
Level 20
Level 20
Posts: 11790
Joined: Mon Jun 12, 2017 8:39 pm

Re: No sound on new install of Mint 20 Cinnamon on zenbook 14 from headphones or speakers; sound cards are detected

Post by MrEen »

Here's my first idea. Let's get PulseAudio out of the way and see if ALSA is able to work on it's own.

Run these one line at a time:

Code: Select all

tee ~/.config/pulse/client.conf <<<'autospawn = no'
pulseaudio -k
sudo fuser -v /dev/snd/*
aplay -D hw:2,0 /usr/share/sounds/alsa/Front_Center.wav
The fuser line is to make sure there's nothing ending with "pulseaudio" and if the aplay command errors like last time, check dmesg | grep snd to see which sound card we should be using.
User avatar
MrEen
Level 20
Level 20
Posts: 11790
Joined: Mon Jun 12, 2017 8:39 pm

Re: No sound on new install of Mint 20 Cinnamon on zenbook 14 from headphones or speakers; sound cards are detected

Post by MrEen »

And I'm already working on the next idea. I'll post it now, but don't run this stuff until after I've seen the results of the above.

First, let's undo the pulseaudio change with rm ~/.config/pulse/client.conf

Next. we'll try to force the new audio driver to load with this command:

Code: Select all

sudo tee /etc/modprobe.d/alsa-fix.conf <<<'options snd-intel-dspcfg dsp_driver=3'
Now reboot and run the dmesg command and paste the output:

Code: Select all

dmesg | grep -C1 -E 'ALSA|HDA|sof|HDMI|snd[_-]|sound|hda.codec|hda.intel'
bubbus
Level 2
Level 2
Posts: 51
Joined: Mon Jul 06, 2020 3:10 pm

Re: No sound on new install of Mint 20 Cinnamon on zenbook 14 from headphones or speakers; sound cards are detected

Post by bubbus »

Code: Select all

karl@Bibbus:~$ tee ~/.config/pulse/client.conf <<<'autospawn = no'
autospawn = no
karl@Bibbus:~$ pulseaudio -k
karl@Bibbus:~$ sudo fuser -v /dev/snd/*
                     USER        PID ACCESS COMMAND
/dev/snd/controlC0:  karl       2854 F.... pulseaudio
/dev/snd/controlC1:  karl       2854 F.... pulseaudio
karl@Bibbus:~$ aplay -D hw:2,0 /usr/share/sounds/alsa/Front_Center.wav
aplay: main:830: audio open error: No such file or directory
and for dmesg:

Code: Select all

karl@Bibbus:~$ dmesg | grep snd
[    3.036879] snd_pci_acp3x 0000:03:00.5: enabling device (0000 -> 0002)
[    3.037085] snd_pci_acp3x 0000:03:00.5: Invalid ACP audio mode : 2
[    3.360929] snd_hda_intel 0000:03:00.1: enabling device (0000 -> 0002)
[    3.361016] snd_hda_intel 0000:03:00.1: Handle vga_switcheroo audio client
[    3.361153] snd_hda_intel 0000:03:00.6: enabling device (0000 -> 0002)
[    3.367013] snd_hda_intel 0000:03:00.1: bound 0000:03:00.0 (ops amdgpu_dm_audio_component_bind_ops [amdgpu])
[    3.376380] acp_pdm_mach acp_pdm_mach.0: snd_soc_register_card(acp) failed: -517
[    3.382659] snd_hda_codec_realtek hdaudioC1D0: autoconfig for ALC294: line_outs=1 (0x17/0x0/0x0/0x0/0x0) type:speaker
[    3.382662] snd_hda_codec_realtek hdaudioC1D0:    speaker_outs=0 (0x0/0x0/0x0/0x0/0x0)
[    3.382670] snd_hda_codec_realtek hdaudioC1D0:    hp_outs=1 (0x21/0x0/0x0/0x0/0x0)
[    3.382672] snd_hda_codec_realtek hdaudioC1D0:    mono: mono_out=0x0
[    3.382673] snd_hda_codec_realtek hdaudioC1D0:    inputs:
[    3.382674] snd_hda_codec_realtek hdaudioC1D0:      Headset Mic=0x19
[    3.382675] snd_hda_codec_realtek hdaudioC1D0:      Internal Mic=0x12
User avatar
MrEen
Level 20
Level 20
Posts: 11790
Joined: Mon Jun 12, 2017 8:39 pm

Re: No sound on new install of Mint 20 Cinnamon on zenbook 14 from headphones or speakers; sound cards are detected

Post by MrEen »

Okay. Looks like we need to reboot first, to get pulseaudio fully out of the way.

If dmesg looks the same after the reboot, the aplay command will be:

Code: Select all

aplay -D hw:1,0 /usr/share/sounds/alsa/Front_Center.wav
bubbus
Level 2
Level 2
Posts: 51
Joined: Mon Jul 06, 2020 3:10 pm

Re: No sound on new install of Mint 20 Cinnamon on zenbook 14 from headphones or speakers; sound cards are detected

Post by bubbus »

ugh, that stupid failure to boot has showed up again. tried booting to the older kernel this time but it did not work. gimme a bit because I have no clue how or when this will resolve
User avatar
MrEen
Level 20
Level 20
Posts: 11790
Joined: Mon Jun 12, 2017 8:39 pm

Re: No sound on new install of Mint 20 Cinnamon on zenbook 14 from headphones or speakers; sound cards are detected

Post by MrEen »

Understood. Sorry this has been such an experience!
User avatar
MrEen
Level 20
Level 20
Posts: 11790
Joined: Mon Jun 12, 2017 8:39 pm

Re: No sound on new install of Mint 20 Cinnamon on zenbook 14 from headphones or speakers; sound cards are detected

Post by MrEen »

In case you check in before being able to boot into Mint, do check your BIOS for any audio settings during this downtime. You might be able to change HDAudio to AC97 for example. Making that change might get your sound working. Just something to check, but this isn't required.

Also, if Secure Boot is enabled in the BIOS, see if disabling it makes any difference. This might both get you back into Mint, and potentially get your sound working as well. Not terribly likely for the sound, but there's a chance.
bubbus
Level 2
Level 2
Posts: 51
Joined: Mon Jul 06, 2020 3:10 pm

Re: No sound on new install of Mint 20 Cinnamon on zenbook 14 from headphones or speakers; sound cards are detected

Post by bubbus »

THE SOUND WORKS


holy hell


this

Code: Select all

tee ~/.config/pulse/client.conf <<<'autospawn = no'
pulseaudio -k
sudo fuser -v /dev/snd/*
aplay -D hw:2,0 /usr/share/sounds/alsa/Front_Center.wav
was the last thing I did before rebooting. Wild. THANKS :D

Also I think the boot issue may have something to do with whether or not the power cable is plugged in. Gotta try again to make sure, but it did not boot when it was unplugged and did after I plugged it in
User avatar
MrEen
Level 20
Level 20
Posts: 11790
Joined: Mon Jun 12, 2017 8:39 pm

Re: No sound on new install of Mint 20 Cinnamon on zenbook 14 from headphones or speakers; sound cards are detected

Post by MrEen »

Okay, then I'm suspecting you're one of the few that are affected by the most recent update to PulseAudio. It might not be a Zenbook issue after all, though it still might be to some extent.

Let me see the output of apt policy pulseaudio please, and maybe we can reload the previous version and see if it works with your system.
bubbus
Level 2
Level 2
Posts: 51
Joined: Mon Jul 06, 2020 3:10 pm

Re: No sound on new install of Mint 20 Cinnamon on zenbook 14 from headphones or speakers; sound cards are detected

Post by bubbus »

Code: Select all

karl@Bibbus:~$ apt policy pulseaudio
pulseaudio:
  Installed: 1:13.99.1-1ubuntu3.3
  Candidate: 1:13.99.1-1ubuntu3.3
  Version table:
 *** 1:13.99.1-1ubuntu3.3 500
        500 http://archive.ubuntu.com/ubuntu focal-updates/main amd64 Packages
        100 /var/lib/dpkg/status
     1:13.99.1-1ubuntu3.2 500
        500 http://security.ubuntu.com/ubuntu focal-security/main amd64 Packages
     1:13.99.1-1ubuntu3 500
        500 http://archive.ubuntu.com/ubuntu focal/main amd64 Packages
User avatar
MrEen
Level 20
Level 20
Posts: 11790
Joined: Mon Jun 12, 2017 8:39 pm

Re: No sound on new install of Mint 20 Cinnamon on zenbook 14 from headphones or speakers; sound cards are detected

Post by MrEen »

I have to head to bed.

Tomorrow we'll get the rest of this sorted out. In /var/log/apt/history.log see if the pulseaudio update is listed in there. Just open the files and Ctrl+F to search for pulseaudio should work. It may have rolled over into one of the .gz files already, but I'll need to find out what the older version was so we can undo the newer one.
Post Reply

Return to “Hardware Support”