rcu_sched detected stalls on CPUs/tasks

Questions about hardware,drivers and peripherals
Forum rules
Before you post please read how to get help
Post Reply
secureIT
Level 4
Level 4
Posts: 287
Joined: Wed Dec 05, 2018 1:26 pm

rcu_sched detected stalls on CPUs/tasks

Post by secureIT »

Hi,

I am on LM 20 Xfce

After LM 20 Xfce had worked very well for days, today I had the following error messages when starting up the system:

The messages started with the first 2 lines (see below).

Then a blinking cursor appeared ...... and nothing happened for about 3 minutes ...... until the next 2 lines.

And then again about 3 minutes ..... and the next 2 lines were displayed.

After another 3 minutes - and the next messages I did a hard reset.

When restarting everything was "normal again - as always ... without problems"

Due to the hard reset I unfortunately have no entries in the log file.

So I can only post a transcript of a screenshot:

Code: Select all

[   61.239828] rcu: INFO: rcu_sched detected stalls on CPUs/tasks:
[   61.239849] rcu: o1-...!: (0 ticks GP) idle=940/0/0x0 softirq=191/191 fqs=0
[   61.240857] rcu: rcu_sched kthread starved for 15002 jiffies! g-871 f0x0 RCU_GP_WAIT_FQS(5) ->state=0x402 ->cpu=1
[   61.240861] rcu: RCU grace-period kthread stack dump:
[  241.259826] rcu: INFO: rcu_sched detected stalls on CPUs/tasks:
[  241.260149] rcu: o1-...!: (0 ticks this GP) idle=8d4/0/0x0 softirq=191/191 fqs=1
[  241.261944] rcu: rcu_sched kthread starved for 45005 jiffies! g-871 f0x0 RCU_GP_WAIT_FQS(5) ->state=0x402 ->cpu=1 
[  301.267828] rcu: INFO: rcu_sched detected stalls on CPUs/tasks:
[  301.268150] rcu: o1-...!: (0 ticks this GP) idle=8c0/0/0x0 softirq=191/191 fqs=0
[  301.269484] rcu: rcu_sched kthread starved for 15002 jiffies! g-867 f0x0 RCU_GP_WAIT_FQS(5) ->state=0x402 ->cpu=1
[  301.269945] rcu: RCU grace-period kthread stack dump:

And now the question arises:

What was that ?

Is it a kernel- or hardware problem?

Although I have often been able to solve other problems myself, I have real difficulties interpreting these messages.

I would be very grateful for tips on where to start with a possible troubleshooting ........
.
RetiredTech
Level 1
Level 1
Posts: 2
Joined: Mon Jul 13, 2020 11:47 am

Re: rcu_sched detected stalls on CPUs/tasks

Post by RetiredTech »

I had the same problem this morning. About three days ago I performed a clean install of LM20 on a new hard drive partition, all this on a 10 year old Gateway/Acer. I still run LM19.3 on a different partition. All has worked fine since the install. Today, my PC started itself in the middle of the night, which is a separate, ongoing issue I haven't resolved yet. By the time I arrived at my desk, the kernel had been looping for perhaps hours. Basically, the screen looked much like yours. It's interesting that we are both experiencing such an issue shortly after upgrading to LM20. After a cold boot, the system is back to normal operation, and I'm left wondering what's going on. Below is a photo of the screen taken with my cell phone.
Screen photo of semi-frozen kernel loop.
Screen photo of semi-frozen kernel loop.
Post Reply

Return to “Hardware Support”