Sound in Toshiba VA-100 with HD intel sound not working

Questions about hardware,drivers and peripherals
Forum rules
Before you post please read how to get help
Level 3
Level 3
Posts: 119
Joined: Mon Jun 04, 2007 4:04 pm

Sound in Toshiba VA-100 with HD intel sound not working

Postby Christof999 » Fri Jun 15, 2007 9:17 am

Hi there,

I cannot get my sound to work under cassandra. The sound card seems to be detected but the speaker in the corner of the desktop is off. When I try to do a sound test under control center ===> Sound Preferences, I Get nothing but an error.

audiotestsrc wave=sine freq=512 ! audioconvert ! audioresample ! gconfaudiosink: Could not open resource for writing.

Can someone please help me with this ?

I have a Toshiba Satelitte VA-100, with on board High Def Intel sound. I recently ran suse 10.2 and the sound worked out of the box, so I know its possible. Doing an lsmod | grep snd gives this.

snd_hda_intel 21912 0
snd_hda_codec 205440 1 snd_hda_intel
snd_pcm_oss 44544 0
snd_mixer_oss 17408 1 snd_pcm_oss
snd_pcm 79876 3 snd_hda_intel,snd_hda_codec,snd_pcm_oss
snd_seq_dummy 4740 0
snd_seq_oss 32896 0
snd_seq_midi 9600 0
snd_rawmidi 25472 1 snd_seq_midi
snd_seq_midi_event 8448 2 snd_seq_oss,snd_seq_midi
snd_seq 52592 6 snd_seq_dummy,snd_seq_oss,snd_seq_midi,snd_seq_midi_event
snd_timer 23684 2 snd_pcm,snd_seq
snd_seq_device 9100 5 snd_seq_dummy,snd_seq_oss,snd_seq_midi,snd_rawmidi,snd_seq
snd 54020 10 snd_hda_intel,snd_hda_codec,snd_pcm_oss,snd_mixer_oss,snd_pcm,snd_seq_oss,snd_rawmidi,snd_seq,snd_timer,snd_seq_device
soundcore 8672 1 snd
snd_page_alloc 10888 2 snd_hda_intel,snd_pcm

Any help appreciated.


Level 23
Level 23
Posts: 18703
Joined: Sun Feb 11, 2007 7:22 am
Location: Near Borås Sweden

Postby Husse » Fri Jun 15, 2007 1:04 pm

H ere's another Toshiba with sond problem
I'm not at home now - on a rather sloppy laptop with Windows :)
You can't convince everyone :)
So I haven't read the post
Don't fix it if it ain't broken, don't break it if you can't fix it

Level 1
Level 1
Posts: 1
Joined: Mon Jun 18, 2007 1:50 pm
Location: Lisbon / Portugal

Postby Mektub » Mon Jun 18, 2007 2:09 pm

I have a Toshiba Laptop P100-332.

lspci gives for the sound card:

00:1b.0 Audio device: Intel Corporation 82801G (ICH7 Family) High Definition Audio Controller (rev 02)

I couldn't get any sound out of it with Fedora FC7, Ubuntu Feisty or Mint.

I followed several proposed solutions for similar problems in several forums, mainly Ubuntu.

None worked for me.

The solution that worked for me in all the above distributions was to set acpi=off on the load kernel line in Grub.

Of course, you loose acpi. :shock:


Level 1
Level 1
Posts: 2
Joined: Mon Aug 13, 2007 6:28 pm

Postby sacasaca » Mon Aug 13, 2007 6:36 pm

Do you have the modem disabled in the bios? I had the modem disabled on my IBM laptop and the sound would not work. I enabled it and now the sound more errors.
I tried a few different distros before I found out about the disabled modem breaking the sound and had no luck with any of them.

Return to “Hardware Support”