Wifi driver won't 100% work in Linux mint 20

Questions about hardware,drivers and peripherals
Forum rules
Before you post please read how to get help
Post Reply
javibg6
Level 1
Level 1
Posts: 11
Joined: Wed Dec 12, 2018 4:21 am

Wifi driver won't 100% work in Linux mint 20

Post by javibg6 »

Hey people!

I upgraded some weeks ago to Linux mint 20, with new kernel. My laptop now works perfectly, but there's one specific wifi network i can't connect to, but with Linux mint 19.3 there was no problem.


When i launch the command to get to know the wifi driver, i get the same result in Linux mint 20 and with Linux mint 19.3, but with this last one i can connect to this wifi network. There's an image attached to this thread with those results.

What can i do? Can i change some configuration somewhere to make this hardware work as it used to, with the same exact driver?

Thanks in advance!
Attachments
Wifi.png
sleeper12
Level 12
Level 12
Posts: 4175
Joined: Thu May 25, 2017 3:22 pm

Re: Wifi driver won't 100% work in Linux mint 20

Post by sleeper12 »

Post your system details:

Code: Select all

 inxi -Fxxxz && rfkill list && mokutil --sb-state 
javibg6
Level 1
Level 1
Posts: 11
Joined: Wed Dec 12, 2018 4:21 am

Re: Wifi driver won't 100% work in Linux mint 20

Post by javibg6 »

Sure! Thanks for replying. Here they are:

System:
Kernel: 5.4.0-47-generic x86_64 bits: 64 compiler: gcc v: 9.3.0
Desktop: Cinnamon 4.6.7 wm: muffin 4.6.3 dm: LightDM 1.30.0
Distro: Linux Mint 20 Ulyana base: Ubuntu 20.04 focal
Machine:
Type: Laptop System: ASUSTeK product: UX32VD v: 1.0 serial: <filter>
Mobo: ASUSTeK model: UX32VD v: 1.0 serial: <filter>
UEFI: American Megatrends v: UX32VD.213 date: 11/16/2012
Battery:
ID-1: BAT0 charge: 30.1 Wh condition: 30.1/48.2 Wh (62%) volts: 7.4/7.4
model: ASUSTeK UX32-65 type: Li-ion serial: <filter> status: Full
cycles: 481
CPU:
Topology: Dual Core model: Intel Core i5-3317U bits: 64 type: MT MCP
arch: Ivy Bridge rev: 9 L2 cache: 3072 KiB
flags: avx lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 13569
Speed: 935 MHz min/max: 800/2600 MHz Core speeds (MHz): 1: 809 2: 809
3: 868 4: 810
Graphics:
Device-1: Intel 3rd Gen Core processor Graphics vendor: ASUSTeK
driver: i915 v: kernel bus ID: 00:02.0 chip ID: 8086:0166
Device-2: NVIDIA GF117M [GeForce 610M/710M/810M/820M / GT
620M/625M/630M/720M]
vendor: ASUSTeK driver: nouveau v: kernel bus ID: 01:00.0
chip ID: 10de:1140
Display: x11 server: X.Org 1.20.8 driver: modesetting unloaded: fbdev,vesa
resolution: 1366x768~60Hz
OpenGL: renderer: Mesa DRI Intel HD Graphics 4000 (IVB GT2)
v: 4.2 Mesa 20.0.8 compat-v: 3.0 direct render: Yes
Audio:
Device-1: Intel 7 Series/C216 Family High Definition Audio vendor: ASUSTeK
driver: snd_hda_intel v: kernel bus ID: 00:1b.0 chip ID: 8086:1e20
Sound Server: ALSA v: k5.4.0-47-generic
Network:
Device-1: Intel Centrino Advanced-N 6235 driver: iwlwifi v: kernel
port: e000 bus ID: 03:00.0 chip ID: 8086:088e
IF: wlp3s0 state: up mac: <filter>
Drives:
Local Storage: total: 953.88 GiB used: 265.44 GiB (27.8%)
ID-1: /dev/sda vendor: Crucial model: CT1000BX500SSD1 size: 931.51 GiB
speed: 6.0 Gb/s serial: <filter> rev: 030 scheme: GPT
ID-2: /dev/sdb vendor: SanDisk model: SSD i100 24GB size: 22.37 GiB
speed: 6.0 Gb/s serial: <filter> rev: 0.02 scheme: GPT
Partition:
ID-1: / size: 48.74 GiB used: 14.36 GiB (29.5%) fs: ext4 dev: /dev/sda6
ID-2: /home size: 259.96 GiB used: 56.30 GiB (21.7%) fs: ext4
dev: /dev/sda7
ID-3: swap-1 size: 22.36 GiB used: 21.5 MiB (0.1%) fs: swap dev: /dev/sdb1
Sensors:
System Temperatures: cpu: 63.0 C mobo: N/A gpu: nouveau temp: 63 C
Fan Speeds (RPM): cpu: 3400
Info:
Processes: 267 Uptime: 4h 45m Memory: 9.62 GiB used: 4.64 GiB (48.2%)
Init: systemd v: 245 runlevel: 5 Compilers: gcc: 9.3.0 alt: 9 Shell: bash
v: 5.0.17 running in: gnome-terminal inxi: 3.0.38
0: phy0: Wireless LAN
Soft blocked: no
Hard blocked: no
1: hci0: Bluetooth
Soft blocked: no
Hard blocked: no
sleeper12
Level 12
Level 12
Posts: 4175
Joined: Thu May 25, 2017 3:22 pm

Re: Wifi driver won't 100% work in Linux mint 20

Post by sleeper12 »

You could try #2.4 here for the iwlwifi driver:
https://easylinuxtipsproject.blogspot.c ... html#ID2.4
javibg6
Level 1
Level 1
Posts: 11
Joined: Wed Dec 12, 2018 4:21 am

Re: Wifi driver won't 100% work in Linux mint 20

Post by javibg6 »

Hi! I already tried that before, and it didn't work out.. I've tried again, to double check it was the same command, but i still have no results.

What else can i try? Thanks!!
sleeper12
Level 12
Level 12
Posts: 4175
Joined: Thu May 25, 2017 3:22 pm

Re: Wifi driver won't 100% work in Linux mint 20

Post by sleeper12 »

It might be the 5.4 kernel causing the problem. Did you use 5.4 in 19.3 or another?
Post Reply

Return to “Hardware Support”