Bluetooth not working, Linux Mint 19.3 "Tricia"(Cinnamon, 64-bit)

Questions about hardware,drivers and peripherals
Forum rules
Before you post please read how to get help
Post Reply
Wolfgang 348
Level 1
Level 1
Posts: 9
Joined: Sun Sep 06, 2020 8:23 am

Bluetooth not working, Linux Mint 19.3 "Tricia"(Cinnamon, 64-bit)

Post by Wolfgang 348 »

Hello, Linux Mint Forums!

So, I have just installed Linux Mint 19.3 "Tricia"(Cinnamon, 64-bit) on HP 15- AC044TU.
First thing I did was run the driver manager, and install the recommended "bcmwl-kernel-source" driver and restart.
Wireless internet now performs well, however, I am unable to use bluetooth.
The blueberry applet appears in the taskbar, and the window says that my computer is visible to other devices, but it does not detect my devices, and my devices do not detect it. Tried Blueman also, but no luck.

Does anyone know what changed, or how I can fix it? Please help.
Hoser Rob
Level 16
Level 16
Posts: 6432
Joined: Sat Dec 15, 2012 8:57 am

Re: Bluetooth not working, Linux Mint 19.3 "Tricia"(Cinnamon, 64-bit)

Post by Hoser Rob »

Broadcom drivers can be tricky because they have models that can have more than one chipset within. Driver Manager can be fooled there. So run these in terminal and paste the text output here (the 2nd one gets the PCI ID of the Broadcom card):

Code: Select all

inxi -Fxz

Code: Select all

lspci -nn -d 14e4:
Wolfgang 348
Level 1
Level 1
Posts: 9
Joined: Sun Sep 06, 2020 8:23 am

Re: Bluetooth not working, Linux Mint 19.3 "Tricia"(Cinnamon, 64-bit)

Post by Wolfgang 348 »

Hoser Rob wrote:
Thu Sep 17, 2020 8:59 am
Broadcom drivers can be tricky because they have models that can have more than one chipset within. Driver Manager can be fooled there. So run these in terminal and paste the text output here (the 2nd one gets the PCI ID of the Broadcom card):

Code: Select all

inxi -Fxz
Output:

Code: Select all

System:
  Host: kamal-HP-Notebook Kernel: 5.0.0-32-generic x86_64 bits: 64 
  compiler: gcc v: 7.4.0 Desktop: Cinnamon 4.4.5 
  Distro: Linux Mint 19.3 Tricia base: Ubuntu 18.04 bionic 
Machine:
  Type: Laptop System: Hewlett-Packard product: HP Notebook 
  v: Type1ProductConfigId serial: <filter> 
  Mobo: Hewlett-Packard model: 80C1 v: 96.45 serial: <filter> UEFI: Insyde 
  v: F.1F date: 01/18/2016 
Battery:
  ID-1: BAT1 charge: 32.0 Wh condition: 35.5/41.6 Wh (85%) 
  model: COMPAL PABAS0241231 status: Discharging 
CPU:
  Topology: Dual Core model: Intel Core i3-5010U bits: 64 type: MT MCP 
  arch: Broadwell rev: 4 L2 cache: 3072 KiB 
  flags: lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 16799 
  Speed: 800 MHz min/max: 500/2000 MHz Core speeds (MHz): 1: 939 2: 804 
  3: 900 4: 826 
Graphics:
  Device-1: Intel HD Graphics 5500 vendor: Hewlett-Packard driver: i915 
  v: kernel bus ID: 00:02.0 
  Display: x11 server: X.Org 1.20.4 driver: modesetting unloaded: fbdev,vesa 
  resolution: 1366x768~60Hz 
  OpenGL: renderer: Mesa DRI Intel HD Graphics 5500 (Broadwell GT2) 
  v: 4.5 Mesa 19.0.8 direct render: Yes 
Audio:
  Device-1: Intel Broadwell-U Audio vendor: Hewlett-Packard 
  driver: snd_hda_intel v: kernel bus ID: 00:03.0 
  Device-2: Intel Wildcat Point-LP High Definition Audio 
  vendor: Hewlett-Packard driver: snd_hda_intel v: kernel bus ID: 00:1b.0 
  Sound Server: ALSA v: k5.0.0-32-generic 
Network:
  Device-1: Realtek RTL810xE PCI Express Fast Ethernet 
  vendor: Hewlett-Packard driver: r8169 v: kernel port: 4000 bus ID: 07:00.0 
  IF: enp7s0 state: down mac: <filter> 
  Device-2: Broadcom and subsidiaries BCM43142 802.11b/g/n 
  vendor: Hewlett-Packard driver: wl v: kernel port: 4000 bus ID: 0d:00.0 
  IF: wlp13s0 state: up mac: <filter> 
Drives:
  Local Storage: total: 465.76 GiB used: 13.67 GiB (2.9%) 
  ID-1: /dev/sda vendor: Toshiba model: MQ01ABF050 size: 465.76 GiB 
Partition:
  ID-1: / size: 456.96 GiB used: 13.67 GiB (3.0%) fs: ext4 dev: /dev/sda2 
Sensors:
  System Temperatures: cpu: 46.0 C mobo: N/A 
  Fan Speeds (RPM): N/A 
Info:
  Processes: 190 Uptime: 10m Memory: 3.77 GiB used: 963.0 MiB (25.0%) 
  Init: systemd runlevel: 5 Compilers: gcc: 7.4.0 Shell: bash v: 4.4.20 
  inxi: 3.0.32 
Wolfgang 348
Level 1
Level 1
Posts: 9
Joined: Sun Sep 06, 2020 8:23 am

Re: Bluetooth not working, Linux Mint 19.3 "Tricia"(Cinnamon, 64-bit)

Post by Wolfgang 348 »

Hoser Rob wrote:
Thu Sep 17, 2020 8:59 am
Broadcom drivers can be tricky because they have models that can have more than one chipset within. Driver Manager can be fooled there. So run these in terminal and paste the text output here (the 2nd one gets the PCI ID of the Broadcom card):

Code: Select all

lspci -nn -d 14e4:
Output:

Code: Select all

0d:00.0 Network controller [0280]: Broadcom Inc. and subsidiaries BCM43142 802.11b/g/n [14e4:4365] (rev 01)
JeremyB
Level 20
Level 20
Posts: 11699
Joined: Fri Feb 21, 2014 8:17 am

Re: Bluetooth not working, Linux Mint 19.3 "Tricia"(Cinnamon, 64-bit)

Post by JeremyB »

Please post results for

Code: Select all

lsusb; dmesg | egrep -i 'blue|firm'
Wolfgang 348
Level 1
Level 1
Posts: 9
Joined: Sun Sep 06, 2020 8:23 am

Re: Bluetooth not working, Linux Mint 19.3 "Tricia"(Cinnamon, 64-bit)

Post by Wolfgang 348 »

JeremyB wrote:
Fri Sep 18, 2020 5:58 am
Please post results for

Code: Select all

lsusb; dmesg | egrep -i 'blue|firm'
Output:

Code: Select all

Bus 001 Device 002: ID 8087:8001 Intel Corp. 
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 003 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 002 Device 003: ID 04f2:b509 Chicony Electronics Co., Ltd 
Bus 002 Device 002: ID 0a5c:216d Broadcom Corp. 
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
[    0.047673] [Firmware Bug]: TSC_DEADLINE disabled due to Errata; please update microcode to version: 0x25 (or later)
[   16.005742] Bluetooth: Core ver 2.22
[   16.005767] Bluetooth: HCI device and connection manager initialized
[   16.005771] Bluetooth: HCI socket layer initialized
[   16.005773] Bluetooth: L2CAP socket layer initialized
[   16.005778] Bluetooth: SCO socket layer initialized
[   16.219219] Bluetooth: hci0: BCM: chip id 70
[   16.220200] Bluetooth: hci0: BCM: features 0x06
[   16.236195] Bluetooth: hci0: BCM43142A
[   16.237178] Bluetooth: hci0: BCM43142A0 (001.001.011) build 0000
[   16.316141] bluetooth hci0: Direct firmware load for brcm/BCM43142A0-0a5c-216d.hcd failed with error -2
[   16.316156] Bluetooth: hci0: BCM: Patch brcm/BCM43142A0-0a5c-216d.hcd not found
[   18.333461] Bluetooth: hci0: command 0x1003 tx timeout
[   18.334228] Bluetooth: hci0: unexpected event for opcode 0x1003
[   21.791530] Bluetooth: BNEP (Ethernet Emulation) ver 1.3
[   21.791531] Bluetooth: BNEP filters: protocol multicast
[   21.791537] Bluetooth: BNEP socket layer initialized
[   68.433134] Bluetooth: RFCOMM TTY layer initialized
[   68.433155] Bluetooth: RFCOMM socket layer initialized
[   68.433161] Bluetooth: RFCOMM ver 1.11
User avatar
MrEen
Level 21
Level 21
Posts: 13154
Joined: Mon Jun 12, 2017 8:39 pm

Re: Bluetooth not working, Linux Mint 19.3 "Tricia"(Cinnamon, 64-bit)

Post by MrEen »

And yet more deja vu:

Code: Select all

[   16.316141] bluetooth hci0: Direct firmware load for brcm/BCM43142A0-0a5c-216d.hcd failed with error -2
[   16.316156] Bluetooth: hci0: BCM: Patch brcm/BCM43142A0-0a5c-216d.hcd not found
See here: viewtopic.php?p=1875112#p1875112
Wolfgang 348
Level 1
Level 1
Posts: 9
Joined: Sun Sep 06, 2020 8:23 am

Re: Bluetooth not working, Linux Mint 19.3 "Tricia"(Cinnamon, 64-bit)

Post by Wolfgang 348 »

MrEen wrote:
Fri Sep 18, 2020 10:02 pm
And yet more deja vu:

Code: Select all

[   16.316141] bluetooth hci0: Direct firmware load for brcm/BCM43142A0-0a5c-216d.hcd failed with error -2
[   16.316156] Bluetooth: hci0: BCM: Patch brcm/BCM43142A0-0a5c-216d.hcd not found
See here: viewtopic.php?p=1875112#p1875112

Thank you very much! It works :D
Post Reply

Return to “Hardware Support”