19.1 Earphone mic and internal mic not working

Questions about hardware,drivers and peripherals
Forum rules
Before you post please read how to get help
Post Reply
shovon64
Level 1
Level 1
Posts: 4
Joined: Sat Oct 17, 2020 8:07 am

19.1 Earphone mic and internal mic not working

Post by shovon64 »

I am using dual boot on my laptop. Earphone works on windows so i know that it is working.

Linux Mint 19.1
VERSION_CODENAME=tessa
UBUNTU_CODENAME=bionic
#cat /proc/version
Linux version 4.15.0-115-generic (buildd@lgw01-amd64-037) (gcc version 7.5.0 (Ubuntu 7.5.0-3ubuntu1~18.04)) #116-Ubuntu SMP Wed Aug 26 14:04:49 UTC 2020

I ran this command "curl https://gitlab.freedesktop.org/pulseaud ... line=false".
https://termbin.com/0t1w
User avatar
MrEen
Level 21
Level 21
Posts: 14188
Joined: Mon Jun 12, 2017 8:39 pm

Re: 19.1 Earphone mic and internal mic not working

Post by MrEen »

Hi shovon64, and welcome to the forum.

I see in the output that Skype was in use. If that's the only way you're testing the mics you should try disabling Skype's Automatically Adjust Volume somewhere in it's options. I know that has helped a few users.

If that makes no difference, I need to know if you blacklisted the realtek module, as we're not getting the codec's ALC number. The output of ls -l /etc/modprobe.d might help here.
shovon64
Level 1
Level 1
Posts: 4
Joined: Sat Oct 17, 2020 8:07 am

Re: 19.1 Earphone mic and internal mic not working

Post by shovon64 »

MrEen wrote:
Sat Oct 17, 2020 12:40 pm
Hi shovon64, and welcome to the forum.

I see in the output that Skype was in use. If that's the only way you're testing the mics you should try disabling Skype's Automatically Adjust Volume somewhere in it's options. I know that has helped a few users.

If that makes no difference, I need to know if you blacklisted the realtek module, as we're not getting the codec's ALC number. The output of ls -l /etc/modprobe.d might help here.
Disabled that settings in skype but it didn't work in skype test call.
output of that command that you asked.

Code: Select all

total 56
-rw-r--r-- 1 root root 2507 Jul 31  2015 alsa-base.conf
-rw-r--r-- 1 root root  154 Jun 26  2018 amd64-microcode-blacklist.conf
-rw-r--r-- 1 root root  325 Jan 28  2018 blacklist-ath_pci.conf
-rw-r--r-- 1 root root 1667 Nov 13  2018 blacklist.conf
-rw-r--r-- 1 root root  210 Jan 28  2018 blacklist-firewire.conf
-rw-r--r-- 1 root root  677 Apr  9  2020 blacklist-framebuffer.conf
-rw-r--r-- 1 root root  156 Jul 31  2015 blacklist-modem.conf
-rw-r--r-- 1 root root  106 Jul 22  2019 blacklist-nouveau.conf
lrwxrwxrwx 1 root root   41 Jul 20  2019 blacklist-oss.conf -> /lib/linux-sound-base/noOSS.modprobe.conf
-rw-r--r-- 1 root root  583 Jan 28  2018 blacklist-rare-network.conf
-rw-r--r-- 1 root root  127 Feb  7  2017 dkms.conf
-rw-r--r-- 1 root root  154 Jun 20  2019 intel-microcode-blacklist.conf
-rw-r--r-- 1 root root  347 Jan 28  2018 iwlwifi.conf
-rw-r--r-- 1 root root   26 Jul 22  2019 nouveau-kms.conf
-rw-r--r-- 1 root root   27 May 22  2019 qemu-system-x86.conf
User avatar
MrEen
Level 21
Level 21
Posts: 14188
Joined: Mon Jun 12, 2017 8:39 pm

Re: 19.1 Earphone mic and internal mic not working

Post by MrEen »

Okay, let's look at this output now:

Code: Select all

cat /etc/modprobe.d/alsa-base.conf
I'm trying to find a reason your Codec isn't getting identified, so we can then try to apply the appropriate quirk to add a headset mic option.

I even googled the last line from this:

Code: Select all

!!HDA-Intel Codec information
!!---------------------------
--startcollapse--

Codec: Realtek Generic
Address: 0
AFG Function Id: 0x1 (unsol 1)
Vendor Id: 0x10ec0230
And so far, all the results have been like yours, just showing Realtek Generic instead of something like Realtek ALC1220.

You can go ahead and try this, but I suspect it's not going to work:

Code: Select all

sudo tee /etc/modprobe.d/lenovo-fix.conf <<<'options snd-hda-intel model=dell-headset-multi'
Reboot after running that, then look at dmesg | grep snd to see if a Headset Mic was added to this section:

Code: Select all

[    6.607886] snd_hda_codec_generic hdaudioC0D0: autoconfig for Generic: line_outs=1 (0x14/0x0/0x0/0x0/0x0) type:speaker
[    6.607888] snd_hda_codec_generic hdaudioC0D0:    speaker_outs=0 (0x0/0x0/0x0/0x0/0x0)
[    6.607889] snd_hda_codec_generic hdaudioC0D0:    hp_outs=1 (0x21/0x0/0x0/0x0/0x0)
[    6.607889] snd_hda_codec_generic hdaudioC0D0:    mono: mono_out=0x0
[    6.607890] snd_hda_codec_generic hdaudioC0D0:    inputs:
[    6.607891] snd_hda_codec_generic hdaudioC0D0:      Mic=0x19
[    6.607892] snd_hda_codec_generic hdaudioC0D0:      Internal Mic=0x12
I should ask, does you headset have one jack or two? And does the laptop have one audio port or two?
shovon64
Level 1
Level 1
Posts: 4
Joined: Sat Oct 17, 2020 8:07 am

Re: 19.1 Earphone mic and internal mic not working

Post by shovon64 »

MrEen wrote:
Sun Oct 18, 2020 12:11 pm
Okay, let's look at this output now:

Code: Select all

cat /etc/modprobe.d/alsa-base.conf
I'm trying to find a reason your Codec isn't getting identified, so we can then try to apply the appropriate quirk to add a headset mic option.

I even googled the last line from this:

Code: Select all

!!HDA-Intel Codec information
!!---------------------------
--startcollapse--

Codec: Realtek Generic
Address: 0
AFG Function Id: 0x1 (unsol 1)
Vendor Id: 0x10ec0230
And so far, all the results have been like yours, just showing Realtek Generic instead of something like Realtek ALC1220.

You can go ahead and try this, but I suspect it's not going to work:

Code: Select all

sudo tee /etc/modprobe.d/lenovo-fix.conf <<<'options snd-hda-intel model=dell-headset-multi'
Reboot after running that, then look at dmesg | grep snd to see if a Headset Mic was added to this section:

Code: Select all

[    6.607886] snd_hda_codec_generic hdaudioC0D0: autoconfig for Generic: line_outs=1 (0x14/0x0/0x0/0x0/0x0) type:speaker
[    6.607888] snd_hda_codec_generic hdaudioC0D0:    speaker_outs=0 (0x0/0x0/0x0/0x0/0x0)
[    6.607889] snd_hda_codec_generic hdaudioC0D0:    hp_outs=1 (0x21/0x0/0x0/0x0/0x0)
[    6.607889] snd_hda_codec_generic hdaudioC0D0:    mono: mono_out=0x0
[    6.607890] snd_hda_codec_generic hdaudioC0D0:    inputs:
[    6.607891] snd_hda_codec_generic hdaudioC0D0:      Mic=0x19
[    6.607892] snd_hda_codec_generic hdaudioC0D0:      Internal Mic=0x12
I should ask, does you headset have one jack or two? And does the laptop have one audio port or two?
Output of this - cat /etc/modprobe.d/alsa-base.conf

Code: Select all

# autoloader aliases
install sound-slot-0 /sbin/modprobe snd-card-0
install sound-slot-1 /sbin/modprobe snd-card-1
install sound-slot-2 /sbin/modprobe snd-card-2
install sound-slot-3 /sbin/modprobe snd-card-3
install sound-slot-4 /sbin/modprobe snd-card-4
install sound-slot-5 /sbin/modprobe snd-card-5
install sound-slot-6 /sbin/modprobe snd-card-6
install sound-slot-7 /sbin/modprobe snd-card-7

# Cause optional modules to be loaded above generic modules
install snd /sbin/modprobe --ignore-install snd $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-ioctl32 ; /sbin/modprobe --quiet --use-blacklist snd-seq ; }
#
# Workaround at bug #499695 (reverted in Ubuntu see LP #319505)
install snd-pcm /sbin/modprobe --ignore-install snd-pcm $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-pcm-oss ; : ; }
install snd-mixer /sbin/modprobe --ignore-install snd-mixer $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-mixer-oss ; : ; }
install snd-seq /sbin/modprobe --ignore-install snd-seq $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-seq-midi ; /sbin/modprobe --quiet --use-blacklist snd-seq-oss ; : ; }
#
install snd-rawmidi /sbin/modprobe --ignore-install snd-rawmidi $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-seq-midi ; : ; }
# Cause optional modules to be loaded above sound card driver modules
install snd-emu10k1 /sbin/modprobe --ignore-install snd-emu10k1 $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-emu10k1-synth ; }
install snd-via82xx /sbin/modprobe --ignore-install snd-via82xx $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-seq ; }

# Load saa7134-alsa instead of saa7134 (which gets dragged in by it anyway)
install saa7134 /sbin/modprobe --ignore-install saa7134 $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist saa7134-alsa ; : ; }
# Prevent abnormal drivers from grabbing index 0
options bt87x index=-2
options cx88_alsa index=-2
options saa7134-alsa index=-2
options snd-atiixp-modem index=-2
options snd-intel8x0m index=-2
options snd-via82xx-modem index=-2
options snd-usb-audio index=-2
options snd-usb-caiaq index=-2
options snd-usb-ua101 index=-2
options snd-usb-us122l index=-2
options snd-usb-usx2y index=-2
# Ubuntu #62691, enable MPU for snd-cmipci
options snd-cmipci mpu_port=0x330 fm_port=0x388
# Keep snd-pcsp from being loaded as first soundcard
options snd-pcsp index=-2
# Keep snd-usb-audio from beeing loaded as first soundcard
options snd-usb-audio index=-2

I tried that command and rebooted but still not working. then i ran this dmesg | grep snd.

Code: Select all

[    6.012464] snd_hda_intel 0000:00:1f.3: bound 0000:00:02.0 (ops i915_audio_component_bind_ops [i915])
[    6.053080] snd_hda_codec_generic hdaudioC0D0: autoconfig for Generic: line_outs=1 (0x14/0x0/0x0/0x0/0x0) type:speaker
[    6.053082] snd_hda_codec_generic hdaudioC0D0:    speaker_outs=0 (0x0/0x0/0x0/0x0/0x0)
[    6.053083] snd_hda_codec_generic hdaudioC0D0:    hp_outs=1 (0x21/0x0/0x0/0x0/0x0)
[    6.053083] snd_hda_codec_generic hdaudioC0D0:    mono: mono_out=0x0
[    6.053084] snd_hda_codec_generic hdaudioC0D0:    inputs:
[    6.053085] snd_hda_codec_generic hdaudioC0D0:      Mic=0x19
[    6.053086] snd_hda_codec_generic hdaudioC0D0:      Internal Mic=0x12
[   68.638255] snd_hda_intel 0000:00:1f.3: Unstable LPIB (65536 >= 32768); disabling LPIB delay counting
Also my laptop has only one port for audio output and my earphone also has only one jack.
User avatar
MrEen
Level 21
Level 21
Posts: 14188
Joined: Mon Jun 12, 2017 8:39 pm

Re: 19.1 Earphone mic and internal mic not working

Post by MrEen »

Okay, as it didn't work, remove the edit with this command:

Code: Select all

sudo rm /etc/modprobe.d/lenovo-fix.conf
Next, install alsa-tools-gui so you can run HDAJackRetask. When it opens, what can you select in the upper left next to Select a Codec?

Assuming you can select Generic, do so, then check the box for Show unconnected pins, then in the left pane click on the Override for the Not connected pins and see if any can be changed to Headset Mic. If you can find one, after selecting that, click on Apply now then see if there's a Headset Mic in your sound settings you can select. If it works, click on Install boot override then reboot and verify it still works.
shovon64
Level 1
Level 1
Posts: 4
Joined: Sat Oct 17, 2020 8:07 am

Re: 19.1 Earphone mic and internal mic not working

Post by shovon64 »

MrEen wrote:
Sun Oct 18, 2020 6:11 pm
Okay, as it didn't work, remove the edit with this command:

Code: Select all

sudo rm /etc/modprobe.d/lenovo-fix.conf
Next, install alsa-tools-gui so you can run HDAJackRetask. When it opens, what can you select in the upper left next to Select a Codec?

Assuming you can select Generic, do so, then check the box for Show unconnected pins, then in the left pane click on the Override for the Not connected pins and see if any can be changed to Headset Mic. If you can find one, after selecting that, click on Apply now then see if there's a Headset Mic in your sound settings you can select. If it works, click on Install boot override then reboot and verify it still works.
May be i f** up at some point it was showing realtec generic but now it's showing something else like "generic fff generic" and my browser playback stopped working.
User avatar
MrEen
Level 21
Level 21
Posts: 14188
Joined: Mon Jun 12, 2017 8:39 pm

Re: 19.1 Earphone mic and internal mic not working

Post by MrEen »

No worries, we'll get it fixed.

Just in case, run this again:

Code: Select all

sudo rm /etc/modprobe.d/lenovo-fix.conf
It may say the file doesn't exist, that's fine. And you should probably shut down for a couple of minutes if you haven't already.

Next, delete the files in /home/YourUserName/.config/pulse then run pulseaudio -k in the terminal. Now start your browser and see if you're back to normal.

Before doing all that, please run dmesg | grep snd again as maybe the non Realtek parser actually shows a headset mic option. Regardless the outcome, go ahead and do the other steps, but do let me know if it had a headset mic option.

Once you're back to normal, we'll try something else to get the mic showing.

EDIT: If you had clicked on Install boot override, you can undo that by clicking on Remove boot override then rebooting. Everything else HDAJackRetask does besides the Install boot override can be undone with a reboot.
Post Reply

Return to “Hardware Support”