numpad stopped working

Questions about hardware,drivers and peripherals
Forum rules
Before you post please read how to get help
Post Reply
NegitiveSinX
Level 1
Level 1
Posts: 6
Joined: Tue Jan 20, 2009 5:42 pm

numpad stopped working

Post by NegitiveSinX »

Hi,
I'm pretty noob to Linux, so I don't know what file this is. But sometime last week my number pad on my keyboard stopped working. Now I know it's not my keyboard that's broken because I change to a different user profile in Mint and it works fine. I went into the keyboard settings in the control panel and tried messing with the settings to fix it, no luck.
So what file should I edit/delete to get this fixed as I use my numpad A LOT?
Thanks,
User avatar
DrHu
Level 17
Level 17
Posts: 7522
Joined: Wed Jun 17, 2009 8:20 pm

Re: numpad stopped working

Post by DrHu »

In the BIOS of the computer, you can often set number pad ON
--and have the installed OS ignore the numpad settings
http://www.cyberciti.biz/faq/linux-nume ... nly-works/
http://tuxtraining.com/2009/10/27/fix-n ... #more-2246

May depend on whether you are using a notebook with a trackpad/touchpad/mouse which may affect the keyboard if you enabled some touchpad setting..

Do you have a Num Lock key on the number pad of the keyboard ?
danielfrins
Level 1
Level 1
Posts: 1
Joined: Mon Feb 08, 2010 11:06 am

Re: numpad stopped working

Post by danielfrins »

In the preferences menu choose Keyboard (settings). The fourth tab is 'Mousekeys' I think (I need to translate out of Dutch).
Under this tab you can find the option to use the numpad of your keyboard to control the mouse. Deselect it :).

This problem seems to return to me quit frequently... Does anybody know how to keep ik deselected?
gibbs1984
Level 5
Level 5
Posts: 802
Joined: Mon Oct 27, 2008 2:40 pm
Location: Hemel Hempstead, England

Re: numpad stopped working

Post by gibbs1984 »

Ah, thank you danielfrins, I had this problem and that has solved it, haven't tested to see if it comes back though, very frustrating.
Linux Mint 19.0 (Cinnamon) 64bit.
sherbert
Level 1
Level 1
Posts: 8
Joined: Tue May 11, 2010 7:57 pm

Re: numpad stopped working

Post by sherbert »

please add SOLVED to subject line. This issue is a teeth gnasher, thankfully solved. It seems to happen spontaneously.
sherbert :)
faeldra
Level 1
Level 1
Posts: 1
Joined: Wed Aug 25, 2010 3:09 pm

Re: numpad stopped working

Post by faeldra »

Worked for me to on Mint 9.

Thanks,
Faeldra
icmp_request
Level 1
Level 1
Posts: 22
Joined: Sun Jan 09, 2011 9:20 am

Re: numpad stopped working

Post by icmp_request »

danielfrins wrote:In the preferences menu choose Keyboard (settings). The fourth tab is 'Mousekeys' I think (I need to translate out of Dutch).
Under this tab you can find the option to use the numpad of your keyboard to control the mouse. Deselect it :).

This problem seems to return to me quit frequently... Does anybody know how to keep ik deselected?
Happened after my last update (Jan/09/2011). I don't know which packages were updated, I didn't update my System for sometime (1+ month), but seems that some software automatically selects the keyboard to control the mouse against our will. My mint is Ubuntu-based.

Worked with this solution anyway, thanks danielfrins, but it's very frustrating... Is there a bugzilla for that? Shouldn't suppose to happen.
Post Reply

Return to “Hardware Support”