HP Deskjet 2430 AllInOne

Questions about hardware,drivers and peripherals
Forum rules
Before you post please read how to get help
Level 1
Level 1
Posts: 1
Joined: Sun Dec 27, 2009 9:24 pm

HP Deskjet 2430 AllInOne

Postby dougm » Sun Dec 27, 2009 9:33 pm

I just installed Helena 8. Tried to update to the newest HPLIP using the automatic installer. Failed GCC dependency. So I am attaching some info in hopes that it may help someone else. I can print. Haven't tried scanning yet so it may require more effort.
HPLIP installation

1. followed instructions on:
http://hplipopensource.com/hplip-web/in ... xmint.html

The following errors came up during ./configure step 4:
Linking and byte-compiling packages for runtime python2.5...
/usr/lib/python2.5/site-packages/Onboard/KeyboardSVG.py:104: Warning: 'with' will become a reserved keyword in Python 2.6
Compiling /usr/lib/python2.5/site-packages/Onboard/KeyboardSVG.py ...
File "/usr/lib/python2.5/site-packages/Onboard/KeyboardSVG.py", line 104
with open(pane_svg_filename) as svg_file:
SyntaxError: invalid syntax

Errors were ignored.

In package manager, installed python-dev creating the log:

Commit Log for Sun Dec 27 18:39:52 2009

Installed the following packages:
python-dev (2.6.4-0ubuntu1)
python2.6-dev (2.6.4-0ubuntu3)

The following errors came up during make step 5:

In file included from prnt/hpcups/HPCupsFilter.h:34,
from prnt/hpcups/HPCupsFilter.cpp:31:
prnt/hpcups/CommonDefinitions.h:41:25: error: cups/raster.h: No such file or directory
In file included from prnt/hpcups/HPCupsFilter.cpp:31:
prnt/hpcups/HPCupsFilter.h:100: error: ‘cups_page_header2_t’ has not been declared
prnt/hpcups/HPCupsFilter.h:101: error: ‘cups_raster_t’ has not been declared
prnt/hpcups/HPCupsFilter.h:102: error: ‘cups_page_header2_t’ has not been declared
prnt/hpcups/HPCupsFilter.h:104: error: ‘cups_page_header2_t’ has not been declared
prnt/hpcups/HPCupsFilter.cpp:233: error: ‘DRIVER_ERROR HPCupsFilter::startPage’ is not a static member of ‘class HPCupsFilter’
prnt/hpcups/HPCupsFilter.cpp:233: error: ‘cups_page_header2_t’ was not declared in this scope
prnt/hpcups/HPCupsFilter.cpp:233: error: ‘cups_header’ was not declared in this scope
prnt/hpcups/HPCupsFilter.cpp:234: error: expected ‘,’ or ‘;’ before ‘{’ token
make: *** [hpcups-HPCupsFilter.o] Error 1


In package manager:
1. Removed cupsys-bsd because there is a cups-bsd, and I was afraid the two were conflicting.
2. Installed cups-dbg in hopes this would pull in the required files, not knowing what else to do.
creating the log:

Commit Log for Sun Dec 27 18:53:09 2009

Removed the following packages:

Upgraded the following packages:
cups (1.4.1-5ubuntu2) to 1.4.1-5ubuntu2.1
cups-bsd (1.4.1-5ubuntu2) to 1.4.1-5ubuntu2.1
cups-client (1.4.1-5ubuntu2) to 1.4.1-5ubuntu2.1
libcupscgi1 (1.4.1-5ubuntu2) to 1.4.1-5ubuntu2.1
libcupsdriver1 (1.4.1-5ubuntu2) to 1.4.1-5ubuntu2.1
libcupsimage2 (1.4.1-5ubuntu2) to 1.4.1-5ubuntu2.1

Installed the following packages:
cups-dbg (1.4.1-5ubuntu2.1)
libcupsdriver1-dev (1.4.1-5ubuntu2.1)
libcupsimage2-dev (1.4.1-5ubuntu2.1)
libpng12-dev (1.2.37-1)

The fix_symlink step 6 didn't work, fix_symlink.py was missing:
sudo python ./installer/fix_symlink.py

Ran make install anyway assuming that the fix was no longer required, and the instructions were dated. It seemed to work.

Went to hp-setup page:
http://hplipopensource.com/hplip-web/in ... setup.html

Test page printed, but driver wasn't specific to f2430, so not sure if there is an f2430 ppd file.

Level 23
Level 23
Posts: 18703
Joined: Sun Feb 11, 2007 7:22 am
Location: Near Borås Sweden

Re: HP Deskjet 2430 AllInOne

Postby Husse » Fri Jan 01, 2010 12:33 pm

hplip is included in the repositories and I think installed by default
The instructions you found are for the LTS edition Elyssa and if my memory serves me right there is another python version in Helena than in Elyssa
Can't say for sure what you need to do for scanning, hplip is "HP Linux Printing and Imaging System" so I suppose the scanner drivers are there too
I recommend you to install SANE as the built in scanner is not all that good
Don't fix it if it ain't broken, don't break it if you can't fix it

User avatar
Level 1
Level 1
Posts: 39
Joined: Sun Jun 28, 2009 5:25 pm

Re: HP Deskjet 2430 AllInOne

Postby jack.herbert » Tue Jan 05, 2010 12:32 pm

I have the Deskjet F2480 and Helena64, couldn't print nor scan with it,
tried to install hplip 3.9.12, made it till step 5, got stuck,
googled my way to this thread, fixed the cups business, et voila!
Now printing AND scanning without a hitch,
Thanks a million Husse!
*hum... what i meant was thanks a million DOUGM!!!
Last edited by jack.herbert on Fri Jan 15, 2010 12:02 pm, edited 2 times in total.
The light at the end of the tunnel is just the light of an oncoming train.
Robert Lowell

Level 1
Level 1
Posts: 14
Joined: Sat Jun 13, 2009 6:18 am

Re: HP Deskjet 2430 AllInOne

Postby AshtheFlash » Thu Jan 07, 2010 7:45 am

I'm having similar issues in Mint 7. Have made some of the changes to cups as suggested but not all the same packages were there. I've installed via the online cups system but it doesn't work unless I install the f735 instead of the 2430. The f735 works for printing but I don't get scanner function.

Any ideas?

Return to “Hardware Support”

Who is online

Users browsing this forum: MrEen, pdc_2 and 10 guests