[Solved] Wacom CTH-460

Questions about hardware,drivers and peripherals
Forum rules
Before you post please read how to get help
Level 3
Level 3
Posts: 155
Joined: Thu Oct 02, 2008 4:54 pm

[Solved] Wacom CTH-460

Postby Locuust » Sat Jan 02, 2010 10:28 pm

Well I got it working with the help of several posts on the ubuntu forums. The wacom project doesn't support this model yet so someone on the forums had some patches for the latest source. The problem is that they added a bunch of debug messages in the thing and I learned the hard way that this results in kern and message logs approaching the 1 Gb mark.

Patched driver Thread - http://ubuntuforums.org/showpost.php?p= ... tcount=541
Official driver Thread - http://ubuntuforums.org/showthread.php?t=1038949

Now somewhere I found a post suggesting I comment out any occurrences of 'printk' in the source. When I did a -
grep -r -H -i "printk" .
from the src/2.6.31/ directory I did in fact find where the kernel messages that have been filling up my logs are so I commented them all out (/* */) and rebuilt it. After a reboot I still have the problem. I'm new to this so I figure it's something stupid like the make script is reapplying the debugged patch after I manually edit the source. Any suggestions?

I'm moving backwards. Now I got to figure out why wacomcpl is broken again. :P

*Edit* Ok I think I got it fixed I'll post what I did just in case it will help someone else.
Last edited by Locuust on Sun Jan 03, 2010 12:04 am, edited 1 time in total.

Level 3
Level 3
Posts: 155
Joined: Thu Oct 02, 2008 4:54 pm

Re: Wacom CTH-460

Postby Locuust » Sat Jan 02, 2010 11:31 pm

I just started over with a new copy of the source.

If you follow the patched driver thread I posted above.. *before* you apply the patches on step.. wait thats right he doesn't have it numbered. Well before you do -

Code: Select all

# patch -p1 < wacomcpl-exec.patch
# patch -p1 < wacom_sys.c.patch
# patch -p1 < wacom_wac.c.patch
# patch -p1 < wacom_wac.h.patch
# patch -p1 < wactablet.h.patch
# patch -p1 < wacusb.c.patch
# patch -p1 < wcmUSB.c.patch

You need to modify wacom_wac.c.patch. Open it p in gedit or whatever editor you like and do a search on "printk". Comment out each printk line. i.e. -

Code: Select all

+                printk("[wacom]: reporting as eraser\n");

+                /* printk("[wacom]: reporting as eraser\n"); */

Should be all you need to do. Continue from there.

Note: If like me you had to go back and recompile make sure you re-apply changes to your 10-linuxwacom.fdi as I believe this gets re-written make the make install. I used http://ubuntuforums.org/attachment.php? ... 1261034609 and was able to use wacomcpl.

Return to “Hardware Support”

Who is online

Users browsing this forum: coffee412 and 4 guests