sometimes sound works, sometimes not

Questions about hardware,drivers and peripherals
Forum rules
Before you post please read how to get help
bfeggans
Level 1
Level 1
Posts: 3
Joined: Tue Jan 26, 2010 3:05 pm

sometimes sound works, sometimes not

Postby bfeggans » Tue Jan 26, 2010 3:09 pm

i just installed mint 8, and the sound is iffy. sometimes when i boot up, the sound is working. sometimes when i boot up, it is not. i was wondering what could be the cause of this. i am running mint 8 on a toshiba satellite m105 s3004. please help. i can supply any additional info. thanks in advance!

User avatar
remoulder
Level 17
Level 17
Posts: 7650
Joined: Fri May 09, 2008 1:14 pm
Contact:

Re: sometimes sound works, sometimes not

Postby remoulder » Tue Jan 26, 2010 3:42 pm

There are some bugs in the sound system inherited upstream in ubuntu karmic. If you install the linux-backports-modules-karmic and linux-backports-modules-karmic-generic and update your kernel to the latest 2.6.31-18, some of these issues appear to have been fixed. You might also have to install linux-backports-modules-alsa-2.6.31-18-generic after you have rebooted into the new kernel.

To install the backpost modules, simply enter [b]apt install <name as above>/b] in a terminal. To update your kernel, in mintupdate go to Edit | Preferences and put a tick against level 5 under the visible column. Exit preferences then do a Refresh, you should find the updates unticked. Select all the level 5 updates and Install.

Do this at your own risk.
[Edit] your original post and add [SOLVED] once your question is resolved.

“The people are my God” stressing the factor determining man’s destiny lies within man not in anything outside man, and thereby defining man as the dominator and remoulder of the world.

bfeggans
Level 1
Level 1
Posts: 3
Joined: Tue Jan 26, 2010 3:05 pm

Re: sometimes sound works, sometimes not

Postby bfeggans » Tue Jan 26, 2010 6:56 pm

thanks for the help remoulder, however, when i try using terminal to install the listed files, im getting a no such file could be found message. should i have to download these?

bfeggans
Level 1
Level 1
Posts: 3
Joined: Tue Jan 26, 2010 3:05 pm

Re: sometimes sound works, sometimes not

Postby bfeggans » Tue Jan 26, 2010 7:05 pm

i ran the command, alsamixer, in terminal, and it is saying my master volume is set to zero. i dont know how to change this, but on my desktop, my volume control is at 100% and 0.00 db. i dont know if that helps, but just thought i would add it.

User avatar
remoulder
Level 17
Level 17
Posts: 7650
Joined: Fri May 09, 2008 1:14 pm
Contact:

Re: sometimes sound works, sometimes not

Postby remoulder » Wed Jan 27, 2010 7:08 pm

bfeggans wrote:alsamixer, in terminal, and it is saying my master volume is set to zero. i dont know how to change this


use arrow keys to move left/right and increase/decrease volumes, tab to switch between all/capture/output, "m" to mute/un-mute, "esc" to save and exit.
[Edit] your original post and add [SOLVED] once your question is resolved.

“The people are my God” stressing the factor determining man’s destiny lies within man not in anything outside man, and thereby defining man as the dominator and remoulder of the world.


Return to “Hardware Support”

Who is online

Users browsing this forum: Moem and 7 guests