help requested : asus usb wifi adapter in Helena Main

Questions about hardware,drivers and peripherals
Forum rules
Before you post please read how to get help
Post Reply
colossus75
Level 1
Level 1
Posts: 48
Joined: Tue Jun 09, 2009 12:59 pm

help requested : asus usb wifi adapter in Helena Main

Post by colossus75 » Thu Feb 25, 2010 6:32 pm

Hi there,

I have an Asus WL-160N USB wifi adapter that I am trying to get working with Linux Mint 8 Helena Main Edition.
I have an IBM Thinkpad R51 1829 KCF that my Helena is multi-booting from. I am trying to implement the USB adapter after-the-install. Since there are times I go to wifi cafes that support N and I like to try and make use of the N speed/range.

When I plug in my WL-160N to my thinkpad, Helena "sees" it, gives it "WLANx" and that's about all I can do with it. My internal intel wifi chipset which is designated as "eth1" I can not seem to turn off or switch over to the Asus wifi USB adapter. I tried changing it in WICD..but not good results..I get response from the adapter for like 5 seconds or so then it drops out..and I can't connect to anything.

When I run lsusb -v this is what I get :
Bus 001 Device 006: ID 0b05:1731 ASUSTek Computer, Inc. ASUS 802.11n Network Adapter
Device Descriptor:
bLength 18
bDescriptorType 1
bcdUSB 2.00
bDeviceClass 0 (Defined at Interface level)
bDeviceSubClass 0
bDeviceProtocol 0
bMaxPacketSize0 64
idVendor 0x0b05 ASUSTek Computer, Inc.
idProduct 0x1731 ASUS 802.11n Network Adapter
bcdDevice 0.01
iManufacturer 1
iProduct 2
iSerial 0
bNumConfigurations 1
Configuration Descriptor:
bLength 9
bDescriptorType 2
wTotalLength 67
bNumInterfaces 1
bConfigurationValue 1
iConfiguration 0
bmAttributes 0x80
(Bus Powered)
MaxPower 4mA
Interface Descriptor:
bLength 9
bDescriptorType 4
bInterfaceNumber 0
bAlternateSetting 0
bNumEndpoints 7
bInterfaceClass 255 Vendor Specific Class
bInterfaceSubClass 255 Vendor Specific Subclass
bInterfaceProtocol 255 Vendor Specific Protocol
iInterface 3
Endpoint Descriptor:
bLength 7
bDescriptorType 5
bEndpointAddress 0x81 EP 1 IN
bmAttributes 2
Transfer Type Bulk
Synch Type None
Usage Type Data
wMaxPacketSize 0x0200 1x 512 bytes
bInterval 0
Endpoint Descriptor:
bLength 7
bDescriptorType 5
bEndpointAddress 0x01 EP 1 OUT
bmAttributes 2
Transfer Type Bulk
Synch Type None
Usage Type Data
wMaxPacketSize 0x0200 1x 512 bytes
bInterval 0
Endpoint Descriptor:
bLength 7
bDescriptorType 5
bEndpointAddress 0x02 EP 2 OUT
bmAttributes 2
Transfer Type Bulk
Synch Type None
Usage Type Data
wMaxPacketSize 0x0200 1x 512 bytes
bInterval 0
Endpoint Descriptor:
bLength 7
bDescriptorType 5
bEndpointAddress 0x03 EP 3 OUT
bmAttributes 2
Transfer Type Bulk
Synch Type None
Usage Type Data
wMaxPacketSize 0x0200 1x 512 bytes
bInterval 0
Endpoint Descriptor:
bLength 7
bDescriptorType 5
bEndpointAddress 0x04 EP 4 OUT
bmAttributes 2
Transfer Type Bulk
Synch Type None
Usage Type Data
wMaxPacketSize 0x0200 1x 512 bytes
bInterval 0
Endpoint Descriptor:
bLength 7
bDescriptorType 5
bEndpointAddress 0x05 EP 5 OUT
bmAttributes 2
Transfer Type Bulk
Synch Type None
Usage Type Data
wMaxPacketSize 0x0200 1x 512 bytes
bInterval 0
Endpoint Descriptor:
bLength 7
bDescriptorType 5
bEndpointAddress 0x06 EP 6 OUT
bmAttributes 2
Transfer Type Bulk
Synch Type None
Usage Type Data
wMaxPacketSize 0x0200 1x 512 bytes
bInterval 0
can't get device qualifier: Operation not permitted
can't get debug descriptor: Operation not permitted
cannot read device status, Operation not permitted (1)

I'm not quite sure how to interpret all that is in there.

this is what results I get from iwconfig :

lo no wireless extensions.

eth0 no wireless extensions.

irda0 no wireless extensions.

eth1 IEEE 802.11g ESSID:"NewValarek"
Mode:Managed Frequency:2.462 GHz Access Point: 00:23:CD:A3:8C:C0
Bit Rate:54 Mb/s Tx-Power=20 dBm Sensitivity=8/0
Retry limit:7 RTS thr:off Fragment thr:off
Power Management:off
Link Quality=91/100 Signal level=-38 dBm Noise level=-87 dBm
Rx invalid nwid:0 Rx invalid crypt:770 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:109 Missed beacon:5

wmaster0 no wireless extensions.

wlan3 IEEE 802.11bgn ESSID:""
Mode:Managed Frequency:2.412 GHz Access Point: Not-Associated
Tx-Power=0 dBm
Retry long limit:7 RTS thr:off Fragment thr:off
Power Management:on
Link Quality:0 Signal level:0 Noise level:0
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:0 Missed beacon:0

Any tips on how I am able to at least switch between the internal wifi and the external Asus USB wifi adapter?

Any thoughts appreciated.

Thanks,
colossus75
Gigabyte GA-M78SM-S2H
AMD Athlon 64 x2 5000 2.6GHz
4GB OCZ DDR2 800Mhz
500GB Seagate SATA 3.5" 7200.11 [OS/data]
2TB (main data drive xfs)
2TB rsync'd data drive NTFS)
400GB (virtual machine drive xfs)
OS : Mint Rosa 64bit

Husse
Level 23
Level 23
Posts: 18703
Joined: Sun Feb 11, 2007 7:22 am
Location: Near Borås Sweden

Re: help requested : asus usb wifi adapter in Helena Main

Post by Husse » Fri Mar 05, 2010 1:41 pm

I have yet not seen a laptop that does not have some sort of on/off switch for the wifi
You have to find that and switch off the internal or use it
Does the internal wifi work? You are not clear on that
Image
Don't fix it if it ain't broken, don't break it if you can't fix it

colossus75
Level 1
Level 1
Posts: 48
Joined: Tue Jun 09, 2009 12:59 pm

Re: help requested : asus usb wifi adapter in Helena Main

Post by colossus75 » Mon May 17, 2010 11:00 am

Husse wrote:I have yet not seen a laptop that does not have some sort of on/off switch for the wifi
You have to find that and switch off the internal or use it
Does the internal wifi work? You are not clear on that
There is a switch, for my thinkpad..but when I have the internal running and the Asus USB wifi plugged in..and I turn off..it shuts them both down. The internal wifi works though.
Gigabyte GA-M78SM-S2H
AMD Athlon 64 x2 5000 2.6GHz
4GB OCZ DDR2 800Mhz
500GB Seagate SATA 3.5" 7200.11 [OS/data]
2TB (main data drive xfs)
2TB rsync'd data drive NTFS)
400GB (virtual machine drive xfs)
OS : Mint Rosa 64bit

Post Reply

Return to “Hardware Support”