[Solved] Realtek RTL8191/8192SE Wireless Driver!

Questions about hardware,drivers and peripherals
Forum rules
Before you post please read how to get help
Post Reply
Level 1
Level 1
Posts: 5
Joined: Mon Mar 01, 2010 12:32 pm

[Solved] Realtek RTL8191/8192SE Wireless Driver!

Post by Bornabe » Mon Mar 01, 2010 1:04 pm

I've recently made the switch out of Windows and into Linux (Although not a Linux Newb) and instantly ran into a problem I'm noticing MANY others are having, their Realtek 8191/8192 Wireless not showing up after first install. I've come across this solution and it works flawlessly, aside from losing WEP / WPA security. You can connect to Unsecure & WPA2 connections just fine with it. The solution for LinuxMint 8 is:

Code: Select all

cd ~
mkdir Realtek
cd Realtek
wget http://launchpadlibrarian.net/33927923/rtl8192se_linux_2.6.0010.1012.2009.tar.gz
tar -xvzf rtl8192se_linux_2.6.0010.1012.2009.tar.gz
cd rtl8192se_linux_2.6.0010.1012.2009
sudo su   
make install

modprobe r8192se_pci
The solution for Ubuntu v9.10 is located at: http://ubuntuforums.org/showthread.php?t=1329254

I hope this helps those that are having troubles sticking with Linux coming from a Windows system. Linux, specifically LinuxMint, really is an all-you-can-eat buffet. I'm unfortunately dual-booted with Windows 7 on my new Toshiba Qosmio x505-Q870 simply for the gaming, but LinuxMint 8 has replaced my daily desktop in EVERY way. Thank you Linux / LinuxMint... Thank you.

Level 1
Level 1
Posts: 3
Joined: Tue Feb 02, 2010 4:01 pm

Re: [Solved] Realtek RTL8191/8192SE Wireless Driver!

Post by volosong » Tue Mar 02, 2010 1:32 am

Man, I love you! Works perfectly. Good directions for a novice.

I recently purchased an ASUS Eee PC 1201n and reconfigured it to dual boot the OEM Windows 7 and Mint 8. All works fine except for the wireless, (don't know about microphone or camera, as I don't have a need for those). Even though the 1201n has a RTL8191SE card, your instructions (for the 8192) work great.

Thank you very much. Will the drivers for the Realtek card be part of the next Mint release?

Level 1
Level 1
Posts: 3
Joined: Tue Feb 02, 2010 4:01 pm

Re: [Solved] Realtek RTL8191/8192SE Wireless Driver!

Post by volosong » Tue Mar 02, 2010 1:35 am

Oh, forgot to mention. I had to boot Windows 7 to download the gz file, then copy it to a thumb drive, re-boot to Mint, copy from the thumb drive to hard drive, and continue with the rest of your instructions as written.

Level 1
Level 1
Posts: 1
Joined: Tue Mar 02, 2010 10:11 pm

Re: [Solved] Realtek RTL8191/8192SE Wireless Driver!

Post by vandrade89 » Tue Mar 02, 2010 10:16 pm

Hey thanks a lot! I appreciate this forum. It was real easy to solve my wireless driver problem and now I am so looking forwards towrds using my Asus 1201N with Mint and 7.

Thank you again.

User avatar
Level 2
Level 2
Posts: 64
Joined: Wed Jan 03, 2007 10:24 am
Location: Ettlingen, Germany

Re: [Solved] Realtek RTL8191/8192SE Wireless Driver!

Post by Dr.U » Sun Mar 28, 2010 6:48 am

A big Thank You from me as well! :D

I recently purchased a Medion Akoya netbook E1222 and, using the newest rtl8192se driver (version 15 -- version 14 was always dropping the connection and would not reconnect), I am now very pleased with my new computer and Linux Mint 8 LXDE RC1.

Fast, low memory consumption, everything I need just works. I have not tried to use sound or the built-in camera, but those things are not really of interest to me: I use the box for work when not at home (or at home but not at the desktop PC).

Best regards,
-- Dr. U

User avatar
Level 3
Level 3
Posts: 118
Joined: Thu Jun 17, 2010 10:19 pm
Location: Central Alabama, USA

Re: [Solved] Realtek RTL8191/8192SE Wireless Driver!

Post by rdanner3 » Fri Jun 18, 2010 4:55 pm

No joy here. Machine sees wlan0 fine. Wireless card refuses to work at all except occasionally in ad-hoc mode with a 10.x.x.x IP addy. This is very bad, for my network (wireless and wired) is based off the 192.168.x.x range. (yes, I have a netmask of!)

Have followed all instructions. Am thinking of uninstalling the driver totally, since it's simply not working.

Card reports as "rtl8191se-VA2" in Win7 (works perfectly there) It reports as "rtl8191SEVA2" in Linux Mint 9 and doesn't work worth beans.

Have been looking for a solution across six or seven sites for several days now, too. :cry:
Doesn't seem to see my router at all, and (currently) am sitting within easy (Nerf) ball throw of the dang thing. (It's a Netgear DGN2000 Wireless N router with built-in DSL adapter)

This sort of thing is what frustrates efforts to get Linux to bigger market share. Things don't just "work" like they do in Windows or (usually) Mac OSX.

I know the password, and the fact it is WPA/WPA2 dual-mode, so those aren't the issue. WLAN0's not even seeing the SSID of the router. Very puzzling stuff. (On Mint now, on a wired-to-router port.)
Toshiba Satellite A505-S6005 on LM18.3 x64 (MATE/LXDE).
Linux dabbler since 1996. Registered Linux User #547455
Serious Linux user since Linux Mint 9 (also x64).

Level 1
Level 1
Posts: 1
Joined: Mon Oct 08, 2012 1:43 pm

Re: [Solved] Realtek RTL8191/8192SE Wireless Driver!

Post by quicky2g » Mon Oct 08, 2012 1:46 pm

I have an Acer Veriton Nettop running Debain 6.0.6 with a Realtek RTL8192DE wireless card. I downloaded the Unix/Linux driver from the Realtek website but compiling the module from source kept failing. The README file mentioned using compat-wireless. The versions of compat-wireless seemed to be organized based on kernel versions. Debian is currently running 2.6.32-5. I tried compat-wireless v2.6 but it didn't work. After extracting the tar.bz2 file and going through the README file, there's a command showing the wireless cards it supports:

Code: Select all

v2.6 didn't have the right driver available. I downloaded v3.5 and it did:

Code: Select all

Supported 802.11 drivers:

Supported Ethernet drivers:

Supported group drivers:
        atheros <  ath5k ath9k carl9170 zd1211rw ath6kl >
        ath <  ath5k ath9k carl9170 ath6kl >
        brcm80211 <  brcmsmac brcmfmac >
        intel <  iwlwifi, iwlegacy >
        rtl818x <  rtl8180 rtl8187 >
        rtlwifi <  rtl8192ce >
        ti <  wl1251 wl12xx (SPI and SDIO)>

Supported group drivers: Bluetooth & Ethernet:
        atlxx <  atl1 atl2 atl1e alx>
        bt <  Linux bluetooth drivers >
gcc, kernel headers, and all the other usual software for compiling packages should be installed. I compiled the driver successfully using the instructions in the README file. Pay attention to output after the scripts finish installing the kernel modules. There are a few extra commands needed to load the drivers into the kernel and reboot, but I can't remember what they are. I'm using the rtlwifi driver with no problems. Hope this helps!

Post Reply

Return to “Hardware Support”