Dualscreen, can't get any higher res than 640x480

Questions about hardware,drivers and peripherals
Forum rules
Before you post please read how to get help
slogum
Level 1
Level 1
Posts: 25
Joined: Sat Jun 13, 2009 5:55 am

Dualscreen, can't get any higher res than 640x480

Postby slogum » Tue Jun 15, 2010 7:02 am

I'm running dual-screen. On 24" at 1920x1080 and one 19" at 1440x900.

After installing Mint 9 I can't set the resolution any higher than 640x480 in nvidia-settings. I've installed the "recommended" nvidia-driver that Mint suggests.

Heres my xorg:

# nvidia-settings: X configuration file generated by nvidia-settings
# nvidia-settings: version 1.0 (buildd@yellow) Fri Apr 9 11:51:21 UTC 2010


Section "ServerLayout"
Identifier "Layout0"
Screen 0 "Screen0" 0 0
InputDevice "Keyboard0" "CoreKeyboard"
InputDevice "Mouse0" "CorePointer"
Option "Xinerama" "0"
EndSection

Section "Module"
Load "glx"
EndSection

Section "InputDevice"
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "auto"
Option "Device" "/dev/psaux"
Option "Emulate3Buttons" "no"
Option "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"

# generated from default
Identifier "Keyboard0"
Driver "kbd"
EndSection

Section "Monitor"
Identifier "Monitor0"
VendorName "Unknown"
ModelName "CRT-0"
HorizSync 28.0 - 33.0
VertRefresh 43.0 - 72.0
Option "DPMS"
# HorizSync source: builtin, VertRefresh source: builtin
EndSection

Section "Device"
Identifier "Device0"
Driver "nvidia"
VendorName "NVIDIA Corporation"
BoardName "GeForce 8800 GTS"
Option "NoLogo" "True"
EndSection

Section "Screen"

# Removed Option "metamodes" "CRT-0: 640x480 +1920+300, CRT-1: nvidia-auto-select +0+0; CRT-0: 1024x768, CRT-1: nvidia-auto-select +0+0"
# Removed Option "metamodes" "CRT-0: 320x240 +1920+300, CRT-1: nvidia-auto-select +0+0; CRT-0: NULL, CRT-1: nvidia-auto-select +0+0"
Identifier "Screen0"
Device "Device0"
Monitor "Monitor0"
DefaultDepth 24
Option "TwinView" "1"
Option "TwinViewXineramaInfoOrder" "CRT-1"
Option "metamodes" "CRT-0: 640x480 +1920+300, CRT-1: nvidia-auto-select +0+0; CRT-0: NULL, CRT-1: nvidia-auto-select +0+0"
SubSection "Display"
Depth 24
EndSubSection
EndSection



What could be the problem? Why can't I set the res higher than 640 in nvidia-settings?

denzil
Level 2
Level 2
Posts: 78
Joined: Tue Sep 15, 2009 8:33 am
Location: Cornwall, UK

Re: Dualscreen, can't get any higher res than 640x480

Postby denzil » Tue Jun 15, 2010 5:42 pm

Are you running nvidia-settings as a normal user? In that case it won't save the settings, because it doesn't have permission to save outside /home.

Fire up a command prompt and type

Code: Select all

sudo nvidia-settings


and save the settings from there.
Denzil

slogum
Level 1
Level 1
Posts: 25
Joined: Sat Jun 13, 2009 5:55 am

Re: Dualscreen, can't get any higher res than 640x480

Postby slogum » Tue Jun 15, 2010 5:45 pm

I'm running it as SU.

The problem is that the only choices I have in nvidia-settings is 320x240 and 640x480 for the 19".

slogum
Level 1
Level 1
Posts: 25
Joined: Sat Jun 13, 2009 5:55 am

Re: Dualscreen, can't get any higher res than 640x480

Postby slogum » Wed Jun 23, 2010 3:46 pm

Any suggestions?

slogum
Level 1
Level 1
Posts: 25
Joined: Sat Jun 13, 2009 5:55 am

Re: Dualscreen, can't get any higher res than 640x480

Postby slogum » Tue Jun 29, 2010 11:20 am

Bump!

Tried every solution I could find in by googling Can't figure this out. What is wrong with my xorg?

During installation the resolution was a lot higher than 680. But after installing the nvidia-drivers it doesn't work.

Everything was working in mint 8.

What could be wrong?


Return to “Hardware Support”

Who is online

Users browsing this forum: dl9220 and 5 guests