optical drives don't mount

Questions about hardware,drivers and peripherals
Forum rules
Before you post please read how to get help
DarinB
Level 4
Level 4
Posts: 246
Joined: Fri Feb 12, 2010 11:32 am

optical drives don't mount

Post by DarinB » Fri Jun 18, 2010 8:13 am

help!!!
LM9 things were great and now optical drives don't mount!!!!
and they are not in /home/media/ i thought i used to see them there.
the floppy and floppy0 is there....they represent my card reader (i think)
any ideas ??????

# /etc/fstab: static file system information.
#
# Use 'blkid -o value -s UUID' to print the universally unique identifier
# for a device; this may be used with UUID= as a more robust way to name
# devices that works even if disks are added and removed. See fstab(5).
#
# <file system> <mount point> <type> <options> <dump> <pass>
proc /proc proc nodev,noexec,nosuid 0 0
# / was on /dev/sda5 during installation
UUID=6237f2fc-580f-4f64-b45a-71d0753debbd / ext4 errors=remount-ro 0 1
# /mnt/music was on /dev/sdb1 during installation
UUID=63705dc6-133e-449e-9c9d-114a2a760102 /mnt/music ext3 defaults 0 2
# /mnt/o was on /dev/sdc1 during installation
UUID=4242b0bf-b298-4911-bfc2-af4d442c195e /mnt/o ext4 defaults 0 2
# /mnt/o1 was on /dev/sdc2 during installation
UUID=9a66b32b-8213-4469-a52b-ed24ba8357f7 /mnt/o1 ext4 defaults 0 2
# swap was on /dev/sda6 during installation
UUID=751c0a41-95f0-41b0-ab41-8964640b0a2c none swap sw 0 0
/dev/fd0 /media/floppy0 auto rw,user,noauto,exec,utf8 0 0opy

sakisds
Level 1
Level 1
Posts: 20
Joined: Fri Jun 18, 2010 6:31 am
Location: Athens, Greece

Re: optical drives don't mount

Post by sakisds » Fri Jun 18, 2010 9:27 am

Mounted volumes should appear at /media/ not at /home/media(Unless you changed it). Also, check if your optical drive is recognized by the system with this command:

Code: Select all

ls /dev/cd*
My output is:

Code: Select all

$ ls /dev/cd*
/dev/cdrom  /dev/cdrw
This means my optical drive is recognized by the system. You should get something similar.

DarinB
Level 4
Level 4
Posts: 246
Joined: Fri Feb 12, 2010 11:32 am

Re: optical drives don't mount

Post by DarinB » Fri Jun 18, 2010 9:34 am

darin@darin-desktop ~ $ ls /dev/cd*
/dev/cdrom /dev/cdrom1 /dev/cdrw /dev/cdrw1

sakisds
Level 1
Level 1
Posts: 20
Joined: Fri Jun 18, 2010 6:31 am
Location: Athens, Greece

Re: optical drives don't mount

Post by sakisds » Fri Jun 18, 2010 9:55 am

This means your optical drive is ok. Try mounting a cd manually with the following command:

Code: Select all

sudo mount -t iso9660 -o ro /dev/cdrom /media/cdrom
This will mount your cd to /media/cdrom, test if it accessible now.

DarinB
Level 4
Level 4
Posts: 246
Joined: Fri Feb 12, 2010 11:32 am

Re: optical drives don't mount

Post by DarinB » Fri Jun 18, 2010 11:04 am

i got this
darin@darin-desktop ~ $ sudo mount -t iso9660 -o ro /dev/cdrom /media/cdrom
[sudo] password for darin:
mount: no medium found on /dev/sr0
i did try mkdir in /media/ for cdrom cdrom1 cdrw cdrw1 and then changed the permissions to darin.

i have no idea now if i boot with the dvd in it shows up on the desktop but does nothing else
at least it is there and does something....it looks nice in the tower LOL
crap i am freaking out everything was so good for about 5 days
any more ideas? I can delete the dir i made if they are wrong...

User avatar
oobetimer
Level 7
Level 7
Posts: 1879
Joined: Tue Jun 01, 2010 12:53 pm
Location: Finland / above the Arctic Circle
Contact:

Re: optical drives don't mount

Post by oobetimer » Fri Jun 18, 2010 11:25 am

DarinB wrote:i got this
darin@darin-desktop ~ $ sudo mount -t iso9660 -o ro /dev/cdrom /media/cdrom
[sudo] password for darin:
mount: no medium found on /dev/sr0
i did try mkdir in /media/ for cdrom cdrom1 cdrw cdrw1 and then changed the permissions to darin.

i have no idea now if i boot with the dvd in it shows up on the desktop but does nothing else
at least it is there and does something....it looks nice in the tower LOL
crap i am freaking out everything was so good for about 5 days
any more ideas? I can delete the dir i made if they are wrong...
You could make a mount-point to /etc/fstab

Code: Select all

sudo gedit /etc/fstab

....the file

#cdwriter

/dev/cdrom /media/cdrom auto rw,noauto,user,exec 0 0

sakisds
Level 1
Level 1
Posts: 20
Joined: Fri Jun 18, 2010 6:31 am
Location: Athens, Greece

Re: optical drives don't mount

Post by sakisds » Fri Jun 18, 2010 11:31 am

DarinB wrote:i got this
darin@darin-desktop ~ $ sudo mount -t iso9660 -o ro /dev/cdrom /media/cdrom
[sudo] password for darin:
mount: no medium found on /dev/sr0
i did try mkdir in /media/ for cdrom cdrom1 cdrw cdrw1 and then changed the permissions to darin.

i have no idea now if i boot with the dvd in it shows up on the desktop but does nothing else
at least it is there and does something....it looks nice in the tower LOL
crap i am freaking out everything was so good for about 5 days
any more ideas? I can delete the dir i made if they are wrong...
No medium found means there is no cd in, or that's what linux thinks. Also you could try what oobetimer suggests. About the folder, i don't think they can cause any problems there, cause I usually mount stuff to /mnt/ without deleting /mnt/ every time before remounting.

DarinB
Level 4
Level 4
Posts: 246
Joined: Fri Feb 12, 2010 11:32 am

Re: optical drives don't mount

Post by DarinB » Fri Jun 18, 2010 4:34 pm

i added the fstab entry but it still did not work i could open the cd with vlc player but it would not play...then the system crashed was able to log off... and restart then i removed the fstab entry.
any ideas as to what to do???
btw i appreciate all the help so far

sakisds
Level 1
Level 1
Posts: 20
Joined: Fri Jun 18, 2010 6:31 am
Location: Athens, Greece

Re: optical drives don't mount

Post by sakisds » Sat Jun 19, 2010 6:55 am

If you don't mind of another crash, re-add the fstab entry and run VLC through a terminal, so we can see what kind of error it gives.

DarinB
Level 4
Level 4
Posts: 246
Joined: Fri Feb 12, 2010 11:32 am

Re: optical drives don't mount

Post by DarinB » Sat Jun 19, 2010 7:35 am

OK I added
mkdir sr0
mkdir sr1
mkdir sr2

that is what was in disk utility
disk utility.png
disk utility.png (265.77 KiB) Viewed 5345 times
then added these lines i get the disk at start up but not functional i can put a dvd in and get a title track but not play it so don't know if that is good after boot up nothing can load.
here are the line i added to fstab maybe they should be diff.
#dvdwriter
/dev/sr0 /media/sr0 auto rw,noauto,user,exec 0 0
#cdwriter
/dev/sr1 /media/sr1 auto rw,noauto,user,exec 0 0
#cdrom
/dev/sr2 /media/sr2 auto rw,noauto,user,exec 0 0

i think the dvd is sr2 but that doesn't matter i think since it is only a label rem out

sakisds
Level 1
Level 1
Posts: 20
Joined: Fri Jun 18, 2010 6:31 am
Location: Athens, Greece

Re: optical drives don't mount

Post by sakisds » Sat Jun 19, 2010 8:19 am

I assume the disk you are using is fine. Anyway, I searched around the web for your problem and I can't find a solution. Someone else that had this problem said that booting with a disk in the optical drive will auto-mount it. Have you tried that? I will keep searching for a while and let you know if I find something.

Edit: I've found that the problem is usually solved after an upgrade(for example, ubuntu 9.04 -> ubuntu 9.10) or using the fstab method provided. So this means if you can't fix it, consider making a back-up(with that backup tool mint has) and reinstalling. I will keep searching for another solution.

User avatar
markcynt
Level 6
Level 6
Posts: 1117
Joined: Sun May 17, 2009 10:53 am
Location: Lakeland Florida

Re: optical drives don't mount

Post by markcynt » Sat Jun 19, 2010 12:33 pm

Good luck finding a solution.

This is a bug present in all distros based on Ubuntu 10.04.

I've tried all of them and the bug persists.

No amount of updating will fix it (at present), neither will any fstab modification I've seen.

The bug does not exist in Ubuntu 9.04 or Ubuntu 10.04 and the distros based on them.

I had to revert to Mint 8.

Last time I checked Launchpad the bug was being worked on.

Unfortunately since the vast majority of users aren't affected by this bug it's not a high priority.
Image
P5N-E SLI, Core2Duo E6850 3GHZ X 2
2 GB DDR2 800MHZ
EVGA 8800GTS 320MB
2x320GB Hitachi
Arctic Cooling Freezer 7 Pro

DarinB
Level 4
Level 4
Posts: 246
Joined: Fri Feb 12, 2010 11:32 am

Re: optical drives don't mount

Post by DarinB » Sat Jun 19, 2010 12:56 pm

i feared it was a bug i will have to sit with it and be patient that someone will figure it out.

DarinB
Level 4
Level 4
Posts: 246
Joined: Fri Feb 12, 2010 11:32 am

Re: optical drives don't mount

Post by DarinB » Wed Jun 23, 2010 10:36 am

using LM9
adding noapic after splash in the grub edit
causes all the drives to work fine.
how do i make this a permanent thing?

DarinB
Level 4
Level 4
Posts: 246
Joined: Fri Feb 12, 2010 11:32 am

Re: optical drives don't mount

Post by DarinB » Thu Jun 24, 2010 7:40 am

This is how i made noapic permanent i hope it holds over to the next kernel upgrade...
does anybody know that answer.

Use
Code:
gksudo gedit /etc/default/grub
Add it to GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
so it looks like
Code:
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash noapic"
and then run
Code:
sudo update-grub

User avatar
markcynt
Level 6
Level 6
Posts: 1117
Joined: Sun May 17, 2009 10:53 am
Location: Lakeland Florida

Re: optical drives don't mount

Post by markcynt » Thu Jun 24, 2010 2:02 pm

DarinB wrote:using LM9
adding noapic after splash in the grub edit
causes all the drives to work fine.
how do i make this a permanent thing?
This works for me too.
DarinB wrote:This is how i made noapic permanent i hope it holds over to the next kernel upgrade...
does anybody know that answer.

Use
Code:
gksudo gedit /etc/default/grub
Add it to GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
so it looks like
Code:
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash noapic"
and then run
Code:
sudo update-grub
This also works for me. :)

Thanks for doing the legwork and posting this DarinB.
Image
P5N-E SLI, Core2Duo E6850 3GHZ X 2
2 GB DDR2 800MHZ
EVGA 8800GTS 320MB
2x320GB Hitachi
Arctic Cooling Freezer 7 Pro

DarinB
Level 4
Level 4
Posts: 246
Joined: Fri Feb 12, 2010 11:32 am

Re: optical drives don't mount

Post by DarinB » Fri Jun 25, 2010 9:08 am

You're welcome
I think it is our mother board
I have an ASUS P5NSLI ACPI BIOS Revision 1801
I also read it is made to run windows and that causes the irq problems

robert-e
Level 3
Level 3
Posts: 156
Joined: Fri Nov 27, 2009 1:38 am

Re: optical drives don't mount

Post by robert-e » Fri Jun 25, 2010 3:14 pm

Yes, this fix DID work (asus 1386 motherboard). However I do have a couple of questions for the knowlegable:

Firstly, while DVDs did not mount, and indeed could not be found, except if the DVD was in the drive on bootup; CDs would automount normally in the same drive. I found that strange and still do find it so. That indicated something other than an apic problem, since (I think) the same process does the mounting in both the CD case and the DVD case. Possible explanations??

Secondly, what are the possible ramifications of running with apic disabled? Could there be problems with the temperature sensors, and fan sensors on the motherboard? I know this can happen in the case of a laptop, and can either turn on the fans full bore (no all that bad, but for battery life) or worse, shut them down completely (catastrophic heating problems..not good)

I do know that this mounting problem was not evident in Mint 7 or in Mint 8, so something has changed in Mint, as my hardware has not been changed.

Thank you for taking the time.

Regards,
Bob

DarinB
Level 4
Level 4
Posts: 246
Joined: Fri Feb 12, 2010 11:32 am

Re: optical drives don't mount

Post by DarinB » Fri Jun 25, 2010 10:17 pm

i remember starting with jaunty i would get a apic not on something like this.
or no apic loaded then it would boot.
but it is possible that in an effort to speed up the boot this script to not use apic was removed. and besides it seems to be only an asus p5n sli issue.
I did read that when noapic is used it may cause usb problems but i have not had that problem. so for now we are good to go.

robert-e
Level 3
Level 3
Posts: 156
Joined: Fri Nov 27, 2009 1:38 am

Re: optical drives don't mount

Post by robert-e » Wed Sep 08, 2010 4:42 pm

It has been some time now, and I am wondering if someone has a handle on what the problem with the DVD (in the drive at bootup) being reported by the os, whereas if the dvd is inserted after bootup, it is not reported? I still remain somewhat uncomfortable with running with noacip appended to the kernel boot line.

Regards,
Bob

Post Reply

Return to “Hardware Support”