Can Someone PLEASE Help Me With 3D!!

Questions about hardware,drivers and peripherals
Forum rules
Before you post please read how to get help
Post Reply
User avatar
gqpolo
Level 2
Level 2
Posts: 85
Joined: Sun Jun 06, 2010 11:23 am
Location: Orlando, Florida

Can Someone PLEASE Help Me With 3D!!

Post by gqpolo » Tue Sep 14, 2010 4:56 am

I can't play ANY game that requires 3D and I think my hardware is suported. I don't know where to start.
HP DV5-5120, AMD Turion 64 ML-32, ATI M200, 1GB RAM, Mint 9 LXDE

JasonLG
Level 7
Level 7
Posts: 1612
Joined: Thu May 20, 2010 9:15 pm
Location: Polk City, Iowa USA

Re: Can Someone PLEASE Help Me With 3D!!

Post by JasonLG » Tue Sep 14, 2010 8:26 am

gqpolo wrote:I can't play ANY game that requires 3D and I think my hardware is suported. I don't know where to start.
A detailed description of your hardware is a good place to start, and better description of the problem wouldn't hurt either.

But the short answer is to check if there are proprietary drivers available for your graphics card/chipset by going to Mint Menu> Control Center> Hardware Drivers.
"I see" said the blind man to the deaf man who stuck his wooden leg out the window to check the weather.

User avatar
gqpolo
Level 2
Level 2
Posts: 85
Joined: Sun Jun 06, 2010 11:23 am
Location: Orlando, Florida

Re: Can Someone PLEASE Help Me With 3D!!

Post by gqpolo » Tue Sep 14, 2010 4:51 pm

HP Pavilion dv5120us with ATI Radeon XPress 200M video, 1GB ram, 1.8Ghz processor, mint9 LXDE...and no drivers loaded in hardware drivers (no options for any either) I have tried playing games like WoW both with mint LXDE and within XP using the virtualbox and it will either crash(in mint) or say no 3D device found in VB even though I enabled it.

http://yfrog.com/83desktop1001p
http://yfrog.com/83desktop1002p

If you need any other info please tell me what and I will post. Thanks for looking.
HP DV5-5120, AMD Turion 64 ML-32, ATI M200, 1GB RAM, Mint 9 LXDE

User avatar
DrHu
Level 17
Level 17
Posts: 7537
Joined: Wed Jun 17, 2009 8:20 pm

Re: Can Someone PLEASE Help Me With 3D!!

Post by DrHu » Tue Sep 14, 2010 6:08 pm

You can try installing the ATI Linux driver, but it may be a little far behind the current Linux kernels..

http://www2.ati.com/drivers/linux/linux_8.16.20.html
However, they do have an installer program, use that as a test install, it can only fail if something it requires is missing or the incorrect version

You can also use the open source drivers, but 3D acceleration may not be available..
https://help.ubuntu.com/community/RadeonDriver
https://help.ubuntu.com/community/BinaryDriverHowto/ATI
--same page, link to AMD (ati) binary driver instakllation..

Ati radeon express 200M..
http://www.ensode.net/ati_radeon_xpress_200m_linux.html
http://support.amd.com/us/gpudownload/Pages/index.aspx

User avatar
gqpolo
Level 2
Level 2
Posts: 85
Joined: Sun Jun 06, 2010 11:23 am
Location: Orlando, Florida

Re: Can Someone PLEASE Help Me With 3D!!

Post by gqpolo » Wed Sep 15, 2010 12:08 pm

Thank you DrHu for all of the help Here is the error message I get when trying to install the ATI driver

Error: ./default_policy.sh does not support version
default:v2:i686:lib::none:2.6.32-22-generic; make sure that the version is being
correctly set by --iscurrentdistro

Removing temporary directory: fglrx-install.8a56BL

Can I fix this or will it not work?

I read all those pages and installed mesa-utils and ran glxgears and i see the spinning wheels does that mean 3D works? I changed my BIOS like the one link said.
HP DV5-5120, AMD Turion 64 ML-32, ATI M200, 1GB RAM, Mint 9 LXDE

Post Reply

Return to “Hardware Support”