Reinstall of onboard NIC drivers

Questions about hardware,drivers and peripherals
Forum rules
Before you post please read how to get help
Level 1
Level 1
Posts: 7
Joined: Sun Feb 25, 2007 9:49 pm

Reinstall of onboard NIC drivers

Postby jimint » Sat Oct 06, 2007 5:53 pm

How do you uninstall and reinstall the NIC drivers in Cassandra.It's an onboard RealTek 8139.

User avatar
Level 8
Level 8
Posts: 2277
Joined: Sat Dec 02, 2006 4:19 pm
Location: Switzerland

Re: Reinstall of onboard NIC drivers

Postby scorp123 » Sat Oct 06, 2007 8:39 pm

jimint wrote:How do you uninstall and reinstall the NIC drivers in Cassandra.It's an onboard RealTek 8139.
There are no 'drivers' in Linux. What you mean are 'kernel modules'. If the card is supported --which means: the kernel recognises it and knows how to 'talk to it'-- it should work right away. Only thing you have to do is to (re?)configure it in your system preferences.

Besides: "removing and adding stuff again" or "uninstall something and install it again: this will fix it" may have worked fine on Windows. Here it's a stupid tactic and will fail in 99.99% of the cases because *this pseudo-trick does usually not work* ... The settings are kept elsewhere and not inside a package.

So if something doesn't work: Uninstalling and installing it again will only load the not working settings again, it will not change anything. It is therefore better if you describe your problems in details so we others can tell you what you need to do. 'Uninstall + reinstall' won't help you here.

Level 1
Level 1
Posts: 1
Joined: Mon Nov 05, 2007 2:03 am

Postby Mconn » Mon Nov 05, 2007 9:51 pm

Well if this post isn't too old I'll refine the question with more details since I'm having the same problems.

I'm trying to run Mint in a Biostar MCE 300i media center PC. It has a Broadcom BCM 5751 Gigabit nic card.

I've downloaded the "bcm5700-source_8.2.18-1_all.deb", "kernel-package_10.049ubuntu5_all.deb", and "module-assistant_0.10.6_all.deb" files and tried to install but to no avail.

The card is also identified in the Device Manager, so linux see's the card just can't get me on the net.

All this and I can't even get a file to copy into a folder owned by Root... I am completely new to linux as of 2 days ago but am very eager to learn. I'll suck up any usefull info given but please spell it out because I'm a windows guy of 12 years and know absoloutly nothing of the linux structure or command system.

Return to “Hardware Support”

Who is online

Users browsing this forum: No registered users and 4 guests