No Sound on Mint 10 - Realtek ALC888?

Questions about hardware,drivers and peripherals
Forum rules
Before you post please read how to get help
Post Reply
Bosola
Level 1
Level 1
Posts: 12
Joined: Sun Aug 08, 2010 9:15 pm

No Sound on Mint 10 - Realtek ALC888?

Post by Bosola » Sun Nov 21, 2010 2:29 pm

I've recently installed Mint 10 (very keen on it), but cannot get sound to work. Playing Youtube videos and using the system sound control's 'test speakers' doesn't work, and nor does playing an MP3. Sound just isn't working.

I'm using an MSI 770 C45 motherboard with its own sound controller. Gnome ALSA Mixer refers to it as a Realtek ALC888 and also provides a tab for the NVIDIA GT240 HDMI; alsamixer itself refers to it as a pulse audio device.

I downloaded and ran Realtek's own HD Audio Driver (the readme in it suggests it works with the ALC888), then installed alsamixer, followed by gnome-alsamixer, but to no avail.

Below is the result of hwinfo --sound:
mycomputername ~ $ hwinfo --sound
> hal.1: read hal dataprocess 2295: arguments to dbus_move_error() were incorrect, assertion "(dest) == NULL || !dbus_error_is_set ((dest))" failed in file dbus-errors.c line 280.
This is normally a bug in some application using the D-Bus library.
libhal.c 3483 : Error unsubscribing to signals, error=The name org.freedesktop.Hal was not provided by any .service files
19: PCI 14.2: 0403 Audio device
[Created at pci.318]
Unique ID: 5Dex.dzs94LWk+iA
SysFS ID: /devices/pci0000:00/0000:00:14.2
SysFS BusID: 0000:00:14.2
Hardware Class: sound
Model: "ATI SBx00 Azalia (Intel HDA)"
Vendor: pci 0x1002 "ATI Technologies Inc"
Device: pci 0x4383 "SBx00 Azalia (Intel HDA)"
SubVendor: pci 0x1462 "Micro-Star International Co., Ltd."
SubDevice: pci 0x7599
Driver: "HDA Intel"
Driver Modules: "snd_hda_intel"
Memory Range: 0xfcff4000-0xfcff7fff (rw,non-prefetchable)
IRQ: 16 (9465 events)
Module Alias: "pci:v00001002d00004383sv00001462sd00007599bc04sc03i00"
Driver Info #0:
Driver Status: snd_hda_intel is active
Driver Activation Cmd: "modprobe snd_hda_intel"
Config Status: cfg=new, avail=yes, need=no, active=unknown

29: PCI 100.1: 0403 Audio device
[Created at pci.318]
Unique ID: NXNs.+HJB1DcwX53
Parent ID: _Znp.ZJmKoWxd6BF
SysFS ID: /devices/pci0000:00/0000:00:02.0/0000:01:00.1
SysFS BusID: 0000:01:00.1
Hardware Class: sound
Model: "nVidia Audio device"
Vendor: pci 0x10de "nVidia Corporation"
Device: pci 0x0be4
Revision: 0xa1
Driver: "HDA Intel"
Driver Modules: "snd_hda_intel"
Memory Range: 0xfea7c000-0xfea7ffff (rw,non-prefetchable)
IRQ: 19 (143 events)
Module Alias: "pci:v000010DEd00000BE4sv00000000sd00000000bc04sc03i00"
Driver Info #0:
Driver Status: snd_hda_intel is active
Driver Activation Cmd: "modprobe snd_hda_intel"
Config Status: cfg=new, avail=yes, need=no, active=unknown
Attached to: #8 (PCI bridge)
jim@jim-MS-7599 ~ $
This is my lspci output:
00:00.0 Host bridge: ATI Technologies Inc RX780/RX790 Chipset Host Bridge
00:02.0 PCI bridge: ATI Technologies Inc RD790 PCI to PCI bridge (external gfx0 port A)
00:06.0 PCI bridge: ATI Technologies Inc RD790 PCI to PCI bridge (PCI express gpp port C)
00:11.0 SATA controller: ATI Technologies Inc SB700/SB800 SATA Controller [IDE mode]
00:12.0 USB Controller: ATI Technologies Inc SB700/SB800 USB OHCI0 Controller
00:12.1 USB Controller: ATI Technologies Inc SB700 USB OHCI1 Controller
00:12.2 USB Controller: ATI Technologies Inc SB700/SB800 USB EHCI Controller
00:13.0 USB Controller: ATI Technologies Inc SB700/SB800 USB OHCI0 Controller
00:13.1 USB Controller: ATI Technologies Inc SB700 USB OHCI1 Controller
00:13.2 USB Controller: ATI Technologies Inc SB700/SB800 USB EHCI Controller
00:14.0 SMBus: ATI Technologies Inc SBx00 SMBus Controller (rev 3c)
00:14.1 IDE interface: ATI Technologies Inc SB700/SB800 IDE Controller
00:14.2 Audio device: ATI Technologies Inc SBx00 Azalia (Intel HDA)
00:14.3 ISA bridge: ATI Technologies Inc SB700/SB800 LPC host controller
00:14.4 PCI bridge: ATI Technologies Inc SBx00 PCI to PCI Bridge
00:14.5 USB Controller: ATI Technologies Inc SB700/SB800 USB OHCI2 Controller
00:18.0 Host bridge: Advanced Micro Devices [AMD] Family 10h Processor HyperTransport Configuration
00:18.1 Host bridge: Advanced Micro Devices [AMD] Family 10h Processor Address Map
00:18.2 Host bridge: Advanced Micro Devices [AMD] Family 10h Processor DRAM Controller
00:18.3 Host bridge: Advanced Micro Devices [AMD] Family 10h Processor Miscellaneous Control
00:18.4 Host bridge: Advanced Micro Devices [AMD] Family 10h Processor Link Control
01:00.0 VGA compatible controller: nVidia Corporation GT215 [GeForce GT 240] (rev a2)
01:00.1 Audio device: nVidia Corporation High Definition Audio Controller (rev a1)
02:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168B PCI Express Gigabit Ethernet controller (rev 03)
Can anyone provide any help? To be honest, I don't know much about ALSA, or whether I'm missing something very obvious.

I can also confirm that sound works when I run Windows XP. The hardware seems to be fine. The speakers are plugged into a green (headphone?) socket on the back of the machine (motherboard) which functions properly in the other OS.

Thanks for any help.
Last edited by Bosola on Sun Nov 21, 2010 11:03 pm, edited 1 time in total.

User avatar
inktitan
Level 5
Level 5
Posts: 885
Joined: Wed Aug 18, 2010 10:51 pm
Location: Houston, Tx

Re: No Sound on Mint 10 - Realtek ALS888?

Post by inktitan » Sun Nov 21, 2010 3:23 pm

I will try to help but I too am not all that familiar with Linux Audio. Have tried alsamixer in the terminal just to make sure everything is on? Also have you tried the OSS? Which is an alternative to Alsa but it is usually the one that gives me problems. When you right click the volume icon on the panel is everything set for Alsa and does your hardware match?
Proud hugger of Penguins.
Pentium D 2.8Ghz, 3 GB RAM, 1 GB Nvidia GT 240, Linux Mint Debian
“...not the strongest...survives, nor the most intelligent... It is...the [one] most adaptable to change.”~C.D.
Please do not post new topics in [solved] topics

User avatar
mads
Level 6
Level 6
Posts: 1298
Joined: Wed Nov 03, 2010 3:44 pm
Contact:

Re: No Sound on Mint 10 - Realtek ALS888?

Post by mads » Sun Nov 21, 2010 7:04 pm

Have you checked "Sound Preferences" - "Output" - "Choose a device for sound output"?
Some times it switches to the graphic card's HDMI device which usually is not used. Switch it back and disable the HDMI device.

Bosola
Level 1
Level 1
Posts: 12
Joined: Sun Aug 08, 2010 9:15 pm

Re: No Sound on Mint 10 - Realtek ALS888?

Post by Bosola » Sun Nov 21, 2010 9:48 pm

inktitan wrote:I will try to help but I too am not all that familiar with Linux Audio. Have tried alsamixer in the terminal just to make sure everything is on? Also have you tried the OSS? Which is an alternative to Alsa but it is usually the one that gives me problems. When you right click the volume icon on the panel is everything set for Alsa and does your hardware match?
I ran Alsamixer in the terminal, and the device seemed on. Still, I turned all channels up to red, but couldn't get sound output.

I might try OSS, but I'm told it's older and less compatible.
mads wrote:Have you checked "Sound Preferences" - "Output" - "Choose a device for sound output"?
Some times it switches to the graphic card's HDMI device which usually is not used. Switch it back and disable the HDMI device.
I looked here, but it's not using the HDMI device.

I did see one thing, though - when I installed wine, I ran winecfg via terminal. When I opened the sound tab, I saw the message
fixme:mixer:ALSA_MixerInit No master control found on HDA NVidia, disabling mixer
Is something trying to use the HDMI output?

User avatar
mads
Level 6
Level 6
Posts: 1298
Joined: Wed Nov 03, 2010 3:44 pm
Contact:

Re: No Sound on Mint 10 - Realtek ALS888?

Post by mads » Sun Nov 21, 2010 10:08 pm

Bosola wrote:I did see one thing, though - when I installed wine, I ran winecfg via terminal. When I opened the sound tab, I saw the message
fixme:mixer:ALSA_MixerInit No master control found on HDA NVidia, disabling mixer
Is something trying to use the HDMI output?
Seems like your devices have identical

Code: Select all

Driver Modules: "snd_hda_intel"
which might confuse alsa-base.conf. Could you run

Code: Select all

cat /proc/asound/modules
and post the output?

Bosola
Level 1
Level 1
Posts: 12
Joined: Sun Aug 08, 2010 9:15 pm

Re: No Sound on Mint 10 - Realtek ALS888?

Post by Bosola » Sun Nov 21, 2010 10:27 pm

mads wrote: which might confuse alsa-base.conf. Could you run

Code: Select all

cat /proc/asound/modules
and post the output?
Certainly. I get:
~ $ cat /proc/asound/modules
0 snd_hda_intel
1 snd_hda_intel
Is that the sort of duplication you're thinking of?

User avatar
mads
Level 6
Level 6
Posts: 1298
Joined: Wed Nov 03, 2010 3:44 pm
Contact:

Re: No Sound on Mint 10 - Realtek ALS888?

Post by mads » Sun Nov 21, 2010 10:44 pm

Bosola wrote:Is that the sort of duplication you're thinking of?
Yes.
I've seen workarounds on the web, but don't remember where since I was not affected by it. I'll let you know if I find any.
Last edited by mads on Sun Nov 21, 2010 10:57 pm, edited 3 times in total.

Bosola
Level 1
Level 1
Posts: 12
Joined: Sun Aug 08, 2010 9:15 pm

Re: No Sound on Mint 10 - Realtek ALS888?

Post by Bosola » Sun Nov 21, 2010 10:49 pm

mads wrote:
Bosola wrote:Is that the sort of duplication you're thinking of?
Yes.
I've seen workarounds on the web, but don't remember where since I was not affected by it. I'll let you know if I find any.
Thanks. If you can remember, did they involve changing the ALSA config, disabling the HDMI output, or something entirely different?

User avatar
mads
Level 6
Level 6
Posts: 1298
Joined: Wed Nov 03, 2010 3:44 pm
Contact:

Re: No Sound on Mint 10 - Realtek ALS888?

Post by mads » Sun Nov 21, 2010 10:56 pm

Check out this link: http://ubuntuforums.org/showthread.php?t=1043568
Note that "alsa-base" in the guide should be replaced by "alsa-base.conf"

Bosola
Level 1
Level 1
Posts: 12
Joined: Sun Aug 08, 2010 9:15 pm

Re: No Sound on Mint 10 - Realtek ALS888?

Post by Bosola » Sun Nov 21, 2010 11:07 pm

mads wrote:Check out this link: http://ubuntuforums.org/showthread.php?t=1043568
Note that "alsa-base" in the guide should be replaced by "alsa-base.conf"
Thanks - I'll try that tomorrow (it's 3am over here!) and let you know if any of them work, and post the solution for others.

Bosola
Level 1
Level 1
Posts: 12
Joined: Sun Aug 08, 2010 9:15 pm

Re: No Sound on Mint 10 - Realtek ALS888?

Post by Bosola » Mon Nov 22, 2010 5:12 pm

Bosola wrote:
mads wrote:Check out this link: http://ubuntuforums.org/showthread.php?t=1043568
Note that "alsa-base" in the guide should be replaced by "alsa-base.conf"
Thanks - I'll try that tomorrow (it's 3am over here!) and let you know if any of them work, and post the solution for others.
Nothing there really seems to work. I'm looking into setting a default card, but the two modules are named the same, so forcing one into index 0 might not work. Asoundconf isn't working for some reason. I'm tired. Let me try again later.

User avatar
mads
Level 6
Level 6
Posts: 1298
Joined: Wed Nov 03, 2010 3:44 pm
Contact:

Re: No Sound on Mint 10 - Realtek ALS888?

Post by mads » Mon Nov 22, 2010 5:51 pm

Bosola wrote:I'm looking into setting a default card, but the two modules are named the same, so forcing one into index 0 might not work.
Yes. This is exactly what I have done with my cards:

Code: Select all

options snd_intel8x0 index=0
options snd_hda_intel index=1
I am not sure, but I think you would need to alias the names of the cards. I found some info here: http://alsa.opensrc.org/index.php/MultipleCards

Bosola
Level 1
Level 1
Posts: 12
Joined: Sun Aug 08, 2010 9:15 pm

Re: No Sound on Mint 10 - Realtek ALS888?

Post by Bosola » Mon Nov 22, 2010 9:54 pm

mads wrote:
Bosola wrote:I'm looking into setting a default card, but the two modules are named the same, so forcing one into index 0 might not work.
Yes. This is exactly what I have done with my cards:

Code: Select all

options snd_intel8x0 index=0
options snd_hda_intel index=1
I am not sure, but I think you would need to alias the names of the cards. I found some info here: http://alsa.opensrc.org/index.php/MultipleCards
Thanks. Unfortunately, I need the pid and vid values of the cards, and I can find no way of doing this. The command I'd insert, apparently, would be something like

Code: Select all

options snd-usb-audio index=1,2 vid=0x0ccd,0x0d8c pid=0x0028,0x000c
I did see some information here...
After installing a new graphics adapter, I can not play audio in mocp:

Code: Select all

Code:
/home/effo> mocp 
Running the server... 
Trying JACK... 
Trying ALSA... 
ALSA lib pcm_dmix.c:1010:(snd_pcm_dmix_open) unable to open slave 
Trying OSS... 

FATAL_ERROR: No valid sound driver 


FATAL_ERROR: Server exited 
It seems like the HDMI on the new graphics card is used instead of my 'real' sound card. I found another thread about Alsa order, with a link to the wiki and instructions on how to change the order of the cards. But I can't figure out how to do this if the same module is used for both cards. This is my situation:

Code: Select all

Code:
/home/effo> cat /proc/asound/cards 
 0 [HDMI           ]: HDA-Intel - HDA ATI HDMI 
                      HDA ATI HDMI at 0xdfefc000 irq 25 
 1 [VT82xx         ]: HDA-Intel - HDA VIA VT82xx 
                      HDA VIA VT82xx at 0xbfffc000 irq 17 


      Code:
/home/effo> cat /proc/asound/modules 
 0 snd_hda_intel 
 1 snd_hda_intel

      Code:
/home/effo> aplay -l 
**** List of PLAYBACK Hardware Devices **** 
card 0: HDMI [HDA ATI HDMI], device 3: ATI HDMI [ATI HDMI] 
  Subdevices: 1/1 
  Subdevice #0: subdevice #0 
card 1: VT82xx [HDA VIA VT82xx], device 0: ALC883 Analog [ALC883 Analog] 
  Subdevices: 1/1 
  Subdevice #0: subdevice #0 
card 1: VT82xx [HDA VIA VT82xx], device 1: ALC883 Digital [ALC883 Digital] 
  Subdevices: 1/1 
  Subdevice #0: subdevice #0 

I did some googling and found the ALSA wiki. Running modinfo gives me

Code: Select all

      Code:
root@siduxbox:/home/effo/# modinfo -p snd_hda_intel 
power_save_controller:Reset controller in power save mode. 
power_save:Automatic power-saving timeout (in second, 0 = disable). 
beep_mode:Select HDA Beep registration mode (0=off, 1=on, 2=mute switch on/off) (default=1). 
patch:Patch file for Intel HD audio interface. 
enable_msi:Enable Message Signaled Interrupt (MSI) 
single_cmd:Use single command to communicate with codecs (for debugging only). 
probe_only:Only probing and no codec initialization. 
probe_mask:Bitmask to probe codecs (default = -1). 
bdl_pos_adj:BDL position adjustment offset. 
position_fix:Fix DMA pointer (0 = auto, 1 = none, 2 = POSBUF). 
model:Use the given board model. 
enable:Enable Intel HD audio interface. 
id:ID string for Intel HD audio interface. 
index:Index value for Intel HD audio interface.
So no pid or vid, does this mean I have to use udev as suggested in the Alsa wiki? Or is there another way?
Unfortunately, no-one replied to him. He did solve his problem -
did some more digging on the ALSA wiki and found this script which can be used to create a .asoundrc file, which seem to be a configuration file for Alsa. If I gave VT82xx as argument to the script, Alsa actually used that card, so I could use moc to play audio.

But this was not perfect. With this setup it seemed like I got a 'collision' between Alsa and KDE. Either I could play sound on the command line, or in KDE. If I had played a song in moc, I could not get any audio in eg Youtube. If I played a clip in Iceweasel, I could not play audio in moc.

The simplest solution was to dig out an old sound card and hope it would be assigned as the first card. And I had luck - the new card became card 0, so now I have no problem playing sound. Not the most elegant solution, but at least it works!
Unfortunately, I can't get that script to work. The terminal complains that there's 'no job control in this shell' (I have no idea what that means). I did chmod u+x the script before running, and it still doesn't work. I'm also unsure how I'd specify the default sound card as an argument that script - after all, I can't call it 'snd_hda_intel'.

Any ideas on pids and vids? Is there some switch to hwinfo or lspci that might help?

User avatar
mads
Level 6
Level 6
Posts: 1298
Joined: Wed Nov 03, 2010 3:44 pm
Contact:

Re: No Sound on Mint 10 - Realtek ALS888?

Post by mads » Tue Nov 23, 2010 7:34 am

Bosola wrote:Any ideas on pids and vids? Is there some switch to hwinfo or lspci that might help?
Here are all the relevant/irrelevant commands I know:
lsusb
lspci | grep audio -vvnn
lspci -nn|egrep 'ultimedia|udio|sound|AC97|ac97|EMU'
sudo discover --vendor-id --model-id pci | uniq

Bosola
Level 1
Level 1
Posts: 12
Joined: Sun Aug 08, 2010 9:15 pm

Re: No Sound on Mint 10 - Realtek ALC888?

Post by Bosola » Wed Nov 24, 2010 7:50 am

Thanks - that worked well.

Alas, this saga isn't quite over yet. It looks like the ALSA wiki is wrong - I can't just pass PID and VID values to the alsabase.conf file. Someone else had a similar problem (http://www.linuxquestions.org/questions ... am-769626/), but they'd just forgotten to mark the PID and VID values as hex figures (I'll check tonight, but I'm pretty sure I didn't make the same error).

The alsa wiki suggests using various config files that aren't present in *buntu variants, but it looks like I might be able to use udev to do this instead. I'll keep this thread updated - I think it'll be relevant for anyone with an onboard and a graphics card HDMI that take the same module.

Bosola
Level 1
Level 1
Posts: 12
Joined: Sun Aug 08, 2010 9:15 pm

Re: No Sound on Mint 10 - Realtek ALC888?

Post by Bosola » Sun Nov 28, 2010 3:41 pm

Well, I haven't really done anything with udev, because it looks a little bit beyond me. But I have found a few interesting things using the CAT command. Here's my output:

Code: Select all

jim@jim-MS-7599 ~ $ cat /proc/asound/card0/id
NVidia
jim@jim-MS-7599 ~ $ cat /proc/asound/card1/id
HDMI
jim@jim-MS-7599 ~ $ cat /proc/asound/card2/id
cat: /proc/asound/card2/id: No such file or directory
jim@jim-MS-7599 ~ $ cat /proc/asound/modules
 0 snd_hda_intel
 1 snd_hda_intel
jim@jim-MS-7599 ~ $ cat /proc/asound/cards
 0 [NVidia         ]: HDA-Intel - HDA NVidia
                      HDA NVidia at 0xfea7c000 irq 19
 1 [HDMI           ]: HDA-Intel - HDA ATI SB
                      HDA ATI SB at 0xfcff4000 irq 16
I can see the HDMI output on the card, clear as a bell. But what about the other entry? I expected the ATI onboard sound chip to be listed, not *another* sound output associated with the graphics card (a GT240).

It's no wonder my attempts to use

Code: Select all

options snd-hda-intel id=SB index=0 
options snd-hda-intel id=HDMI index=1
won't work - they're apparently both related to the graphics card. The card has a HDMI, DVI and VGA output. Am I right in assuming that those first two carry sound?

More to the point, how would I get Mint to recognize my onboard card?

User avatar
inktitan
Level 5
Level 5
Posts: 885
Joined: Wed Aug 18, 2010 10:51 pm
Location: Houston, Tx

Re: No Sound on Mint 10 - Realtek ALC888?

Post by inktitan » Sun Nov 28, 2010 5:40 pm

I know hardware a little better than I know software so I wonder...Can you remove your Nvidia card then reconfigure your sound and disable the nvidia drivers. Then put the card back in and reconfigure/enable the nvidia driver. This may cause graphics problems but it could be an alternative solution. I don't recommend this approach just something to consider if you are comfortable. Hopefully someone can give you the better software solution.
Proud hugger of Penguins.
Pentium D 2.8Ghz, 3 GB RAM, 1 GB Nvidia GT 240, Linux Mint Debian
“...not the strongest...survives, nor the most intelligent... It is...the [one] most adaptable to change.”~C.D.
Please do not post new topics in [solved] topics

zerozero
Level 16
Level 16
Posts: 6506
Joined: Tue Jul 07, 2009 2:29 pm

Re: No Sound on Mint 10 - Realtek ALC888?

Post by zerozero » Mon Nov 29, 2010 6:03 pm

Hi Bosola i have the same card as you in a newly finish box and could get no sound out of it: aparently everything was working, no errors from players but no sound at all, i tried this fix today and it works

http://www.webupd8.org/2010/11/fix-hda- ... qus_thread

I think it worths a try
Image

[ bliss of ignorance ]

Bosola
Level 1
Level 1
Posts: 12
Joined: Sun Aug 08, 2010 9:15 pm

Re: No Sound on Mint 10 - Realtek ALC888?

Post by Bosola » Wed Dec 08, 2010 7:59 pm

Absolutely, it's worth a try. I also received a personal message from mads:
Hi Bosola!

You haven't been around for a while. It has come a good post by "zerozero".
Please check it out.

But first let me tell you that I have found something interesting,
enable=1. Maybe combined with index=0.
Of course, we knew about index=0, but not (i didn't know!) about enable=1
(and enable=0 to disable). Do you get what I mean:

options snd-hda-intel enable=1 index=0
options snd-hda-intel enable=0 index=1

or

options snd-hda-intel enable=0 index=0
options snd-hda-intel enable=1 index=1

With regards
mads
I'll give these a try ASAP. Unfortunately, my HDD has died (this is a risk with new machines), but I'll see if these work on the Live CD edition.

fixrman
Level 3
Level 3
Posts: 110
Joined: Fri Apr 20, 2007 11:25 pm
Location: Pennsylvania

Re: No Sound on Mint 10 - Realtek ALC888?

Post by fixrman » Mon Apr 11, 2011 10:08 pm

I just had this same issue with Mint 10 and I found that when I run alsamixer from Terminal it lists nVidia. That is wrong because I have a SoundBlaster! card and I believe
onboard is turned off in the BIOS. Odd.

I have noticed that the problem seems to be tied to the wireless mouse. As long as the mouse is not used, you tube videos will play to the end, and if another window is opened, mouse use does not affect the video being played.

Post Reply

Return to “Hardware Support”