K3B not recognizing any digital devices...

Questions about hardware,drivers and peripherals
Forum rules
Before you post please read how to get help
thetoolmandar
Level 1
Level 1
Posts: 2
Joined: Tue Oct 16, 2007 6:50 pm

K3B not recognizing any digital devices...

Postby thetoolmandar » Tue Oct 16, 2007 7:05 pm

I have run K3B for a couple years on Ubuntu, Mint and other linux OS. The last two times I've run Mint on my box and loaded K3B as usual, initiated for use, then whether a DVD or CD is loaded it's not recognizing. I have no problems using Sound Juicer, Goobox, Brasero or any other burn/rip programs. Help??

Husse
Level 23
Level 23
Posts: 19593
Joined: Sun Feb 11, 2007 7:22 am
Location: Near Borås Sweden

Postby Husse » Wed Oct 17, 2007 5:52 am

Welcome to Mint thetoolmandar
As you can use Brasero and others there is no "major error" I would expect that a setting has been changed in K3B
If not try to reinstall it....
It is very hard, not to say impossible, to tell what's happened without a hands on approach in a situation like this....
Image
Don't fix it if it ain't broken, don't break it if you can't fix it

nick
Level 5
Level 5
Posts: 685
Joined: Sat Dec 02, 2006 8:04 am

Postby nick » Wed Oct 17, 2007 10:51 am

Hi

What happens when you try sudo k3b?

Nick

Husse
Level 23
Level 23
Posts: 19593
Joined: Sun Feb 11, 2007 7:22 am
Location: Near Borås Sweden

Postby Husse » Wed Oct 17, 2007 3:31 pm

sudo k3b

Permissions problems - oh yes
But only do that to test!
Image
Don't fix it if it ain't broken, don't break it if you can't fix it

thetoolmandar
Level 1
Level 1
Posts: 2
Joined: Tue Oct 16, 2007 6:50 pm

K3B not recognizing any digital devices...

Postby thetoolmandar » Wed Oct 17, 2007 10:05 pm

Thank you first of all for responding to my question so quickly and for the attempts to help me through this.

Well, I tried sudo k3b and while running I was able to use the DVD drive and load a disc that was recognized.(one I knew was already burned,but a disc anyway)....... I don't know exactly what more to give out that would help troubleshoot. I did already go to the k3b site and reinstall prior to my post. Would the string that ran after initiating "sudo" command help??

You will outgrow your usefulness.
thetoolmandar@TheColdplay-desktop:~$ sudo k3b
Password:
X Error: BadDevice, invalid or uninitialized input device 167
Major opcode: 144
Minor opcode: 3
Resource id: 0x0
Failed to open device
X Error: BadDevice, invalid or uninitialized input device 167
Major opcode: 144
Minor opcode: 3
Resource id: 0x0
Failed to open device
Warning: kbuildsycoca is unable to register with DCOP.
kbuildsycoca running...
X Error: BadDevice, invalid or uninitialized input device 167
Major opcode: 144
Minor opcode: 3
Resource id: 0x0
Failed to open device
X Error: BadDevice, invalid or uninitialized input device 167
Major opcode: 144
Minor opcode: 3
Resource id: 0x0
Failed to open device
Session management error: Authentication Rejected, reason : None of the authentication protocols specified are supported and host-based authentication failed
kbuildsycoca running...
Reusing existing ksycoca
kio (KService*): WARNING: The desktop entry file /usr/share/applications/DefaultPlugins.desktop has Type=Link instead of "Application" or "Service"
kio (KService*): WARNING: Invalid Service : /usr/share/applications/DefaultPlugins.desktop
kio (KSycoca): ERROR: No database available!
Error: "/var/tmp/kdecache-thetoolmandar" is owned by uid 1000 instead of uid 0.
X Error: BadDevice, invalid or uninitialized input device 167
Major opcode: 144
Minor opcode: 3
Resource id: 0x0
Failed to open device
X Error: BadDevice, invalid or uninitialized input device 167
Major opcode: 144
Minor opcode: 3
Resource id: 0x0
Failed to open device
kdecore (KAction): WARNING: KActionCollection::KActionCollection( QObject *parent, const char *name, KInstance *instance )
thetoolmandar@TheColdplay-desktop:~$ (K3bDevice::HalConnection) initializing HAL >= 0.5
Mapping udi /org/freedesktop/Hal/devices/storage_model_DVD_LS_DW1655 to device /dev/scd0
/dev/scd0 resolved to /dev/scd0
/dev/scd0 is block device (0)
/dev/scd0 seems to be cdrom
bus: 1, id: 0, lun: 0
(K3bDevice::Device) /dev/scd0: init()
(K3bDevice::Device) /dev/scd0 feature: CD Mastering
(K3bDevice::Device) /dev/scd0 feature: CD Track At Once
(K3bDevice::Device) /dev/scd0 feature: DVD Read (MMC5)
(K3bDevice::Device) /dev/scd0 feature: DVD+R
(K3bDevice::Device) /dev/scd0 feature: DVD+RW
(K3bDevice::Device) /dev/scd0 feature: DVD+R Double Layer
(K3bDevice::Device) /dev/scd0 feature: DVD-R/-RW Write
(K3bDevice::Device) /dev/scd0 feature: Rigid Restricted Overwrite
(K3bDevice::Device) /dev/scd0 feature: Layer Jump Recording
(K3bDevice::Device) /dev/scd0 unknown profile: -1
(K3bDevice::Device) /dev/scd0: dataLen: 60
(K3bDevice::Device) /dev/scd0: checking for TAO
(K3bDevice::Device) /dev/scd0: checking for SAO
(K3bDevice::Device) /dev/scd0: checking for SAO_R96P
(K3bDevice::ScsiCommand) failed:
command: MODE SELECT (55)
errorcode: 70
sense key: ILLEGAL REQUEST (5)
asc: 26
ascq: 0
(K3bDevice::Device) /dev/scd0: checking for SAO_R96R
(K3bDevice::Device) /dev/scd0: checking for RAW_R16
(K3bDevice::Device) /dev/scd0: checking for RAW_R96P
(K3bDevice::ScsiCommand) failed:
command: MODE SELECT (55)
errorcode: 70
sense key: ILLEGAL REQUEST (5)
asc: 26
ascq: 0
(K3bDevice::Device) /dev/scd0: checking for RAW_R96R
(K3bDevice::ScsiCommand) failed:
command: GET PERFORMANCE (ac)
errorcode: 72
sense key: NO SENSE (2)
asc: 0
ascq: 0
(K3bDevice::Device) /dev/scd0: GET PERFORMANCE length det failed.
(K3bDevice::Device) /dev/scd0: Number of supported write speeds via 2A: 6
(K3bDevice::Device) /dev/scd0 : 8467 KB/s
(K3bDevice::Device) /dev/scd0 : 7056 KB/s
(K3bDevice::Device) /dev/scd0 : 5645 KB/s
(K3bDevice::Device) /dev/scd0 : 4234 KB/s
(K3bDevice::Device) /dev/scd0 : 2822 KB/s
(K3bDevice::Device) /dev/scd0 : 2117 KB/s
(K3bDevice::DeviceManager) setting current write speed of device /dev/scd0 to 3324
Devices:
------------------------------
Blockdevice: /dev/scd0
Generic device:
Vendor: BENQ
Description: DVD LS DW1655
Version: BCDB
Write speed: 3324
Profiles: DVD-ROM, DVD-R Sequential, DVD-R Dual Layer Sequential, DVD-R Dual Layer Jump, DVD-RW Restricted Overwrite, DVD-RW Sequential, DVD+RW, DVD+R, DVD+R Dual Layer, CD-ROM, CD-R, CD-RW
Read Cap: DVD-ROM, DVD-R, DVD-R Sequential, DVD-R Dual Layer, DVD-R Dual Layer Sequential, DVD-R Dual Layer Jump, DVD-RW, DVD-RW Restricted Overwrite, DVD-RW Sequential, DVD+RW, DVD+R, DVD+RW Dual Layer, DVD+R Dual Layer, CD-ROM, CD-R, CD-RW
Write Cap: DVD-R, DVD-R Sequential, DVD-R Dual Layer, DVD-R Dual Layer Sequential, DVD-R Dual Layer Jump, DVD-RW, DVD-RW Restricted Overwrite, DVD-RW Sequential, DVD+RW, DVD+R, DVD+R Dual Layer, CD-R, CD-RW
Writing modes: SAO, TAO, RAW, SAO/R96R, RAW/R16, RAW/R96R, Restricted Overwrite, Layer Jump
Reader aliases: /dev/scd0
------------------------------
removing udi /org/freedesktop/Hal/devices/volume_empty_dvd_r
kdecore (KAction): WARNING: KActionCollection::operator+=(): function is severely deprecated.
X Error: BadDevice, invalid or uninitialized input device 167
Major opcode: 144
Minor opcode: 3
Resource id: 0x0
Failed to open device
X Error: BadDevice, invalid or uninitialized input device 167
Major opcode: 144
Minor opcode: 3
Resource id: 0x0
Failed to open device
kbuildsycoca running...
First sec data area: 43:41:33 (LBA 196608) (402653184
Last sec data area: 488:37:40 (LBA 2198815) (4503173120 Bytes)
Last sec layer 1: 00:00:00 (LBA 0) (0 Bytes)
Layer 1 length: 00:00:01 (LBA 1) (2048 Bytes)
Layer 2 length: 488:37:40 (LBA 2198815) (4503173120 Bytes)
DiskInfo:
Mediatype: DVD-R Sequential
Current Profile: DVD-R Sequential
Disk state: incomplete
Empty: 0
Rewritable: 0
Appendable: 1
Sessions: 1
Tracks: 1
Layers: 1
Capacity: 510:38:38 (LBA 2297888) (4706074624 Bytes)
Remaining size: 65:42:30 (LBA 295680) (605552640 Bytes)
Used Size: 444:56:08 (LBA 2002208) (4100521984 Bytes)
(K3bDevice::ScsiCommand) failed:
command: GET PERFORMANCE (ac)
errorcode: 72
sense key: NO SENSE (2)
asc: 0
ascq: 3
(K3bDevice::Device) /dev/scd0: GET PERFORMANCE length det failed.
(K3bDevice::ScsiCommand) failed:
command: MODE SENSE (5a)
errorcode: 0
sense key: NO SENSE (2)
asc: 0
ascq: 0
(K3bDevice::Device) /dev/scd0: MODE SENSE length det failed.
(K3bDevice::ScsiCommand) failed:
command: MODE SENSE (5a)
errorcode: 0
sense key: NO SENSE (2)
asc: 0
ascq: 0
(K3bDevice::Device) /dev/scd0: MODE SENSE with real length 65535 failed.
(K3bDevice::ScsiCommand) failed:
command: SET SPEED (bb)
errorcode: 0
sense key: NO SENSE (2)
asc: 0
ascq: 0
(K3bDevice::ScsiCommand) failed:
command: READ (10) (28)
errorcode: 0
sense key: NO SENSE (2)
asc: 0
ascq: 0
(K3bDevice::Device) /dev/scd0: READ 10 failed!
(K3bDevice::ScsiCommand) failed:
command: READ (10) (28)
errorcode: 0
sense key: NO SENSE (2)
asc: 0
ascq: 0
(K3bDevice::Device) /dev/scd0: READ 10 failed!
(K3bDevice::ScsiCommand) failed:
command: READ (10) (28)
errorcode: 0
sense key: NO SENSE (2)
asc: 0
ascq: 0
(K3bDevice::Device) /dev/scd0: READ 10 failed!
(K3bDevice::ScsiCommand) failed:
command: READ (10) (28)
errorcode: 0
sense key: NO SENSE (2)
asc: 0
ascq: 0
(K3bDevice::Device) /dev/scd0: READ 10 failed!
(K3bDevice::ScsiCommand) failed:
command: READ (10) (28)
errorcode: 0
sense key: NO SENSE (2)
asc: 0
ascq: 0
(K3bDevice::Device) /dev/scd0: READ 10 failed!
(K3bDevice::ScsiCommand) failed:
command: READ (10) (28)
errorcode: 0
sense key: NO SENSE (2)
asc: 0
ascq: 0
(K3bDevice::Device) /dev/scd0: READ 10 failed!
(K3bDevice::ScsiCommand) failed:
command: READ (10) (28)
errorcode: 0
sense key: NO SENSE (2)
asc: 0
ascq: 0
(K3bDevice::Device) /dev/scd0: READ 10 failed!
(K3bDevice::ScsiCommand) failed:
command: READ (10) (28)
errorcode: 0
sense key: NO SENSE (2)
asc: 0
ascq: 0
(K3bDevice::Device) /dev/scd0: READ 10 failed!
(K3bDevice::ScsiCommand) failed:
command: READ (10) (28)
errorcode: 0
sense key: NO SENSE (2)
asc: 0
ascq: 0
(K3bDevice::Device) /dev/scd0: READ 10 failed!
(K3bDevice::ScsiCommand) failed:
command: READ (10) (28)
errorcode: 0
sense key: NO SENSE (2)
asc: 0
ascq: 0
(K3bDevice::Device) /dev/scd0: READ 10 failed!

Husse
Level 23
Level 23
Posts: 19593
Joined: Sun Feb 11, 2007 7:22 am
Location: Near Borås Sweden

Postby Husse » Thu Oct 18, 2007 6:21 am

It seems to be a problem with permissions, both as sudo k3b worked and from the error message
Check permissons for a mounted CD/DVD and tell us what you get
Image
Don't fix it if it ain't broken, don't break it if you can't fix it

User avatar
tino097
Level 1
Level 1
Posts: 4
Joined: Thu Oct 11, 2007 4:20 pm
Location: Macedonia

Postby tino097 » Mon Nov 05, 2007 7:58 pm

ok, i have same problem, and i get same response after reading advices above

but how to check permissions on mounted device ???

thanks

Husse
Level 23
Level 23
Posts: 19593
Joined: Sun Feb 11, 2007 7:22 am
Location: Near Borås Sweden

Postby Husse » Tue Nov 06, 2007 7:52 am

A CD/DVD should appear on the desktop and you can just right click it > Permissions tab. "Others" should be allowed to access files
Image
Don't fix it if it ain't broken, don't break it if you can't fix it

User avatar
tino097
Level 1
Level 1
Posts: 4
Joined: Thu Oct 11, 2007 4:20 pm
Location: Macedonia

Postby tino097 » Tue Nov 06, 2007 3:14 pm

and how to manage that?

chmod og+rw /dev/hdd

???

Husse
Level 23
Level 23
Posts: 19593
Joined: Sun Feb 11, 2007 7:22 am
Location: Near Borås Sweden

Postby Husse » Tue Nov 06, 2007 7:11 pm

You are right - I just thought of this as a way to see if it did go wrong. If it indeed was a permissions problem I would have to think more...
Even if I am the main support person here I still am a relative newcomer to Linux, so sometimes I have to take one or two steps more than the "real guru" :)
Image
Don't fix it if it ain't broken, don't break it if you can't fix it

User avatar
tino097
Level 1
Level 1
Posts: 4
Joined: Thu Oct 11, 2007 4:20 pm
Location: Macedonia

Postby tino097 » Wed Nov 07, 2007 6:08 pm

ok, its working right now

thanks for help


Return to “Hardware Support”

Who is online

Users browsing this forum: No registered users and 8 guests