No SOUND !!

Questions about hardware,drivers and peripherals
Forum rules
Before you post please read how to get help
youngbud84
Level 1
Level 1
Posts: 7
Joined: Thu Dec 02, 2010 2:03 pm

No SOUND !!

Post by youngbud84 »

Hi, am new to linux mint i been a using ubuntu for about 4 yrs. I installed Mint on My Laptop nd i Love it, But Theres Only one little Major Problem I have no sounds..
i been googlin for the past month nd have not found a solution.. Pls Help..

Code: Select all

lspci
00:00.0 Host bridge: Intel Corporation Core Processor DRAM Controller (rev 18)
00:02.0 VGA compatible controller: Intel Corporation Core Processor Integrated Graphics Controller (rev 18)
00:16.0 Communication controller: Intel Corporation 5 Series/3400 Series Chipset HECI Controller (rev 06)
00:1a.0 USB Controller: Intel Corporation 5 Series/3400 Series Chipset USB2 Enhanced Host Controller (rev 06)
00:1b.0 Audio device: Intel Corporation 5 Series/3400 Series Chipset High Definition Audio (rev 06)
00:1c.0 PCI bridge: Intel Corporation 5 Series/3400 Series Chipset PCI Express Root Port 1 (rev 06)
00:1c.1 PCI bridge: Intel Corporation 5 Series/3400 Series Chipset PCI Express Root Port 2 (rev 06)
00:1c.2 PCI bridge: Intel Corporation 5 Series/3400 Series Chipset PCI Express Root Port 3 (rev 06)
00:1c.5 PCI bridge: Intel Corporation 5 Series/3400 Series Chipset PCI Express Root Port 6 (rev 06)
00:1d.0 USB Controller: Intel Corporation 5 Series/3400 Series Chipset USB2 Enhanced Host Controller (rev 06)
00:1e.0 PCI bridge: Intel Corporation 82801 Mobile PCI Bridge (rev a6)
00:1f.0 ISA bridge: Intel Corporation Mobile 5 Series Chipset LPC Interface Controller (rev 06)
00:1f.2 SATA controller: Intel Corporation 5 Series/3400 Series Chipset 4 port SATA AHCI Controller (rev 06)
00:1f.3 SMBus: Intel Corporation 5 Series/3400 Series Chipset SMBus Controller (rev 06)
00:1f.6 Signal processing controller: Intel Corporation 5 Series/3400 Series Chipset Thermal Subsystem (rev 06)
02:00.0 Network controller: Atheros Communications Inc. AR9285 Wireless Network Adapter (PCI-Express) (rev 01)
04:00.0 System peripheral: JMicron Technology Corp. SD/MMC Host Controller (rev 80)
04:00.2 SD Host controller: JMicron Technology Corp. Standard SD Host Controller (rev 80)
04:00.3 System peripheral: JMicron Technology Corp. MS Host Controller (rev 80)
04:00.4 System peripheral: JMicron Technology Corp. xD Host Controller (rev 80)
04:00.5 Ethernet controller: JMicron Technology Corp. JMC250 PCI Express Gigabit Ethernet Controller (rev 03)
ff:00.0 Host bridge: Intel Corporation Core Processor QuickPath Architecture Generic Non-core Registers (rev 05)
ff:00.1 Host bridge: Intel Corporation Core Processor QuickPath Architecture System Address Decoder (rev 05)
ff:02.0 Host bridge: Intel Corporation Core Processor QPI Link 0 (rev 05)
ff:02.1 Host bridge: Intel Corporation Core Processor QPI Physical 0 (rev 05)
ff:02.2 Host bridge: Intel Corporation Core Processor Reserved (rev 05)
ff:02.3 Host bridge: Intel Corporation Core Processor Reserved (rev 05)
Image

Image

Thx in hadvance..

lauren
Level 5
Level 5
Posts: 602
Joined: Thu Nov 26, 2009 10:50 am

Re: No SOUND !!

Post by lauren »

Hi youngbud84!
To help we must know some details. Please post the output of:
1.

Code: Select all

lsb_release -rd
and
2.

Code: Select all

uname -a
3. Your Desktop;
if you have Gnome:

Code: Select all

gnome-about
lauren
lauren
Notebook: BIOS Linux multiboot
Netbook: EFI Linux multiboot

User avatar
mads
Level 6
Level 6
Posts: 1296
Joined: Wed Nov 03, 2010 3:44 pm
Contact:

Re: No SOUND !!

Post by mads »

Hi!

The screenshots you've attached shows that your sound card is not recognized, so you need to install Open Sound System (OSS) which is an alternative to pulseaudio and ALSA. And you are lucky, your card is supported.

I don't know if you are running Linux Mint or Mint Debian (LMDE). If you have installed Linux Mint, check out this guide: https://help.ubuntu.com/community/OpenSound.
Personally, I don't like that guide because it gives too much information and is somewhat confusing. So, perhaps you should look for a better guide, but I just wanted to give you a hint.

If you are running LMDE, check out the Debian forums.

youngbud84
Level 1
Level 1
Posts: 7
Joined: Thu Dec 02, 2010 2:03 pm

Re: No SOUND !!

Post by youngbud84 »

thx for the reply... i downgraded to

Code: Select all

Description:	Linux Mint 9 Isadora
Release:	9
The sounds works Fine now i have a New problem every time i plug in my Headphone the speaks still keep on playing..

thx...

User avatar
mads
Level 6
Level 6
Posts: 1296
Joined: Wed Nov 03, 2010 3:44 pm
Contact:

Re: No SOUND !!

Post by mads »

Try this. In a terminal window, run

Code: Select all

gksudo gedit /etc/modprobe.d/alsa-base.conf
and add this line at the end of the file:

Code: Select all

options snd-hda-intel model=auto
Save the file and reboot.

If it doesn't work:
1. What brand is your laptop?
2. Post the output of this command: "inxi -A"

youngbud84
Level 1
Level 1
Posts: 7
Joined: Thu Dec 02, 2010 2:03 pm

Re: No SOUND !!

Post by youngbud84 »

mads wrote:Try this. In a terminal window, run

Code: Select all

gksudo gedit /etc/modprobe.d/alsa-base.conf
and add this line at the end of the file:

Code: Select all

options snd-hda-intel model=auto
Save the file and reboot.

If it doesn't work:
1. What brand is your laptop?
2. Post the output of this command: "inxi -A"
It Didn't work..

Code: Select all

-mint ~ $ inxi -A
Audio:     Card Intel 5 Series/3400 Series Chipset High Definition Audio driver HDA Intel
           Sound: Advanced Linux Sound Architecture Version 1.0.21

User avatar
mads
Level 6
Level 6
Posts: 1296
Joined: Wed Nov 03, 2010 3:44 pm
Contact:

Re: No SOUND !!

Post by mads »

mads wrote: If it doesn't work:
1. What brand is your laptop?
You didn't write that! :D
Figure it out by yourself, the list is here: http://www.kernel.org/doc/Documentation ... Models.txt
Change model=MODEL with the model that corresponds to your laptop/sound card.

youngbud84
Level 1
Level 1
Posts: 7
Joined: Thu Dec 02, 2010 2:03 pm

Re: No SOUND !!

Post by youngbud84 »

Asus k52F laptop

User avatar
mads
Level 6
Level 6
Posts: 1296
Joined: Wed Nov 03, 2010 3:44 pm
Contact:

Re: No SOUND !!

Post by mads »

youngbud84 wrote:Asus k52F laptop
Try:
options snd-hda-intel model=asus
If not work, try
options snd-hda-intel model=asus-mode3
if not work, try
options snd-hda-intel model=laptop

lauren
Level 5
Level 5
Posts: 602
Joined: Thu Nov 26, 2009 10:50 am

Re: No SOUND !!

Post by lauren »

Hi youngbud!
Maybe you find something useful here: (I know, Sabayon is not Mint, but I would read it)
http://wiki.sabayon.org/index.php?title ... ound_Cards
or
http://www.mjmwired.net/kernel/Documentation/sound/alsa
lauren
lauren
Notebook: BIOS Linux multiboot
Netbook: EFI Linux multiboot

User avatar
mads
Level 6
Level 6
Posts: 1296
Joined: Wed Nov 03, 2010 3:44 pm
Contact:

Re: No SOUND !!

Post by mads »

Hi lauren.
The problem he is facing now is:
youngbud84 wrote:The sounds works Fine now i have a New problem every time i plug in my Headphone the speaks still keep on playing..

youngbud84
Level 1
Level 1
Posts: 7
Joined: Thu Dec 02, 2010 2:03 pm

Re: No SOUND !!

Post by youngbud84 »

mads wrote: Try:
options snd-hda-intel model=asus
If not work, try
options snd-hda-intel model=asus-mode3
if not work, try
options snd-hda-intel model=laptop
it didnt work thx for replys...

LinuxFan83
Level 1
Level 1
Posts: 6
Joined: Tue Dec 28, 2010 11:33 pm

Re: No SOUND !!

Post by LinuxFan83 »

Hello. I also have an Asus K52F laptop and was wondering if anyone found a solution to the original problem, sound not working at all in Linux Mint 10. I find it very odd that it would work in 9 and not 10.

lspci returns this: 00:1b.0 Audio device: Intel Corporation 5 Series/3400 Series Chipset High Definition Audio (rev 06)

Just an FYI, I've only used LM 10 in live CD. I'm a tad reluctant to install it unless I know I can get the sound problems resolved. Perhaps the fix(es) require a reboot, and thus would require full installation of the OS. I just thought I'd see if anyone has any ideas going forward. Thanks in advance.

Also, to the OP (youngbud84), the issue with the internal speaker not muting when plugging in headphones, I have had this exact same issue when using Linux Mint 9 in Live CD, and also using installs of Ubuntu 10.04, and PCLinux OS 2010.10 (GNOME). A poster on the Ubuntu forums posted a fix, and it worked great for me in both Ubuntu and PCLinux OS. I haven't tested it in Mint 9 yet, but I'd imagine it would likely work, IF your audio is being controlled by ALSA. Let me know if you still have the issue and I will gladly post the fix.

LinuxFan83
Level 1
Level 1
Posts: 6
Joined: Tue Dec 28, 2010 11:33 pm

Re: No SOUND !!

Post by LinuxFan83 »

An update.

I am now getting sound on Linux Mint 10. (on the asus k52f laptop). For those who aren't getting sound in linux mint 10 on this laptop, try the following.

First, I added this line to the /etc/modprobe.d/alsa-base.conf file, at the bottom.

Code: Select all

options snd-hda-intel index=0 model=asus-laptop
Then, I added these two lines to the /etc/rc.local file

Code: Select all

rmmod snd_hda_intel
modprobe snd_hda_intel
Add these before the exit 0 line.

Save the files, Reboot, and see if that fixes it.

In addition to performing these steps, I also upgraded all packages in the Mint Update Manager, including packages at level 5, which include linux kernel versions and generic headers. If the above steps do not resolve your issue, I would suggest using the mint updater to update all packages, including the kernel-related packages listed at level 4 and 5. Yes, there is a risk associated with doing this, but sometimes nothing ventured nothing gained. I did these upgrades on a fresh install on Mint, so I really had nothing to lose. I cannot say for sure whether or not me doing these upgrades had a factor in getting the sound to work, but I thought I should atleast mention it.

The good news is that I now have audio on my Linux Mint install. The bad news is that now I am in the exact same boat as the original poster is in Mint 9. That is, my headphones do not work. My fix that I mentioned above that resolves the issue in Ubuntu and PCLinux OS, does not resolve the issue in LinuxMint 10. Now, when I plug my headphone jack in, the internal speaker does mute, but I hear no audio through my headphones. I tried adding this line to alsa-base.conf

Code: Select all

options snd-hda-intel enable_msi=1
No joy there.

If anyone has any ideas I'd appreciate it. Thank you.

deo11187
Level 1
Level 1
Posts: 3
Joined: Fri Jan 14, 2011 10:34 am

Re: No SOUND !!

Post by deo11187 »

First, thank you everyone, and linuxfan83; I'd still be clueless without what was posted here before.
So, what I did to get the headphones working was adding the following to /etc/modprobe.d/alsa-base.conf

Code: Select all

 options snd-hda-intel model=ideapad 
I can't confirm if this did anything for the microphone, however, I don't have one.

LinuxFan83
Level 1
Level 1
Posts: 6
Joined: Tue Dec 28, 2010 11:33 pm

Re: No SOUND !!

Post by LinuxFan83 »

SInce my last update, I have been distro hopping a bit and decided to revisit Mint 10 and this issue. I discovered that you do actually have to upgrade all the packages (including level 5 ones) in order to get the sound to work. (in addition to the changes I mentioned above). Also, thank you deo11187, your fix for the headphones worked. Haven't tested it with the microphone (i rarely use a mic).

With these sound issues fixed, Linux Mint 10 appears to be a great OS and I look forward to continued use of it. Hopefully these sound issues will be directly fixed in Mint 11.

hugogone
Level 1
Level 1
Posts: 8
Joined: Tue Feb 01, 2011 4:04 pm

Re: No SOUND !!

Post by hugogone »

i am having the same problem so if i can get a walk through that would b great i just need to kno what all i hav to do and post im useing a toshiba satellite p105-6064 modle pspau0-06t01m

hugogone
Level 1
Level 1
Posts: 8
Joined: Tue Feb 01, 2011 4:04 pm

Re: No SOUND !!

Post by hugogone »

been at it yet half a day again today and still no sound i got the driver installed it updated it everything i can think of and still no sound so plz help any help is better than none

tora201
Level 1
Level 1
Posts: 2
Joined: Sun Feb 20, 2011 8:56 pm

Re: No SOUND !!

Post by tora201 »

A long shot (this worked on my Acer 753 with the same problems outlined in this thread)

Open a terminal: sudo gedit /etc/modprobe.d/blacklist-custom

and put one line:

blacklist intel_ips

Save, and re-boot. Sound should (might) work. It worked for me.

source: https://help.ubuntu.com/community/AspireOne/AO753h

ginjabunny
Level 3
Level 3
Posts: 144
Joined: Sun Mar 09, 2008 4:04 pm
Location: West London, UK

Re: No SOUND !!

Post by ginjabunny »

I have just installed Mint10 Gnome Amd64 with all the updates on my Asus X52F with Intel Corporation 5 Series/3400 Series audio and I have sound, but the headphones were not cutting out the speakers so thanks to deo11187 you saved me lots of effort as "options snd-hda-intel model=ideapad" works for me (-:

GB

Post Reply

Return to “Hardware Support”