Page 1 of 1

HP Mini 3000 Series Audio Workaround

Posted: Tue Jun 14, 2011 3:01 pm
by zacklyke
So if you're like me, and I hope for your sake you're not, you've stumbled upon the fact after nearly 6 months of ownership that your HP Mini 3000 series does in fact have on board speakers. To my credit I didn't really use the machine until a couple weeks ago when I started traveling. Seems to be an issue with an incorrect alsa driver.

Additional hardware tested: 1000 series, also worked.
Builds tested for success: Isadora, Julia, Katya & LMDE.

I thought I'd post here and I'll also be linking to this forum page in my update to this particular model (110-3135dx) on the Community page.

Code: Select all

sudo apt-get install alsa-source module-assistant
sudo gedit /etc/alsa/alsa-source.conf
Make sure Line 11 of alsa-source.conf reads:

Code: Select all

ALSA_CARDS=”hda-intel”
Change the line to match (it might say ALL CARDS) or something of that nature, save and exit.
Enter this as your final command:

Code: Select all

sudo m-a a-i alsa-source
Reboot your machine. Should be all you need to do.
Cheers,
Zack

Re: HP Mini 3000 Series Audio Workaround

Posted: Tue Jun 14, 2011 8:13 pm
by TBABill
Alsa-source is in the repos. Would that version work as well instead of adding a Jaunty PPA?

Re: HP Mini 3000 Series Audio Workaround

Posted: Tue Jun 14, 2011 9:39 pm
by zacklyke
Should be. I'm going to edit my original post to shorten things up. This was admittedly the first workaround I tried that completed the task. Thanks for the input!

Either way it's still easier than going through Ubuntu's 10 & 11 sound diagnostics... eesh.
https://help.ubuntu.com/community/Sound ... gProcedure

Re: HP Mini 3000 Series Audio Workaround

Posted: Wed Jun 15, 2011 12:21 pm
by TBABill
I have trouble with one of my machines with sound. I always have to edit /etc/modprobe.d/alsa-base.conf and add this as the last line so it will enable my sound:

Code: Select all

options snd-hda-intel index=0 model=touchsmart
for my HP Touchsmart computer.