disable mouse clicks with touchpad

Questions about hardware,drivers and peripherals
Forum rules
Before you post please read how to get help
Post Reply
User avatar
motoperpetuo
Level 1
Level 1
Posts: 42
Joined: Mon Feb 11, 2008 7:38 pm
Location: Denver

disable mouse clicks with touchpad

Post by motoperpetuo »

i'm looking for specific steps on how to disable mouse clicks with the touchpad on my dell inspiron 15r, under mint 11 64-bit. the cursor and focus jump around a lot when i type, which makes it very difficult to write anything. my understanding is that this is because the touchpad is hypersensitive and i'm accidentally executing mouse clicks with it, which seems like a good explanation. i've googled around and seen suggestions that the option to execute mouse clicks with the touchpad can be disabled, but i don't see the setting in mouse settings or anywhere else, and i haven't found any specific instructions. there is an option on this laptop to disable the touchpad with F3, but although hitting F3 does bring up a little popup image of a touchpad with a red X over it, it doesn't seem to do anything else, and the touchpad continues to work as before.

i'd greatly appreciate any help with this. if i can get this resolved, this laptop should be pretty good, whereas for now it's barely useable.
Singing is a trick to make people listen to music for longer than they normally would.
User avatar
jose_r
Level 1
Level 1
Posts: 19
Joined: Fri Jul 08, 2011 9:24 am

Re: disable mouse clicks with touchpad

Post by jose_r »

User avatar
motoperpetuo
Level 1
Level 1
Posts: 42
Joined: Mon Feb 11, 2008 7:38 pm
Location: Denver

Re: disable mouse clicks with touchpad

Post by motoperpetuo »

thank you for your post, jose. definitely a step in the right direction (look at me, typing now without going crazy and swearing because my cursor is jumping all over the place). nevertheless, does anyone know how to just disable mouse clicks from the touchpad, without disabling the entire touchpad? that would be my ideal, because i often like to use the touchpad instead of the mouse, just never for clicking.
Singing is a trick to make people listen to music for longer than they normally would.
User avatar
jose_r
Level 1
Level 1
Posts: 19
Joined: Fri Jul 08, 2011 9:24 am

Re: disable mouse clicks with touchpad

Post by jose_r »

Hi again,
syndaemon does exactly what you want (and it is easier to setup than the previous solution :oops: )

See this
http://embraceubuntu.com/2006/09/20/dis ... en-typing/

Or do "man syndaemon" in the terminal and figure it out by yourself :)
User avatar
Aging Technogeek
Level 13
Level 13
Posts: 4578
Joined: Sun Jan 11, 2009 9:54 am
Location: Right about here

Re: disable mouse clicks with touchpad

Post by Aging Technogeek »

What you want to do should be doable without installing anything.

Check Menu=>Preferences=>Mouse. Click the "Touchpad" tab and you should find two selections under the General heading. You can turn off clicks entirely or just while typing.
Registered Linux User 483387
User avatar
motoperpetuo
Level 1
Level 1
Posts: 42
Joined: Mon Feb 11, 2008 7:38 pm
Location: Denver

Re: disable mouse clicks with touchpad

Post by motoperpetuo »

thanks for the two additional replies. one thing i've never understood is that i don't have a touchpad tab under mouse preferences, neither in mint, nor in ubuntu, although i've found many forum posts that refer to it. is there some way to make it appear?

as for the other solution, i'm off to work now, but i'll try it when i get home tonight. thanks again for helping me out with this, everyone.
Singing is a trick to make people listen to music for longer than they normally would.
User avatar
Aging Technogeek
Level 13
Level 13
Posts: 4578
Joined: Sun Jan 11, 2009 9:54 am
Location: Right about here

Re: disable mouse clicks with touchpad

Post by Aging Technogeek »

Try this.

Open either Package Manager or Software Manager and enter "gpointing-device-settings" (without the quotes) in the search box and install it.

This should give you the control you want over the touchpad.

Sorry I did not come up with this sooner, but it has been a while since I last used it.
Registered Linux User 483387
User avatar
motoperpetuo
Level 1
Level 1
Posts: 42
Joined: Mon Feb 11, 2008 7:38 pm
Location: Denver

Re: disable mouse clicks with touchpad

Post by motoperpetuo »

Aging Technogeek wrote:Try this.

Open either Package Manager or Software Manager and enter "gpointing-device-settings" (without the quotes) in the search box and install it.

This should give you the control you want over the touchpad.

Sorry I did not come up with this sooner, but it has been a while since I last used it.
thanks again for your help. I installed "gpointing-device settings" though synaptic as you suggested, but i don't see where the setting is to disable mouse clicks through the touchpad. should i have a "touchpad" tab in preferences >> mouse now (i don't, even after a reboot), or would that setting be somewhere else?

as for running /usr/bin/syndaemon -t -d as the other poster suggested, it doesn't seem to work at all. maybe i'm doing something wrong. at least i'm able to type now by totally disabling the touchpad with jose's suggestion, but if i can get to where i can just disable mouse clicks through the touchpad, i'll be a very, very happy man (sometimes it's nice to use the touchpad instead of the mouse).
Singing is a trick to make people listen to music for longer than they normally would.
User avatar
Aging Technogeek
Level 13
Level 13
Posts: 4578
Joined: Sun Jan 11, 2009 9:54 am
Location: Right about here

Re: disable mouse clicks with touchpad

Post by Aging Technogeek »

With gpointing-device-settings installed, you should have a menu entry "Preferences=>Pointing Devices". Click the tab for "Tapping". The first line should be "Disable Tapping".

If you do not have this on your install, check the left column and let me know if your touchpad is identified there and if so, what does it say. For example, on the Acer netbook I am using as a test bed, the touchpad is identified as a "SynPS/2 Synaptics Touchpad".
Registered Linux User 483387
User avatar
Aging Technogeek
Level 13
Level 13
Posts: 4578
Joined: Sun Jan 11, 2009 9:54 am
Location: Right about here

Re: disable mouse clicks with touchpad

Post by Aging Technogeek »

I tried to check the specs on the Dell Inspiron 15r and found that it is a fairly new system. You may be seeing a problem that occurs occasionally where the Linux kernel drivers have not yet caught up with the latest hardware. It may not be possible with the kernel used in Mint 11 to do what you want due to incomplete support of the newest touchpad.

If this is the case, you could try installing the 2.6.39 kernel using the procedure outlined here:

http://forums.linuxmint.com/viewtopic.p ... 85&start=0

Or wait a few months until Mint 12 comes out (most likely in November) with (probably) the 3.* kernel and see if that curesthe problem.
Registered Linux User 483387
User avatar
motoperpetuo
Level 1
Level 1
Posts: 42
Joined: Mon Feb 11, 2008 7:38 pm
Location: Denver

Re: disable mouse clicks with touchpad

Post by motoperpetuo »

yeah, i think my hardware might just be too new. i checked out the pointing devices settings you mentioned, but there isn't any tapping tab. i'll try upgrading my kernel later on. also, syndaemon seems to work if i run it as root. this is getting into another topic, but where should i put

Code: Select all

/usr/bin/syndaemon -t -d
to run it as root every time i log in?
Singing is a trick to make people listen to music for longer than they normally would.
User avatar
jose_r
Level 1
Level 1
Posts: 19
Joined: Fri Jul 08, 2011 9:24 am

Re: disable mouse clicks with touchpad

Post by jose_r »

To run any command as root put it on /etc/rc.local, before the "exit 0" command.
Post Reply

Return to “Hardware Support”