Page 1 of 1

Asus, WIRED Atheros network not working

Posted: Thu Nov 24, 2011 11:59 pm
by 440roadrunner
Hi again after a long absence. Since last, it's been mostly.....Ubuntu

Short version of long story. Ubuntu, worked great untilll.........Unity. I don't think so

Bought new Asus U56E laptop, tried several distros, including Kubuntu, Suse, and now have settled on Mint (I hope) after a long absence of about 5? years

Everything seems OK except the Atheros WIRED ethernet

(Actually the Intel? wireless MAY have a problem or may be router, suffer disconnects, but that, later)

I need help, a step--by step through this problem. I've Googled around found a now DEAD link to Atheros drivers (changed by Qualcom)

When I ran the DVD live on this 'puter, WIRED worked. When I first installed it, it worked. Now, it won't connect. I've checked the connection by:

disconnecting the router, hooking directly to the cable modem.

and hooking the cable modem to two other computers and they both work OK. In fact, both are running Mint, one is a Dell desktop the other a Thinkpad T-61 with a PCMCIA network card. (The internal card does not work in it, yet, either. That, later)

So in conclusion, I need step by step help for an Atheros WIRED network card. It seems to be a 1083??

Re: Asus, WIRED Atheros network not working

Posted: Fri Nov 25, 2011 12:33 am
by mank_in
Try use lspci to know if your network card is working
Open terminal : lspci
Try look at control center>additional driver ,maybe you need a proprietary driver for your network card.
I see the forum about this type of laptop , but no one seem have a wired problem. ... 16#p491916
Good Luck :)

Re: Asus, WIRED Atheros network not working

Posted: Fri Nov 25, 2011 3:12 am
by 440roadrunner
Thanks for your reply. I tried another router, and so far the intermittent disconnects on wireless SEEM to have been a router problem. We'll see after some more use

The command you posted gives the controller:

04:00.0 Ethernet controller: Atheros Communications Device 1083 (rev c0)

Going to control center, it shows "none in use" and finds no proprietary ones.

I've tested the "new" router, wired works with other computers, just not this Asus. (Same cable)

Wireless so far works OK. The problem I have with wireless is that I've had trouble with security settings, and would just as soon use wired.

Where from here?

Re: Asus, WIRED Atheros network not working

Posted: Fri Nov 25, 2011 5:38 am
by AlbertP
Device 1083 (aka Atheros AR8151 v2.0) is not yet fully working with Linux. Perhaps there is a driver available somewhere on the web.

On a Russian forum I found this command. I can't read Russian so I can't read exactly what it said, but I think it might be working.

Code: Select all

sudo sh -c 'echo "1969 1083" > /sys/bus/pci/drivers/atl1c/new_id'
By the way, you can run sudo update-pciids to update the list of lspci device names, to get AR8151 v2.0 instead of Device 1083.

Re: Asus, WIRED Atheros network not working

Posted: Fri Nov 25, 2011 8:02 pm
by 440roadrunner
After thrashing around unsuccessfully, with some 4 different USED Linksys routers (got them cheap,) I went back to the original Netgear router, all reset as "default."

For no good reason, wireless has been connected OK through the day.

WIRED is still not working.

I Googled your "Russian" and think I found the page, l translated?? ... md%3Dimvns

but I don't know what to do with the command you posted.

I did run the suggested update command, and indeed, the device now shows as

Atheros Communications Inc. AR8151 v2.0 Gigabit Ethernet (rev c0)

On the Russian page he mentioned something about a "driver e1000e" but I haven't come up with anything there.

Still Googlin' around with the problem...............

NOTE much of the problem seems to be with out-of-date threads, the link for downloading the Atheros driver no longer works, as Qualcom has changed things......