wireless blinking led

Questions about hardware,drivers and peripherals
Forum rules
Before you post please read how to get help
mr_sudaca
Level 1
Level 1
Posts: 2
Joined: Sun Feb 19, 2012 6:27 pm

wireless blinking led

Postby mr_sudaca » Sun Feb 19, 2012 6:32 pm

I recently installed mint 12, also installed broadcom drivers and now each time I log in into a wireless network the wifi led keeps blinking. Is there a way to disable led or something?
p.s: i'm using a lenovo g450

User avatar
sagirfahmid3
Level 6
Level 6
Posts: 1044
Joined: Sun Sep 04, 2011 12:39 pm

Re: wireless blinking led

Postby sagirfahmid3 » Sun Feb 19, 2012 7:04 pm

It's supposed to. No, you can't disable it (it is related to hardware). I have a Lenovo G550 and it's absolutely normal. Are you so bothered by that light blinking? :roll:

mr_sudaca
Level 1
Level 1
Posts: 2
Joined: Sun Feb 19, 2012 6:27 pm

Re: wireless blinking led

Postby mr_sudaca » Sun Feb 19, 2012 7:35 pm

sagirfahmid3 wrote:It's supposed to. No, you can't disable it (it is related to hardware). I have a Lenovo G550 and it's absolutely normal. Are you so bothered by that light blinking? :roll:



well, it's pretty annoying cuz it never stop (unless i turn off wifi)... well, maybe i can cover it with duct tape or something...

Vulcanor
Level 1
Level 1
Posts: 2
Joined: Tue Feb 21, 2012 9:43 am
Contact:

Re: wireless blinking led

Postby Vulcanor » Tue Feb 21, 2012 9:48 am

Try this:
1. Create (or open) the file /etc/modprobe.d/iwlagn.conf

Code: Select all

sudo gedit /etc/modprobe.d/iwlagn.conf


2. Enter the following line in that file

Code: Select all

options iwlagn led_mode=1


3. Save the file and reboot your system

This worked for me. It's based on https://bugs.launchpad.net/linuxmint/+bug/823791
Everything you want to know => http://www.tomdesair.com/

Vulcanor
Level 1
Level 1
Posts: 2
Joined: Tue Feb 21, 2012 9:43 am
Contact:

Re: wireless blinking led

Postby Vulcanor » Tue Apr 17, 2012 12:28 pm

Since update pack 4 of LMDE (kernel 3.2) the above fix didn't work any more for me.
But I've found a new fix:

Code: Select all

sudo -i
echo 'options iwlwifi led_mode=1' >> /etc/modprobe.d/wlan.conf
modprobe -r iwlwifi && modprobe iwlwifi

If this doesn't work, if posted other possible solutions on http://www.tomdesair.com/blog/2012/04/stop-the-blinking-wireless-led-in-linux/
Everything you want to know => http://www.tomdesair.com/

bigian
Level 1
Level 1
Posts: 2
Joined: Fri Jun 01, 2012 7:00 pm

Re: wireless blinking led

Postby bigian » Tue Jul 03, 2012 12:48 pm

Vulcanor wrote:Since update pack 4 of LMDE (kernel 3.2) the above fix didn't work any more for me.
But I've found a new fix:

Code: Select all

sudo -i
echo 'options iwlwifi led_mode=1' >> /etc/modprobe.d/wlan.conf
modprobe -r iwlwifi && modprobe iwlwifi

If this doesn't work, if posted other possible solutions on http://www.tomdesair.com/blog/2012/04/stop-the-blinking-wireless-led-in-linux/


Thx Vulcanor!

This workd for me!

AlbertP
Level 16
Level 16
Posts: 6709
Joined: Sun Jan 30, 2011 12:38 pm
Location: Utrecht, The Netherlands

Re: wireless blinking led

Postby AlbertP » Tue Jul 03, 2012 1:01 pm

For Intel wireless that may work, yes, but the OP has Broadcom.
Registered Linux User #528502
Image
Feel free to correct me if I'm trying to write in Spanish, French or German.

keithtempleman
Level 1
Level 1
Posts: 1
Joined: Fri Nov 06, 2015 11:49 am

Re: wireless blinking led

Postby keithtempleman » Fri Nov 06, 2015 11:51 am

Just to say thank you, the fix to /etc/modprobe.d/wlan.conf worked for me on a Dell E5410 laptop.

User avatar
Thrasher88
Level 1
Level 1
Posts: 10
Joined: Wed Mar 09, 2016 8:09 am

Re: wireless blinking led

Postby Thrasher88 » Thu Mar 17, 2016 10:48 am

Kernel version greater or equal to 3.2.0

Put this text

options iwlwifi led_mode=1

in the following file (possibly you have to create the file):

Linux Mint (Debian) or Ubuntu: /etc/modprobe.d/wlan.conf
Arch Linux: /etc/modprobe.d/modprobe.conf

Now restart your system or reload the WiFi driver using:
sudo -i
modprobe -r iwlwifi && modprobe iwlwif


This worked for me perfectly / HP 6730b - 17.3 Cinnamon 64bit
HP 6730b
Linux Mint 17.3 "Rosa" - Cinnamon (64 bit)


Return to “Hardware Support”

Who is online

Users browsing this forum: No registered users and 5 guests