"The disk drive is not ready yet" during boot

Forum rules
Before you post please read this
Level 1
Level 1
Posts: 6
Joined: Thu Aug 15, 2013 1:06 am

"The disk drive is not ready yet" during boot

Postby Drisc0 » Sun Sep 29, 2013 2:25 am

Hi guys,

So I've got 3 hds in my system. There's the OS on my SSD, and then two other drives for storage. I've tried setting them up to mount on boot and get presented with an error message saying:

Code: Select all

The disk drive for /mnt/[drive name] is not ready yet or not present.
Continue to wait, or Press S to skip mounting or M for manual recovery

It does this for both storage drives. They mount fine once I am into the system. How can I get these to properly automount on boot? The results of sudo blkid gives me:

Code: Select all

/dev/sda1: LABEL="Storage Drive" UUID="4e0aa3c2-cc00-46f3-a649-357c543cdaaf" TYPE="ext4"
/dev/sdb1: LABEL="SSD" UUID="537d678b-5c87-4569-b60d-c28996a00fe4" TYPE="ext4"
/dev/sdb5: UUID="5b69dbb3-6c8c-4ab2-a21b-63fecb28b11b" TYPE="swap"
/dev/sdc1: LABEL="Data Drive" UUID="d92e23f5-9ce6-41d2-9da3-33c9dd0b7d85" TYPE="ext4"

My fstab file is setup like this:

Code: Select all

# /etc/fstab: static file system information.
# Use 'blkid' to print the universally unique identifier for a
# device; this may be used with UUID= as a more robust way to name devices
# that works even if disks are added and removed. See fstab(5).
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
# / was on /dev/sda1 during installation
UUID=537d678b-5c87-4569-b60d-c28996a00fe4 /               ext4    errors=remount-ro 0       1
# swap was on /dev/sda5 during installation
UUID=5b69dbb3-6c8c-4ab2-a21b-63fecb28b11b none            swap    sw              0       0
LABEL=Data\040Drive /mnt/Data\040Drive auto nosuid,nodev,nofail,x-gvfs-show 0 0
LABEL=Storage\040Drive /mnt/Storage\040Drive auto nosuid,nodev,nofail,x-gvfs-show 0 0

Is there something I should change in my fstab file to get this working properly?

Mute Ant
Level 12
Level 12
Posts: 4105
Joined: Tue Sep 03, 2013 7:45 pm

Re: "The disk drive is not ready yet" during boot

Postby Mute Ant » Thu May 01, 2014 2:05 pm

Nothing wrong with Linux+GNU, apparently, since the drives mount after boot. Linux on its own can handle ext3 file systems. It might be a bit provocative having spaces in the drive labels and using them as mount identifiers with escaped characters...


...may be the part Linux is choking on. Try...

LABEL="Data Drive"

or, better...


You know what you want. I see what you want, Linux has a problem. It smells a bit...buggy Baldrick.
Armageddon only happens once, you know. They don’t let you go around again until you get it right.

Level 3
Level 3
Posts: 167
Joined: Mon Aug 03, 2009 3:26 am
Location: Pembrokeshire, South West Wales

Re: "The disk drive is not ready yet" during boot

Postby bigal » Fri Jun 06, 2014 3:12 pm

Just a couple of thoughts.
Have you tried altering the labels so there are no spaces, use an underscore?
How about changing the backslashes to forward slashes in fstab
Is there a password issue?

Return to “Mounting Partitions”