320gb HDD shows as 140.7 TB drive w/14.1 gb free space ????

Forum rules
Before you post please read this
Im Mintified
Level 1
Level 1
Posts: 1
Joined: Fri Jun 29, 2012 12:50 pm

320gb HDD shows as 140.7 TB drive w/14.1 gb free space ????

Postby Im Mintified » Fri Jun 29, 2012 1:40 pm

This is not a joke. I'm laughing too, kinda.

I have a dual boot (windows 7 and Mint 13) acer aspire with a 320gb HDD but I am having problems. Everything seems to be working OK but I feel it boots slowly. I tried looking around but didn't find anything with this specific problem but some of it is similar to others.

shows up in "computer" as "file system" as a140.7 TB some contents unreadable.
320gb HDD shows as 140.7 TB drive w/ 14.1 gb free space but it is a new install and no way has 100gb on it, etc

I cleaned, defrag, and shrunk the C: drive in windows (it is the far right drive on windows screen) then installed using Mint13 64 BIT ISO.
I tried to partition using these approximate sizes:
/ (root) ~20gb
swap ~8gb (I have 4gb RAM but I figured I would need to resize later when add more)
/home ~114 gb (the rest of the drive)
note: restarting Windows 7 did not check drives at boot
In windows only 6 drives are showing ( a recovery drive, windows C:, and a smaller other windows and the three Linux drives (all as primary))

Here is fdisk -l

Disk /dev/sda: 320.1 GB, 320072933376 bytes
255 heads, 63 sectors/track, 38913 cylinders, total 625142448 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 4096 bytes
I/O size (minimum/optimal): 4096 bytes / 4096 bytes
Disk identifier: 0xa1b87ab0

Device Boot Start End Blocks Id System
/dev/sda1 2048 37750783 18874368 27 Hidden NTFS WinRE
/dev/sda2 * 37750784 37955583 102400 7 HPFS/NTFS/exFAT
/dev/sda3 37955584 342071295 152057856 7 HPFS/NTFS/exFAT
/dev/sda4 342073342 625141759 141534209 5 Extended
Partition 4 does not start on physical sector boundary.
/dev/sda5 342073344 381132799 19529728 83 Linux
/dev/sda6 381134848 397133823 7999488 82 Linux swap / Solaris
/dev/sda7 397135872 625141759 114002944 83 Linux

I did some looking around and tried this also:
sudo fdisk /dev/sda4
fdisk: unable to read /dev/sda4: Inappropriate ioctl for device
~ $ sudo fdisk /dev/sda5
Device contains neither a valid DOS partition table, nor Sun, SGI or OSF disklabel
Building a new DOS disklabel with disk identifier 0xba616558.
Changes will remain in memory only, until you decide to write them.
After that, of course, the previous content won't be recoverable.

Warning: invalid flag 0x0000 of partition table 4 will be corrected by w(rite)

The device presents a logical sector size that is smaller than
the physical sector size. Aligning to a physical sector (or optimal
I/O) size boundary is recommended, or performance may be impacted.

Command (m for help): w
The partition table has been altered!

Calling ioctl() to re-read partition table.

WARNING: Re-reading the partition table failed with error 22: Invalid argument.
The kernel still uses the old table. The new table will be used at
the next reboot or after you run partprobe(8) or kpartx(8)
Syncing disks.

I only see sda4 in fdisk -l

Linux and partitioning are both new to me. Please help.

Level 16
Level 16
Posts: 6715
Joined: Sun Jan 30, 2011 12:38 pm
Location: Utrecht, The Netherlands

Re: 320gb HDD shows as 140.7 TB drive w/14.1 gb free space ?

Postby AlbertP » Mon Jul 02, 2012 4:00 am

You can use the GParted program (from Software Manager > Featured) to manage partitions: you often don't need to use fdisk terminal commands.
Registered Linux User #528502
Feel free to correct me if I'm trying to write in Spanish, French or German.

Return to “Mounting Partitions”