Linux Mint unable to mount partition after resizing

Forum rules
Before you post please read this
Level 1
Level 1
Posts: 1
Joined: Wed Jun 05, 2013 1:22 am

Linux Mint unable to mount partition after resizing

Postby phelenon » Wed Jun 05, 2013 1:31 am

I wanted to shrink the windows partition and increase the D drive.I slept and forgot to plug in my laptop and I dont know if it was completed or not.So today I woke up and when tried to open D it gave me the following error:"Sorry, could not display all the contents of "Data": Error when getting information for file '/media/phelenon/Data/zorin-os-6.3-core-64.iso': Input/output error" I opened Gparted and everything looked normal.Is this because my partition is nfts.
Thanks in advance

Mark Phelps
Level 7
Level 7
Posts: 1763
Joined: Mon Jun 10, 2013 4:39 pm

Re: Linux Mint unable to mount partition after resizing

Postby Mark Phelps » Mon Jun 17, 2013 4:26 pm

Well, basically, it's because you used a Linux utility on a Windows filesystem -- but it's more than just messing around with NTFS partitions using GParted, because that's not enough to cause problems. Starting with Vista, MS changed the internals of NTFS as it is used in their OS partitions, to the degree that using any non-Windows utilities on these risks corrupting the Windows boot process.

You might be lucking and it's just an example of the "dirty bit" being set on the NTFS partition and Linux, in order to prevent "further" filesystem damage, refusing to mount the partition.

What you need to do is run CHKDSK on that partition -- which you can only do from MS Windows or a Windows utility boot disk. One of the best of the latter is the Minitool Partition Wizard Boot CD, which you can get for FREE. Download the ISO, burn the CD, boot from it -- and use the option to Check the filesystem.

Level 1
Level 1
Posts: 5
Joined: Sun Jun 27, 2010 2:25 pm

Re: Linux Mint unable to mount partition after resizing

Postby TJGeezer » Mon Jul 01, 2013 10:02 pm

I had the same D-Bus problem so I downloaded MiniTool Partition Wizard CD (it's up to v8 now), burned the ISO with Brasero, booted to it and watched it come up... in Linux. Made me smile.

Linux or not, it worked. Both the little fallback NTFS partitions I'd set aside just in case, are readable now. GParted team, take note - if MiniTool does that under Linux, GParted could too. Presumably. (But what do I know?)

Anyway, thanks for the only tip I came across that was both written in readable English and actually worked. Now I'm finally out of Windows. Gotta fix Grub and let VirtualBox or PlayOnLinux run any Windows program I need. POL even runs MS Word, Excel and PowerPoint right from the desktop, though I like Libre Office just as much.

And now I have accessible spare NTFS partitions sitting there empty but accessible. Made so by MiniTools running under Linux. Yup - still makes me smile.

The free ISO can be accessed by links at ... le-cd.html if anyone else needs it.

Return to “Mounting Partitions”

Who is online

Users browsing this forum: No registered users and 2 guests