Cant se a partition changed to FAT32 from NTFS - solved

Forum rules
Before you post please read this
Post Reply
Husse
Level 23
Level 23
Posts: 18701
Joined: Sun Feb 11, 2007 7:22 am
Location: Near Borås Sweden

Cant se a partition changed to FAT32 from NTFS - solved

Post by Husse » Thu Mar 01, 2007 2:52 pm

I want to share my Mozilla profiles with XP and found a "how to".
I have dual boot with a second hdd just for backup and the Windows swap file.
According to this "how to" you should set up a FAT32 partition as write to NTFS is still unstable.
Q1) Is this correct or outdated information?
I thought ok lets make the small (approx 7 GB) partition for the swap file on the second disk a FAT32 partition, not NTFS any more. But after that it "disapperared" and it is not automounted at boot.
To confuse me further I read that devices in /etc/fstab will not be automounted but ALL partitions are mentioned there and all but one automounted...
The partition is found in /etc/fstab as a NTFS partition, that has not changed
I did comment out that entry, but no change....
I added a line with the partition as vfat. I copied the existing line and edited it to look like another FAT32 partition - no change.
The line looks like this: "UUID=0A445ED7445EC4DB /media/sdb1 vfat defaults,utf8,umask=007,gid=46 0 1"
Q2) Is this the correct procedure to update /etc/fstab?
I have been able to mount the partition, I can see it in Gparted as mounted, /dev/sdb1 is mounted as /media/sdb1
(In a terminal sudo mount -t vfat /dev/sdb1 /media/sdb1)
In spite of that it is still not visible under "Computer" so I can't open it.
Q3) Am I doing something wrong?
Q4) Can I get permission to write to the partition? For obvious reasons I have not been able to test chmod/chown. In an answer from Clem in another post about chown and FAT32 he gives the advice to look at mintdisk, but the only options I see there are to automount or not to automount and where to mount. I quote Clem:"if you're basically trying to get read/write access to your FAT32 partition make sure to look at mintDisk."
I'm at a loss here :)
I've solved problems with disappearing disks/partitions in Windows at times before so Linux is not alone :)
Last edited by Husse on Fri Mar 02, 2007 2:26 pm, edited 1 time in total.
Image
Don't fix it if it ain't broken, don't break it if you can't fix it

User avatar
Hiko96786
Level 1
Level 1
Posts: 34
Joined: Sun Feb 25, 2007 1:43 pm
Location: Wahiawa, Hi
Contact:

FSTAB

Post by Hiko96786 » Thu Mar 01, 2007 4:23 pm

Aloha,
Can you please post your fstab and the output of the mount command?
Mahalo,
Edward

Husse
Level 23
Level 23
Posts: 18701
Joined: Sun Feb 11, 2007 7:22 am
Location: Near Borås Sweden

Post by Husse » Thu Mar 01, 2007 5:25 pm

Yepp!
Mount gives this:
----------------------------------------------------
/dev/sda2 on / type ext3 (rw,errors=remount-ro)
proc on /proc type proc (rw,noexec,nosuid,nodev)
/sys on /sys type sysfs (rw,noexec,nosuid,nodev)
varrun on /var/run type tmpfs (rw,noexec,nosuid,nodev,mode=0755)
varlock on /var/lock type tmpfs (rw,noexec,nosuid,nodev,mode=1777)
procbususb on /proc/bus/usb type usbfs (rw)
udev on /dev type tmpfs (rw,mode=0755)
devshm on /dev/shm type tmpfs (rw)
devpts on /dev/pts type devpts (rw,gid=5,mode=620)
/dev/sda1 on /media/sda1 type ntfs (rw,nls=utf8,umask=007,gid=46)
/dev/sda4 on /media/sda4 type ntfs (rw,nls=utf8,umask=007,gid=46)
/dev/sdb5 on /media/sdb5 type vfat (rw,utf8,umask=007,gid=46)
binfmt_misc on /proc/sys/fs/binfmt_misc type binfmt_misc (rw)
tmpfs on /lib/modules/2.6.17-11-generic/volatile type tmpfs (rw,mode=0755)

----------------------------------------------

and fstab looks like this:

------------------------------------------------------------------

# /etc/fstab: static file system information.
#
# <file system> <mount point> <type> <options> <dump> <pass>
proc /proc proc defaults 0 0
# /dev/sda2
UUID=3873c033-ae71-4523-a8e7-3e7b01aa62e9 / ext3 defaults,errors=remount-ro 0 1
# /dev/sda1
UUID=A42C6E042C6DD23A /media/sda1 ntfs defaults,nls=utf8,umask=007,gid=46 0 1
# /dev/sda4
UUID=86748758748749BF /media/sda4 ntfs defaults,nls=utf8,umask=007,gid=46 0 1
# /dev/sdb1
# UUID=0A445ED7445EC4DB /media/sdb1 ntfs defaults,nls=utf8,umask=007,gid=46 0 1
UUID=0A445ED7445EC4DB /media/sdb1 vfat defaults,utf8,umask=000,gid=46 0 1
# /dev/sdb5
UUID=FFB7-D432 /media/sdb5 vfat defaults,utf8,umask=007,gid=46 0 1
# /dev/sda5
UUID=3e34ddec-3a65-4b81-8273-d978c42d8a6b none swap sw 0 0
/dev/hda /media/cdrom0 udf,iso9660 user,noauto 0 0
/dev/hdd /media/cdrom1 udf,iso9660 user,noauto 0 0
/dev/ /media/floppy0 auto rw,user,noauto 0 0

----------------------------------------------------------------
The problematic partition is UUID=0A445ED7445EC4DB /media/sdb1
The ntfs version was inserted when I installed, the vfat version has been added and edited by hand
Image
Don't fix it if it ain't broken, don't break it if you can't fix it

User avatar
Hiko96786
Level 1
Level 1
Posts: 34
Joined: Sun Feb 25, 2007 1:43 pm
Location: Wahiawa, Hi
Contact:

FAT32

Post by Hiko96786 » Thu Mar 01, 2007 6:19 pm

Aloha,
Ok looking it over I can see nothing myself that looks like it is out of order. I am not a linux guru though. Did you do a mount -a to reread the fstab and remount everything or reboot? As for permissions to read/write umask sets that, and you have it at 000 which is allowing read/write access to all users. If you have edited and rebooted or remounted then we need to look elsewhere.
Also note you can use an NTFS drive as ntfs-3g will allow you read/write access to and NTFS partition. Mint already has this built in. Reading your post closely it looks like you are mounting the partition manually but it is not there automatically. For fstab to update you have to reboot or type mount -a
-a Mount all filesystems (of the given types) mentioned in fstab. You would porbably have to do a

Code: Select all

sudo mount -a
enter your password, and that should work.
If not let's continue to work at it.
Mahalo,
Edward

Husse
Level 23
Level 23
Posts: 18701
Joined: Sun Feb 11, 2007 7:22 am
Location: Near Borås Sweden

Post by Husse » Thu Mar 01, 2007 7:11 pm

MintDisk is set to mount FAT32 partitions automatically, but it is not mounted. I have mounted it manually (with success as far as I understand from Gparted) but still not visible. The output of "sudo mount -a" is "The special unit /dev/disk/by-uuid/0A445ED7445EC4DB does not exist" and this is the troublesome partition. I could try reformatting it to NTFS and edit fstab accordingly, but it's past midnight here and I'm getting tired so that's for tomorrow
Image
Don't fix it if it ain't broken, don't break it if you can't fix it

Husse
Level 23
Level 23
Posts: 18701
Joined: Sun Feb 11, 2007 7:22 am
Location: Near Borås Sweden

Post by Husse » Fri Mar 02, 2007 9:53 am

It seems I've gone against my signature - I can't fix it :)
I think I might have misunderstood how mintDisk works. It is not a gismo that mounts everything, only things like an USB stick or a hdd that can be disconncted or the like.What's in "fstab" is mounted some other way - am I right?
I reformatted the partition to ntfs and I have mounted it with the mount command i a terminal, it can be seen as mounted i GParted (/dev/sdb1 is mounted as /media/sdb1 and this is exactly as the other, and visible, partition on that disk is mounted, apart from the obvious fact that the number is different, 5 in this case.) The disk has no flags.
When problems of this kind appears in Windows it is (almost) always the registry that is messed up and I can solve it, mostly anyway, but now...
Is information on mount stored elsewhere and interfering? That's the only thing I can think of now
Image
Don't fix it if it ain't broken, don't break it if you can't fix it

User avatar
Hiko96786
Level 1
Level 1
Posts: 34
Joined: Sun Feb 25, 2007 1:43 pm
Location: Wahiawa, Hi
Contact:

Mounting

Post by Hiko96786 » Fri Mar 02, 2007 1:36 pm

The UUID= at the beggining confuses me. Maybe you should eliminate that and got with the standard
/dev/sdb5 /mount/shared_drive etc... instead of having the UUID. That UUID may be there to identify the drive and since you have changed it since, it don't recognize it anymore?
So something like this maybe?
# /dev/sdb5
/dev/sdb5 /media/sdb5 ntfs defaults,nls=utf8,umask=007,gid=46 0 1
I hope that helps.
Mahalo,
Edward

Husse
Level 23
Level 23
Posts: 18701
Joined: Sun Feb 11, 2007 7:22 am
Location: Near Borås Sweden

Post by Husse » Fri Mar 02, 2007 2:26 pm

Thanks - that did it!
I remeber reading that UUID is to replace an earlier method - I suppose the one you proposed.
There's even a 115GB removable disk automounted :)
and visible.
It seems that the UUID has changed. As it is OK now I'm not going to dig deeper - note my signature :)
Image
Don't fix it if it ain't broken, don't break it if you can't fix it

User avatar
Hiko96786
Level 1
Level 1
Posts: 34
Joined: Sun Feb 25, 2007 1:43 pm
Location: Wahiawa, Hi
Contact:

Awesome

Post by Hiko96786 » Fri Mar 02, 2007 3:02 pm

Aloha,
It is awesome that it worked. I am glad it resolved for you. When I started out I actually did two partitions for myself. Back then I was using Fedora Core 4. I loaded it on both partitions and shared the swap and a small partition for a text document on what I did to get things to work. That way I had a play/break/fix/expendable partition and my regular one that got customized as I figured things out. Having the ability to break and then fix things or play around with things, as it were, helped me learn a lot.
Mahalo,
Edward

Post Reply

Return to “Mounting Partitions”