NTFS Read/Write access with Mintdisk

Forum rules
Before you post please read this
Post Reply
creosote7
Level 1
Level 1
Posts: 4
Joined: Fri Mar 16, 2007 8:49 am

NTFS Read/Write access with Mintdisk

Post by creosote7 » Fri Mar 16, 2007 9:11 am

I'm fairly new to linux and just installed Bianca. I'm very impressed with it and the great job Clem and others have done. I've read through all the forums trying to figure out my Mintdisk issue. After logging in through the GDM Mintdisk mounts my existing Windows NTFS partition fine...but I only have read access. Mintdisk Frontend options are set to the default: Mount type: ntf-3g Mount Options: defaults,locale=en_US.utf8

So after reading similar problems in the forum I went to my /etc/fstab and commented out my NTFS partition and restarted Linux. Now when I log into GDM my NTFS partition doesn't even get mounted or showup on the desktop?

As you can see my NTFS partition is commented out of fstab, but the Mintdisk.log still shows that the NTFS partition (/dev/sda1) is managed by fstab?

Below is a my fstab and mintdisk.log:

# /etc/fstab: static file system information.
#
# <file system> <mount point> <type> <options> <dump> <pass>
proc /proc proc defaults 0 0
# /dev/sda3
UUID=c5e578d6-9c4b-4c63-814e-fb486972a719 / ext3 defaults,errors=remount-ro 0 1
# /dev/sda1
#UUID=60B631F90F873B69 /media/sda1 ntfs defaults,nls=utf8,umask=007,gid=46 0 1
# /dev/sda2
UUID=3751-5B7F /media/sda2 vfat defaults,utf8,umask=007,gid=46 0 1
# /dev/sda5
UUID=3d488b1c-5873-4480-9813-3427298633b9 none swap sw 0 0
/dev/hda /media/cdrom0 udf,iso9660 user,noauto 0 0

#######################################

Mintdisk.log

------------------------
* checking the presence of os-prober...
-- os-prober is absent
-------------------------
* checking system environment...
-- user = wpetit
-- home = /home/wpetit
-- locale = en_US.UTF-8
-------------------------
* configuring options...
-- mount point: /media/<<DEVICE>>
-- show links: Yes
-- links location: /home/wpetit/Desktop/
-------------------------
* loading support for FAT32...
-- partition type = b
-- mount type = vfat
-- mount options = iocharset=utf8,umask=000
* loading support for FAT32 (LBA)...
-- partition type = c
-- mount type = vfat
-- mount options = iocharset=utf8,umask=000
* loading support for NTFS...
-- partition type = 7
-- mount type = ntfs-3g
-- mount options = defaults,locale=en_US.utf8
-------------------------
* removing existing links (if any)...
-------------------------
* scanning partitions...
-- detected device /dev/sda1 of type 7 and size 52GB
=> no alias defined
=> partition managed by /etc/fstab
-- detected device /dev/sda2 of type c and size 7GB
=> no alias defined
=> partition managed by /etc/fstab
-- detected device /dev/sda3 of type 83 and size 15GB
=> partition type not supported
-- detected device /dev/sda4 of type 5 and size 1GB
=> partition type not supported
-- detected device /dev/sda5 of type 82 and size 1GB
=> partition type not supported

Husse
Level 23
Level 23
Posts: 18701
Joined: Sun Feb 11, 2007 7:22 am
Location: Near Borås Sweden

Post by Husse » Sat Mar 17, 2007 10:45 am

This is most likely due to the UUID thing.
I've solved a similar prolem by changing the UUID to dev,
in your case instead of
UUID=60B631F90F873B69 /media/sda1 you use
/dev/sda1 /media/sda1
I beleive UUID is the future, but it changes when you make basic things like resizing a partition and adding a new one.Then you get sda1 and sda2 but the UUID of sda1 may have changed.
And pls note that ntfs-3g is not the default. Restrict write permissions to your Windows from Mint and vice versa (of course you must use third party software in Windows)
(You did not have ntfs-3g in fstab)
Hope you understand me, I'm really tired right now :)
Image
Don't fix it if it ain't broken, don't break it if you can't fix it

creosote7
Level 1
Level 1
Posts: 4
Joined: Fri Mar 16, 2007 8:49 am

Post by creosote7 » Sat Mar 17, 2007 12:49 pm

I tried your recommendation by removing the UUID and putting in /dev/sda1 in the fstab file. However, from all the posts I've read it seems that you are supposed to comment your NTFS partition in fstab because Mintdisk will ignore partitions that are already managed by fstab?

Please help...I've been at this for a week now and can't get it figured out.

thanks.

Husse
Level 23
Level 23
Posts: 18701
Joined: Sun Feb 11, 2007 7:22 am
Location: Near Borås Sweden

Post by Husse » Sat Mar 17, 2007 5:08 pm

I think you've misunderstood a bit. I did so myself a few weeks ago when I was new to mint. Mintdisk is there to mount "disks" (like USB flash drives) that appear and disappear. Disks that are always present are mounted in fstab.
You should have
/dev/sda1 /media/sda1 ntfs defaults,nls=utf8,umask=007,gid=46 0 1
not commented out, it will be mounted (if it is ntfs)
As for why the disk is not mounted by Mintdisk I don't know, but possibly Mintdisk does not mount with the option -3g

//edit//Haven't checked a ntfs disk mounted by mintdisk, but I think it's mounted r/w without the option -3g//
You have to edit a bit in fstab if you want write permissions to a "permanent disk"
Image
Don't fix it if it ain't broken, don't break it if you can't fix it

creosote7
Level 1
Level 1
Posts: 4
Joined: Fri Mar 16, 2007 8:49 am

Post by creosote7 » Sat Mar 17, 2007 9:30 pm

Thanks Husse for the followup... Maybe we can review here to make sure I'm not missing something. I have setup my fstab just like you said and the ntfs partition (sda1) is not commented out. When I reboot this ntfs partition shows up on my desktop. When I try to access it I am limited to read only on the folders/files. Isn't Mintdisk what makes it show up on my desktop? So why is it read-only when Mintdisk is configured to use ntfs-3g? Do I need to just forget Mintdisk and use a different method to read/write to this partition?

thanks,

Husse
Level 23
Level 23
Posts: 18701
Joined: Sun Feb 11, 2007 7:22 am
Location: Near Borås Sweden

Post by Husse » Sun Mar 18, 2007 8:09 am

No, not by mintdisk when it's found in fstab that's how it's mounted. You have an option somewhere (can't remember now) to have the disk on your desktop or not - I prefer not and turned it of from the beginning.
If you want to give your ntfs write you just add -3g in fstab and give write permission so you get
/dev/sda1 /media/sda1 ntfs-3g defaults,nls=utf8,umask=000,gid=46 0 1

I.e. you have to change umask as well
Image
Don't fix it if it ain't broken, don't break it if you can't fix it

User avatar
clem
Level 12
Level 12
Posts: 4125
Joined: Wed Nov 15, 2006 8:34 am
Contact:

Post by clem » Tue Mar 20, 2007 12:08 pm

Hi,

I wish I had read this thread earlier, this is a trivial problem.

mintDisk doesn't mount partitions that are present in fstab (commented out, or not). The reason for this is simple, you can :
- have the partition mounted by fstab (by setting it up in fstab)
- have the partition mounted by mintDisk (by removing all occurences of the partition name in fstab)
- have the partition not mounted at all (by having the name in fstab but commented out).

So, basically all you need to do is "remove" the lines referring to your partition from fstab, reboot and it will be picked up by mintDisk in read/write mode.

Clem

Husse
Level 23
Level 23
Posts: 18701
Joined: Sun Feb 11, 2007 7:22 am
Location: Near Borås Sweden

Post by Husse » Tue Mar 20, 2007 12:59 pm

My mistake - obviously I have not read carefully enough :)
//edit
Clem, it might be a good idea to state in mintdisk that it does not mount partitions that are present in /etc/fstab in any form, commented or not. I find it natural that something that's commented is not used by any program, just by humans. It's easy to make the mistake I made in this thread and I have not found any info on mintdisk other than the text in mintdisk itself, but I probably just missed it :)
But the way you can regulate what happens is nice :)
Image
Don't fix it if it ain't broken, don't break it if you can't fix it

User avatar
clem
Level 12
Level 12
Posts: 4125
Joined: Wed Nov 15, 2006 8:34 am
Contact:

Post by clem » Wed Mar 21, 2007 7:07 am

To be honest it's just laziness... mintDisk should have an "ignore list" or a way for you to configure partitions you don't want to see mounted. Since it already checked fstab, the comment way is just a trick to push mintDisk into thinking it's taken care of by fstab and so to make it ignore your partition ;)

Not very pretty I know.. :)

Clem

TheFullEffect
Level 1
Level 1
Posts: 6
Joined: Wed Jan 24, 2007 10:15 pm

Post by TheFullEffect » Tue Apr 17, 2007 12:17 am

clem wrote:To be honest it's just laziness... mintDisk should have an "ignore list" or a way for you to configure partitions you don't want to see...

Clem
Amen.

Post Reply

Return to “Mounting Partitions”