Partition not mounted

Forum rules
Before you post please read this
Locked
Husse
Level 23
Level 23
Posts: 18701
Joined: Sun Feb 11, 2007 7:22 am
Location: Near Borås Sweden

Partition not mounted

Post by Husse » Tue Mar 20, 2007 4:50 pm

It's no big deal, but a NTFS partition I just created does not show up. I have deleted and created the partition quite a few times now when experimenting with Mint.
I always back up everything daily (to another disk) so if I screw up I'll be back, so I can play around.
The partition is not mentioned in fstab in any way. I just learned that even a commented presence stops mintdisk from mounting :)
I have mindtisk set up to mount FAT32 and NTFS partitions
but it does not appear.
If I try to mount it manually (sudo mount /dev/sda4) I get an error message stating that /dev/sda4 cannot be found in /etc/fstab or /etc/mtab
/dev/sda4 is found i GParted.
Image
Don't fix it if it ain't broken, don't break it if you can't fix it

User avatar
clem
Level 12
Level 12
Posts: 4125
Joined: Wed Nov 15, 2006 8:34 am
Contact:

Post by clem » Wed Mar 21, 2007 7:09 am

you need to restart X... mintDisk only runs after you log in through GDM.

Clem

Husse
Level 23
Level 23
Posts: 18701
Joined: Sun Feb 11, 2007 7:22 am
Location: Near Borås Sweden

Post by Husse » Wed Mar 21, 2007 7:39 am

Of course I've restarted :)
It does not show up anywhere except GParted
The situation is still as described.
I don't need acces to the partition so it's no hurry, but in the long run I want a solution
Image
Don't fix it if it ain't broken, don't break it if you can't fix it

User avatar
clem
Level 12
Level 12
Posts: 4125
Joined: Wed Nov 15, 2006 8:34 am
Contact:

Post by clem » Wed Mar 21, 2007 7:40 am

Can you paste the content of the mintDisk log file ?

Husse
Level 23
Level 23
Posts: 18701
Joined: Sun Feb 11, 2007 7:22 am
Location: Near Borås Sweden

Post by Husse » Wed Mar 21, 2007 9:13 am

Here is the log:
-------------------------
* checking the presence of os-prober...
-- os-prober is absent
-------------------------
* checking system environment...
-- user = mats
-- home = /home/mats
-- locale = sv_SE.UTF-8
-------------------------
* configuring options...
-- mount point: /media/<<DEVICE>>
-- show links: Yes
-- links location: /home/mats/Desktop/
-------------------------
* loading support for FAT32...
-- partition type = b
-- mount type = vfat
-- mount options = iocharset=utf8,umask=000
* loading support for FAT32 (LBA)...
-- partition type = c
-- mount type = vfat
-- mount options = iocharset=utf8,umask=000
* loading support for NTFS...
-- partition type = 7
-- mount type = ntfs
-- mount options = defaults,locale=en_US.utf8
-------------------------
* removing existing links (if any)...
-------------------------
* scanning partitions...
-- detected device /dev/sda1 of type 7 and size 26GB
=> no alias defined
=> partition managed by /etc/fstab
-- detected device /dev/sda2 of type 83 and size 29GB
=> partition type not supported
-- detected device /dev/sda3 of type 5 and size 49GB
=> partition type not supported
-- detected device /dev/sda4 of type 7 and size 56GB
=> no alias defined
=> mounting partition...
=> mount: fel filsystemstyp, felaktig flagga, felaktigt superblock
på /dev/sda4, codepage saknas, eller annat fel
I en del fall kan användbar information hittas i syslog
- prova dmesg | tail eller något liknande

=> could not mount partition, no link created
-- detected device /dev/sda5 of type 82 and size 2GB
=> partition type not supported
-- detected device /dev/sda6 of type 83 and size 46GB
=> partition type not supported
-- detected device /dev/sdb1 of type 7 and size 6GB
=> no alias defined
=> partition managed by /etc/fstab
-- detected device /dev/sdb2 of type 7 and size 74GB
=> no alias defined
=> partition managed by /etc/fstab

I'll translate this for you:
=> mount: fel filsystemstyp, felaktig flagga, felaktigt superblock
på /dev/sda4, codepage saknas, eller annat fel
I en del fall kan användbar information hittas i syslog
- prova dmesg | tail eller något liknande
In english:
=> mount: wrong file system type, wrong flag, faulty superblock
on /dev/sda4, codepage missing, or some other error
In some cases useful information can be found in syslog
- check dmesg | tail or similar

Partition structure: sda1 ntfs winXP Primary

sda2 ext3 mint primary
sda3 extended, contains two logical partitions, sda5 =swap and sda6 ext3 home
sda4 is ntfs primary

I have not changed any setting in mintDisk, I'll try sv_SE.UTF-8 and report back

No, that did not help.
I just discovered that I can mount it in fstab
Image
Don't fix it if it ain't broken, don't break it if you can't fix it

Husse
Level 23
Level 23
Posts: 18701
Joined: Sun Feb 11, 2007 7:22 am
Location: Near Borås Sweden

Post by Husse » Tue May 08, 2007 6:02 pm

topic split
//and I forgot to lock it :)
Last edited by Husse on Wed May 09, 2007 4:39 am, edited 1 time in total.
Image
Don't fix it if it ain't broken, don't break it if you can't fix it

User avatar
Boo
Level 7
Level 7
Posts: 1634
Joined: Mon Mar 26, 2007 7:48 am

Post by Boo » Tue May 08, 2007 10:23 pm

try mounting the partition with ntfs-g3 instead of mount.

ntfsg3 /dev/sda4 /mnt/windows

or
http://www.ntfs-3g.org/

has some other options.

:D
Image
Now where was i going? Oh yes, crazy!

Locked

Return to “Mounting Partitions”