New hard drive not in boot options

Forum rules
Before you post please read this
Post Reply
wibbly
Level 1
Level 1
Posts: 38
Joined: Wed Jul 16, 2014 6:13 am

New hard drive not in boot options

Post by wibbly » Wed Aug 05, 2015 11:09 am

Ok, here's the history.

Existing Desktop with Vista.
Installed 17.2 on same drive as a test.
All worked perfectly.
Installed second hard drive, WD 1TB black.
Booted from USB.
Installed 17.2 on new drive. Downloaded all updates, everything worked perfectly, but could not see or mount the original drive.
Rebooted. 17.2 was listed on the new drive in the boot menu.
I selected it, carried on downloading the software I needed, all ok.
Rebooted, and the new drive with the new 17.2 install is not there?
Rebooted, still not there, so ran the original 17.2 from the first drive, and I can mount and open the new drive, and copy files to it from the existing drive.

Question 1 is: How do I get the boot menu to mount and display the new drive, with the new 17.2 install? The system knows it is there, the bios boot order places the new drive as the first boot option. I am obviously missing something.

Question 2 is: How do I get access to the original drive if I run Mint from the fresh install on the new one?

The motherboard is a Gigabyte GA-MA785GM-US2H, Corsair 650w psu, and an Arctic Cooling Freezer 7 pro

My agenda is to get the fresh install working as neatly as I want it to, and then drop the old drive and Vista altogether if i can do without it. If this all works out I will invest in a new motherboard and CPU. The existing hardware is pretty ancient but has served me well.

Hoping someone can assist,

Regards

Rob
Attachments
shotcomputer.jpg
shotsystem.jpg
Linuxmint 64bit version Always the latest version
Kernel 4.4.0-53
Intel i5 4690k @ 3.50Ghz x 4
Ram 8GB
WD Black 1TB
GEForce GT460SE 1GB

wibbly
Level 1
Level 1
Posts: 38
Joined: Wed Jul 16, 2014 6:13 am

Re: New hard drive not in boot options

Post by wibbly » Thu Aug 06, 2015 6:03 am

I ran fdisk -1 and got this, does this give any pointers? I have ploughed through numerous threads but can't find anything that I would tackle without confirmation that I am doing the right thing.
Attachments
sdb2.jpg
sda1.jpg
fdisk.jpg
Linuxmint 64bit version Always the latest version
Kernel 4.4.0-53
Intel i5 4690k @ 3.50Ghz x 4
Ram 8GB
WD Black 1TB
GEForce GT460SE 1GB

wayne128
Level 10
Level 10
Posts: 3412
Joined: Tue Jul 13, 2010 12:15 am

Re: New hard drive not in boot options

Post by wayne128 » Thu Aug 06, 2015 8:10 am

wibbly wrote: The motherboard is a Gigabyte GA-MA785GM-US2H, Corsair 650w psu, and an Arctic Cooling Freezer 7 pro

My agenda is to get the fresh install working as neatly as I want it to, and then drop the old drive and Vista altogether if i can do without it. If this all works out I will invest in a new motherboard and CPU. The existing hardware is pretty ancient but has served me well.

hmm,
since all you want is to have LM running on the new 1TB drive, I suggest this:

1. unplug cables to your 320G, old drive with vista+LM

2. power up, hit boot key, set bios to have 1TB new drive as first boot.

3. boot to see if it can boot
if yes, then, just update it,,,and then use it

4. if not, then, repair the boot by using the USB Live LM:
4a. Boot from USB Live LM
4b. open a terminal, type sudo su and get a root terminal with a # prompt
4c. type this code, and hit enter to execute

Code: Select all

mount /dev/sda1 /mnt
4d. type next one and hit enter

Code: Select all

grub-install --root-directory=/mnt /dev/sda
hopefully no error.
reboot, hit boot key to boot from 1TB drive, and check if LM can boot up.

wibbly
Level 1
Level 1
Posts: 38
Joined: Wed Jul 16, 2014 6:13 am

Re: New hard drive not in boot options (Solved)

Post by wibbly » Thu Aug 06, 2015 12:43 pm

Many thanks for the instructions.
All I needed to do was disconnect the original drive, go into BIOS. Select the 1TB drive (that was already the first boot device as it was the only one connected) and confirm it.
Rebooted and the 1TB drive fired up.
Shut down.
Reconnected the original drive.
Rebooted.
All options were then listed on the first screen, with the 1TB drive LM at the top as the default.
Select Enter, and it booted as normal.
I am now able to boot from the 1TB drive, and can access the files on the original one, which is what I was hoping to achieve.

Kind regards

Rob
Linuxmint 64bit version Always the latest version
Kernel 4.4.0-53
Intel i5 4690k @ 3.50Ghz x 4
Ram 8GB
WD Black 1TB
GEForce GT460SE 1GB

Post Reply

Return to “Mounting Partitions”