Cannot mount hard drive

Forum rules
Before you post please read this
Post Reply
Kinimod
Level 1
Level 1
Posts: 6
Joined: Sun Jan 24, 2016 8:13 am

Cannot mount hard drive

Post by Kinimod » Sun Jan 24, 2016 8:31 am

Hi, I'm just getting started with Mint and Linux in general and ran into an error when trying to mount a hard drive. I run Mint 17.3 from an external drive and am trying to mount an internal one which has Windows 10 on it. I get an error message saying that the mount attempt

"exited with non-zero exit status 14: Windows is hibernated, refused to mount.
Failed to mount '/dev/sda2': Operation not permitted
The NTFS partition is in an unsafe state. Please resume and shutdown
Windows fully (no hibernation or fast restarting), or mount the volume
read-only with the 'ro' mount option."

Most commonly this seems to occur because of Windows' fast startup option, but I have already disabled that option, as well as its hibernation option just in case. I have tried both restarting and shutting down Windows through the start menu, as well as shutting down using "shutdown -p" in the command line. I have also changed the boot order in my computer's BIOS so it should be ignoring the internal drive. No success so far, the drive still cannot be mounted in Linux.

Sorry if this is a Windows question more than a Linux one, or if it has been asked already. Most posts and articles that I found point to "disable the fast startup option" but this has not solved the problem for me.

Grateful for any advice.

User avatar
Pierre
Level 17
Level 17
Posts: 7142
Joined: Fri Sep 05, 2008 5:33 am
Location: Perth, AU.

Re: Cannot mount hard drive

Post by Pierre » Sun Jan 24, 2016 8:35 am

it sounds as if the windows system is still unreadable,
so boot back into the windows system & run it's scan-disk utility.

then try to mount it, again, using your linux system.
Image
Please edit your original post title to include [SOLVED] - when your problem is solved!
and DO LOOK at those Unanswered Topics - - you may be able to answer some!.

User avatar
WharfRat
Level 20
Level 20
Posts: 11428
Joined: Thu Apr 07, 2011 8:15 pm

Re: Cannot mount hard drive

Post by WharfRat » Sun Jan 24, 2016 9:52 am

ImageImage

Kinimod
Level 1
Level 1
Posts: 6
Joined: Sun Jan 24, 2016 8:13 am

Re: Cannot mount hard drive

Post by Kinimod » Mon Jan 25, 2016 2:25 pm

Pierre - thanks, I ran chkdsk on the drive but it found no errors and the drive still cannot be mounted from Linux.

WharfRat - the thread you linked to describes a similar problem. The user was able to fix it though by disabling Fast Startup, whereas for me that did not solve the problem.

I checked the registry to verify that Fast Startup is really disabled - it is. I also cannot mount the drive even after restarting (as opposed to shutting down and then booting again), which supposedly gets you a full reboot, so that makes me think this is not related to Fast Startup.

User avatar
WharfRat
Level 20
Level 20
Posts: 11428
Joined: Thu Apr 07, 2011 8:15 pm

Re: Cannot mount hard drive

Post by WharfRat » Mon Jan 25, 2016 3:37 pm

Either boot windows to run the disk check program, or some other windows disk analysis/repair media.

What is the purpose for mounting the partition in linux :?:
ImageImage

Kinimod
Level 1
Level 1
Posts: 6
Joined: Sun Jan 24, 2016 8:13 am

Re: Cannot mount hard drive

Post by Kinimod » Mon Jan 25, 2016 5:14 pm

That is what I did, ran chkdsk from Windows.

My data is on this NTFS drive and I want to mount it to work with that data in Linux.

Mark Phelps
Level 7
Level 7
Posts: 1794
Joined: Mon Jun 10, 2013 4:39 pm

Re: Cannot mount hard drive

Post by Mark Phelps » Mon Feb 15, 2016 6:31 pm

Kinimod wrote:That is what I did, ran chkdsk from Windows.

My data is on this NTFS drive and I want to mount it to work with that data in Linux.
CHKDSK is NOT the problem.

The problem is that in Win10, a new hibernation feature known as FastStartup is enabled by default. This is NOT the same as Fast Boot.

With FastStartup, no matter how you shut down Win10, the filesystems remain mounted -- thus preventing you from mounting them again from Linux.

There are two ways to disable FastStartup in Win8/10; (1) through the Control Panel, and (2) through an elevated command prompt.

Control Panel - Open Control Panel --> Power Options.
Select "Choose what the power buttons do"
Select "Change settings that are currently unavailable"
At the bottom of the Window, under Shutdown settings, uncheck the box regarding fast startup

Elevated command prompt - run the following command:
REG ADD "HKLM\SYSTEM\CurrentControlSet\Control\Session Manager\Power" /V HiberbootEnabled /T REG_dWORD /D 0 /F

In both cases, reboot Windows.

NOW, FastStartup is disabled.

Kinimod
Level 1
Level 1
Posts: 6
Joined: Sun Jan 24, 2016 8:13 am

Re: Cannot mount hard drive

Post by Kinimod » Thu Feb 18, 2016 2:03 pm

Hi Mark, thanks for the hint. I had already disabled Fast Startup through the control panel and the registry in a regular user session. I now ran the command you suggested in elevated mode. No luck - Windows still insists on booting and Linux cannot mount the drive.

User avatar
austin.texas
Level 20
Level 20
Posts: 12055
Joined: Tue Nov 17, 2009 3:57 pm
Location: at /home

Re: Cannot mount hard drive

Post by austin.texas » Thu Feb 18, 2016 8:27 pm

If you want to share data with Mint, the safest way is to create a separate data partition, formatted NTFS. That should make it easier to gain access, and it will protect your "C Drive".
Mint 18.2 Cinnamon, Quad core AMD A8-3870 with Radeon HD Graphics 6550D, 8GB DDR3, Ralink RT2561/RT61 802.11g PCI
Linux Linx 2018

Kinimod
Level 1
Level 1
Posts: 6
Joined: Sun Jan 24, 2016 8:13 am

Re: Cannot mount hard drive

Post by Kinimod » Mon Feb 29, 2016 2:53 pm

A few posts from this thread seem to have gone missing while the forum was down. Anyway, so far the only way for me to reliably have Linux boot on my computer is to physically disconnect the Windows drive. To access my data that are saved on the Windows drive, I copy what I need to a USB flash drive before I switch to Linux. Not the most convenient way of working but it accomplishes what I need for now.

whitelight999
Level 1
Level 1
Posts: 16
Joined: Sun Feb 28, 2016 3:56 pm

Re: Cannot mount hard drive

Post by whitelight999 » Wed Apr 20, 2016 6:11 am

I had same error
I had two HDD in machine
One windows (multiple partitions) , one Linux

The problem was one of the partitions in the windows was not formatted, one I had never used up to that point,

My solution was to Run a Full format (NFTS) not a quick format on this empty partition
and errors are gone and I can fully access all the partitions on the windows drive from Linux.

Kinimod
Level 1
Level 1
Posts: 6
Joined: Sun Jan 24, 2016 8:13 am

Re: Cannot mount hard drive

Post by Kinimod » Mon May 23, 2016 11:50 am

I found a solution that worked on my machine in this StackExchange thread:
http://askubuntu.com/questions/145902/u ... 410b78b09f

Running "powercfg /h off" in an elevated command prompt in Windows did the trick. Also I noticed the Fast Start option now does not even appear anymore in my Windows power options.

Post Reply

Return to “Mounting Partitions”