Possible problem converting ext3 to ext4

Forum rules
Before you post please read this
Post Reply
johnb0647
Level 1
Level 1
Posts: 33
Joined: Sun Mar 11, 2012 10:02 am

Possible problem converting ext3 to ext4

Post by johnb0647 » Thu Sep 29, 2016 10:03 pm

USING: LM18 w/ latest updates.

I converted or tried to convert a partition from ext3 to ext4 following:

https://debian-administration.org/artic ... filesystem

Specifically the section titled: Converting a non-root filesystem to ext4". (Yes.... including modifying /etc/fstab)

Everything seems to work perfectly EXCEPT some utilities say it is ext4 and some say ext3.

gparted says ext3

mount | grep sdb3 says ext4

"disks" utility says ext4

sudo file -s /dev/sdb3 says ext3

e2fsck -nv /dev/sdb3 says "Clean"

Per suggestion in the referenced article and with reference to:

http://jsmylinux.no-ip.org/howto/improv ... -e4defrag/

I ran e4defrag on the partition but it had no effect on this issue.

As I said, everything seems to be working perfectly but........... I'm a nervous type.

What's up?

Am I OK or not?

TIA

Post Reply

Return to “Mounting Partitions”