External Hard Drive won't mount

Forum rules
Before you post please read this
The Penguin
Level 1
Level 1
Posts: 13
Joined: Sat Aug 20, 2016 4:01 am

External Hard Drive won't mount

Postby The Penguin » Wed Oct 12, 2016 2:22 am

Hi there. I am wanting to move a second computer over to Linux Mint, and therefore backed up all the files I would like to keep onto an HD External Drive. Before installing Linux, though, I decided to check whether the file transfer went o.k. and whether I would be able to transfer all the backed-up files back onto the computer once I have converted to Linux. this I had done successfully in the past with the same External Drive. It, however, keeps on giving me the following message:

Error mounting /dev/sdb1 at /media/jaco/Jaco's Backups: Command-line `mount -t "ntfs" -o "uhelper=udisks2,nodev,nosuid,uid=1000,gid=1000,dmask=0077,fmask=0177" "/dev/sdb1" "/media/jaco/Jaco's Backups"' exited with non-zero exit status 14: The disk contains an unclean file system (0, 0).
Metadata kept in Windows cache, refused to mount.
Failed to mount '/dev/sdb1': Operation not permitted
The NTFS partition is in an unsafe state. Please resume and shutdown
Windows fully (no hibernation or fast restarting), or mount the volume
read-only with the 'ro' mount option.

What do I do to solve this riddle?

Can anyone please help me?

deepakdeshp
Level 8
Level 8
Posts: 2371
Joined: Sun Aug 09, 2015 10:00 am

Re: External Hard Drive won't mount

Postby deepakdeshp » Wed Oct 12, 2016 3:20 am

The windkws system should be cleanly shutdown.If not you get this error.
If I have helped you solve a problem, please add [SOLVED] to your first post title, it helps other users looking for help, and keeps the forum clean.
I am using Mint 18 Cinnamon 64 bit with AMD processor .

The Penguin
Level 1
Level 1
Posts: 13
Joined: Sat Aug 20, 2016 4:01 am

Re: External Hard Drive won't mount

Postby The Penguin » Wed Oct 12, 2016 2:33 pm

Hi, I'm a bit lost here. Do you mean the Windows System, or do you refer to something else? And what do you mean by it should be shut down? Forgive me my ignorance, but I'm relatively new new at Linux.

deepakdeshp
Level 8
Level 8
Posts: 2371
Joined: Sun Aug 09, 2015 10:00 am

Re: External Hard Drive won't mount

Postby deepakdeshp » Wed Oct 12, 2016 2:41 pm

Please attach the usb drive back to the Windows machine. Verify that files are accessible. Eject by right clicking on the drive icon or shut down Windows.

Attach the usb drive to Mint box and verify that you can access the files in the usb.
Good luck
If I have helped you solve a problem, please add [SOLVED] to your first post title, it helps other users looking for help, and keeps the forum clean.
I am using Mint 18 Cinnamon 64 bit with AMD processor .

pegasis
Level 3
Level 3
Posts: 185
Joined: Fri Dec 26, 2014 12:56 pm

Re: External Hard Drive won't mount

Postby pegasis » Sat Jul 01, 2017 12:15 pm

I have the same issue

I can use clonzilla and clone to USB external drive, but mint OS does not see it in the same external hd dock??

how can I fix this??

Mark Phelps
Level 7
Level 7
Posts: 1763
Joined: Mon Jun 10, 2013 4:39 pm

Re: External Hard Drive won't mount

Postby Mark Phelps » Wed Jul 12, 2017 5:06 pm

pegasis wrote:I have the same issue

I can use clonzilla and clone to USB external drive, but mint OS does not see it in the same external hd dock??

how can I fix this??


By the "same issue", do you mean a Windows formatted disk that you can NOT real in Linux?

IF so, read the threads about having to fix this in Windows.

If this is NOT a Windows formatted disk -- then you do NOT have the same issue -- and should start your own thread.

User avatar
WharfRat
Level 19
Level 19
Posts: 9946
Joined: Thu Apr 07, 2011 8:15 pm

Re: External Hard Drive won't mount

Postby WharfRat » Wed Jul 12, 2017 5:18 pm

Penguin,

The message alludes to being able to mount the partition read only. Since you intend to only copy files try the ro option

Code: Select all

sudo mount -t ntfs-3g -o ro,uid=1000,gid=1000,dmask=002,fmask=111 /dev/sdb1 /mnt
Image ImageImage

pegasis
Level 3
Level 3
Posts: 185
Joined: Fri Dec 26, 2014 12:56 pm

Re: External Hard Drive won't mount

Postby pegasis » Wed Jul 12, 2017 6:58 pm

th bloody usb cable was bad

I replaced it and the HD dock worked

User avatar
BG405
Level 5
Level 5
Posts: 828
Joined: Fri Mar 11, 2016 3:09 pm
Location: England

Re: External Hard Drive won't mount

Postby BG405 » Thu Jul 13, 2017 11:45 am

Quite common for USB cables to be the culprit even if they are not faulty as such. My external DVD drive refuses to work properly with some cables that are fine for other devices.

Shorter = better & having a ferrite on the lead = better still. Long leads usually cause problems with DVD drives and external HDs in my experience.
Dell Inspiron 1525 - LM17.3 CE 64-------------------Acer D255E 2GB - LM17.3 KDE 32
Toshiba NB305 - LM17.3 Xfce 32--------------------K7S5A Athlon 1.2GHz - LM17.3 Xfce 32 & WinXP-Pro
Acer Aspire E11 ES1-111M - LM18.2 KDE 64 -----Dell PII 350 64MB - Puppy 4.3 & Win98-SE


Return to “Mounting Partitions”