[Solved] No permission for mounted hdd.

Forum rules
Before you post please read this
User avatar
austin.texas
Level 20
Level 20
Posts: 12054
Joined: Tue Nov 17, 2009 3:57 pm
Location: at /home

Re: No permission for mounted hdd.

Post by austin.texas » Mon Dec 12, 2016 9:59 am

Your fstab looks good, and the result you got for the command, lsblk -f shows that the data partition (sda2) is mounted, so there should be no problem. Everything is in order.
In your file manager go to FILE SYSTEM > mnt/DATA and use the folders you created there.
Mint 18.2 Cinnamon, Quad core AMD A8-3870 with Radeon HD Graphics 6550D, 8GB DDR3, Ralink RT2561/RT61 802.11g PCI
Linux Linx 2018

ALbin75
Level 2
Level 2
Posts: 76
Joined: Fri Nov 18, 2016 7:39 am

Re: No permission for mounted hdd.

Post by ALbin75 » Mon Dec 12, 2016 12:00 pm

austin.texas wrote:Your fstab looks good, and the result you got for the command, lsblk -f shows that the data partition (sda2) is mounted, so there should be no problem. Everything is in order.
In your file manager go to FILE SYSTEM > mnt/DATA and use the folders you created there.
Okay. I can no longer open specific ssd and hdd directly but I can access them from the filesystem. It looks like a third hdd on my computer.
However both of them are currently owned by root.

I can still access and use my homefolder and filesystem even though it is inside the ssd that I cant access directly.

I cant do anything with the new DATA inside the filesystem. I can see that there is 935gb fress space on it.

sda
└─sda2 ext4 9c1b3f85-4a25-4de8-a75a-12372fef6f31 /mnt/DATA
sdb
├─sdb1 ext4 d8f0d64d-cd1d-4896-bbc6-3273ced18265 /
└─sdb5 swap ddd63915-bbc6-4239-b3b1-bc320d352e61 [SWAP]

Im not sure what swap is and if I need it on the 2nd hdd. I thought swap was something that works with the ram an since I have plenty of ram and a swap partition on the ssd disk I never made one on the 2nd hdd.

User avatar
Flemur
Level 17
Level 17
Posts: 7065
Joined: Mon Aug 20, 2012 9:41 pm
Location: Potemkin Village

Re: No permission for mounted hdd.

Post by Flemur » Mon Dec 12, 2016 12:54 pm

ALbin75 wrote:If it is going to be arround 30 random characters, that is unreadable for the human mind it would be good to list this UUID identity.
Which is why I don't use UUID's - they're pointless, confusing and hard to use.

Next time you mess around with a new partition, make life easier for yourself and give it a LABEL with gparted when you create it (or you can define the LABEL on an existing but unmounted partition), then your entries in the /etc/fstab file would be like these:

Code: Select all

LABEL=MINT  /         ext4  noatime,errors=remount-ro 0 1
LABEL=DATA  /mnt/DATA ext4  defaults,noatime 0 0
LABEL=SWAP  none      swap  sw  0   0
#
# don't automount other linux OS:
LABEL=UBUN  /mnt/UBUN ext4  defaults,noatime,noauto    0 0
Much nicer than the UUID nonsense, yes?
Even if I still dont know what UUID is. "Universally unique identifier" perhaps it means the identity of my hdd?
In this case UUID's go with partitions, but yes it's **supposed to be** a "Universally unique" number identifying a partition...but that's not even true because if you copy an entire partition you also copy its UUID (and the LABEL...).
I can't see any reason for a human to use UUIDs rather then LABELs.
Please edit your original post title to include [SOLVED] if/when it is solved!
Your data and OS are backed up....right?
Mint 19.1 Xfce/fluxbox
Manjaro openbox/fluxbox

User avatar
austin.texas
Level 20
Level 20
Posts: 12054
Joined: Tue Nov 17, 2009 3:57 pm
Location: at /home

Re: No permission for mounted hdd.

Post by austin.texas » Mon Dec 12, 2016 1:03 pm

Please post the result of the command:

Code: Select all

ls -la /mnt/DATA
(That is ls -la /mnt/DATA. Use small L not 1. )
Mint 18.2 Cinnamon, Quad core AMD A8-3870 with Radeon HD Graphics 6550D, 8GB DDR3, Ralink RT2561/RT61 802.11g PCI
Linux Linx 2018

ALbin75
Level 2
Level 2
Posts: 76
Joined: Fri Nov 18, 2016 7:39 am

Re: No permission for mounted hdd.

Post by ALbin75 » Mon Dec 12, 2016 1:06 pm

austin.texas wrote:Please post the result of the command:

Code: Select all

ls -la /mnt/DATA
(That is ls -la /mnt/DATA. Use small L not 1. )
ok.

total 24
drwxr-xr-x 3 root root 4096 Dec 10 16:50 .
drwxr-xr-x 4 root root 4096 Dec 12 12:42 ..
drwx------ 2 root root 16384 Dec 10 16:50 lost+found

ALbin75
Level 2
Level 2
Posts: 76
Joined: Fri Nov 18, 2016 7:39 am

Re: No permission for mounted hdd.

Post by ALbin75 » Mon Dec 12, 2016 1:09 pm

Flemur wrote:
ALbin75 wrote:If it is going to be arround 30 random characters, that is unreadable for the human mind it would be good to list this UUID identity.
Which is why I don't use UUID's - they're pointless, confusing and hard to use.

Next time you mess around with a new partition, make life easier for yourself and give it a LABEL with gparted when you create it (or you can define the LABEL on an existing but unmounted partition), then your entries in the /etc/fstab file would be like these:

Code: Select all

LABEL=MINT  /         ext4  noatime,errors=remount-ro 0 1
LABEL=DATA  /mnt/DATA ext4  defaults,noatime 0 0
LABEL=SWAP  none      swap  sw  0   0
#
# don't automount other linux OS:
LABEL=UBUN  /mnt/UBUN ext4  defaults,noatime,noauto    0 0
Much nicer than the UUID nonsense, yes?
Even if I still dont know what UUID is. "Universally unique identifier" perhaps it means the identity of my hdd?
In this case UUID's go with partitions, but yes it's **supposed to be** a "Universally unique" number identifying a partition...but that's not even true because if you copy an entire partition you also copy its UUID (and the LABEL...).
I can't see any reason for a human to use UUIDs rather then LABELs.
Okay that sounds good. I can change the name to lets say. HDD?
Easy for me to remember since the other one is an SSD.

If I do that I could use the lines above in the terminal to fix it?

But I'd better wait until I do any more changes.

User avatar
Flemur
Level 17
Level 17
Posts: 7065
Joined: Mon Aug 20, 2012 9:41 pm
Location: Potemkin Village

Re: No permission for mounted hdd.

Post by Flemur » Mon Dec 12, 2016 1:28 pm

ALbin75 wrote:Okay that sounds good. I can change the name to lets say. HDD?
Easy for me to remember since the other one is an SSD.
As far as I know you can call it anything (dunno about how many characters, limit), but SSD and HDD refer to the disk drives, not partitions...you might want to label your Mint partition "MINT", data partitions "DATA", etc.
If I do that I could use the lines above in the terminal to fix it?
But I'd better wait until I do any more changes.
Probably safest to use gparted, and if you have everything working for the (non-system) HDD you can do that from a running Linux by unmounting the HDD partition(s), change/define the label, remount. For the OS, you need to do it from a LiveDVD/USB boot because the "/" partition can't be unmounted in a running system.

You don't need to change anything in /etc/fstab if you add a partition label, but the label will make output from "sudo blkid" make a lot more sense:

Code: Select all

$ sudo blkid
/dev/sda1: LABEL="MINT" UUID="d7a3e26f-..." TYPE="ext4" PARTUUID="07c537f5-01"
/dev/sda2: LABEL="UBUN" UUID="8c59a1c3-..." TYPE="ext4" PARTUUID="07c537f5-02"
/dev/sda7: LABEL="DATA" UUID="1633cae6-..." TYPE="ext4" PARTUUID="07c537f5-07"
...
Gee, I wonder what sda7 is for...?
Please edit your original post title to include [SOLVED] if/when it is solved!
Your data and OS are backed up....right?
Mint 19.1 Xfce/fluxbox
Manjaro openbox/fluxbox

User avatar
austin.texas
Level 20
Level 20
Posts: 12054
Joined: Tue Nov 17, 2009 3:57 pm
Location: at /home

Re: No permission for mounted hdd.

Post by austin.texas » Mon Dec 12, 2016 2:20 pm

Your result of the command ls -la /mnt/DATA shows /mnt/DATA to be owned by root.
Change the ownership to the current user, with this command:

Code: Select all

sudo chown -R $USER /mnt/DATA
Then again post the result of

Code: Select all

ls -la /mnt/DATA 
Mint 18.2 Cinnamon, Quad core AMD A8-3870 with Radeon HD Graphics 6550D, 8GB DDR3, Ralink RT2561/RT61 802.11g PCI
Linux Linx 2018

ALbin75
Level 2
Level 2
Posts: 76
Joined: Fri Nov 18, 2016 7:39 am

Re: No permission for mounted hdd.

Post by ALbin75 » Mon Dec 12, 2016 3:45 pm

austin.texas wrote:Your result of the command ls -la /mnt/DATA shows /mnt/DATA to be owned by root.
Change the ownership to the current user, with this command:

Code: Select all

sudo chown -R $USER /mnt/DATA
Then again post the result of

Code: Select all

ls -la /mnt/DATA 
Okay Like this then.

total 24
drwxr-xr-x 3 albin root 4096 Dec 10 16:50 .
drwxr-xr-x 4 root root 4096 Dec 12 12:42 ..
drwx------ 2 albin root 16384 Dec 10 16:50 lost+found

User avatar
austin.texas
Level 20
Level 20
Posts: 12054
Joined: Tue Nov 17, 2009 3:57 pm
Location: at /home

Re: No permission for mounted hdd.

Post by austin.texas » Mon Dec 12, 2016 3:51 pm

OK. Now you can use it.
Make a directory, or several directories to use.
EXAMPLE: to make a directory named Music_mp3s:

Code: Select all

mkdir /mnt/DATA/Music_mp3s
Mint 18.2 Cinnamon, Quad core AMD A8-3870 with Radeon HD Graphics 6550D, 8GB DDR3, Ralink RT2561/RT61 802.11g PCI
Linux Linx 2018

ALbin75
Level 2
Level 2
Posts: 76
Joined: Fri Nov 18, 2016 7:39 am

Re: No permission for mounted hdd.

Post by ALbin75 » Mon Dec 12, 2016 5:57 pm

austin.texas wrote:OK. Now you can use it.
Make a directory, or several directories to use.
EXAMPLE: to make a directory named Music_mp3s:

Code: Select all

mkdir /mnt/DATA/Music_mp3s
Thansk. It works. I now own my hdd. :)
Now I can start transfering data from the external drive. Once I get it on the internal drive It will be easier to sort it all out.

I tried the comand mkdir /mnt/DATA/Music_mp3s, but wrote 1tbhdd instead of music mp3s.
It created a folder in mnt/DATA
I don't know if it is different from just right clicking inside the folder and create new folder.

It would be nice to be able to make an active shortcut in homefolder. But it's not really imprtant.

I guess this topic is solved now, thanks :)

Do uou now why 50gb of the empty harddrive is being used?

Also can I delete the folder named LOst and found that's inside nmt DATA?

User avatar
austin.texas
Level 20
Level 20
Posts: 12054
Joined: Tue Nov 17, 2009 3:57 pm
Location: at /home

Re: No permission for mounted hdd.

Post by austin.texas » Mon Dec 12, 2016 6:57 pm

ALbin75 wrote:I don't know if it is different from just right clicking inside the folder and create new folder.
It is the same thing.
ALbin75 wrote:It would be nice to be able to make an active shortcut in homefolder.
I mentioned previously that you can make a Bookmark in the file manager the same way you make a Bookmark in your web browser.
ALbin75 wrote:Do uou now why 50gb of the empty harddrive is being used?
Also can I delete the folder named LOst and found that's inside nmt DATA?
If you can't see what is taking up that 50GB of space, it is possible that the lost+found contains files that you no longer need. You can delete that lost+found, but then you should create a new (empty) one.
To delete the existing lost+found:

Code: Select all

sudo rm /mnt/DATA/lost+found
To create a new (empty) lost+found:

Code: Select all

cd /mnt/DATA
Then:

Code: Select all

sudo mklost+found
Mint 18.2 Cinnamon, Quad core AMD A8-3870 with Radeon HD Graphics 6550D, 8GB DDR3, Ralink RT2561/RT61 802.11g PCI
Linux Linx 2018

ALbin75
Level 2
Level 2
Posts: 76
Joined: Fri Nov 18, 2016 7:39 am

Re: No permission for mounted hdd.

Post by ALbin75 » Tue Dec 13, 2016 3:29 am

Ah yes, I forgot about that. I added DATA in the home filesystem just like a bookmark. Good to know. This is a feature that is easy to use.

The lost and found folder seems to be completely empty. In view I checked show hidden files. No different. Also it can't contain any files that I would need since this harddrive has been added last, after mint 18 and all other software.
It should be a clean empty newly formated hdd. Do I really need to have this lost and found directory in my hdd? Is there some purpose with it?

Also can I in this state use a comand that will stop the hdd from auto mounting at boot?

Also I feel like there is still something strange on my hdd. Ackording to this one there's 70gb still on it. Perhaps something from when it was shipped with windows 8? ANd that might be why I can no longer enter boot at startup.
Last edited by ALbin75 on Tue Dec 13, 2016 6:37 am, edited 2 times in total.

ALbin75
Level 2
Level 2
Posts: 76
Joined: Fri Nov 18, 2016 7:39 am

Re: No permission for mounted hdd.

Post by ALbin75 » Tue Dec 13, 2016 5:28 am

I suspect that my 2nd hdd turned into my primary boot sector.

My 2nd hdd was referred to as sda. And that alone made me suspicious. Why not sdb?

My 2nd hard drive is of no greater significance to my system than a usb memory or an external hdd.

I deleted the extra partition that was still inside sda. I used a disk tool to do that. (big mistake...)
After that there was magically a home folder inside mnt DATA. It looked really good. And all the folders were empty. Everything worked good.

I then reboot and I'm stuck. I can no longer boot. When sda2 partition on sda isn't found my system refuse to move on to normal boot from ssd.

I then open my computer and remove the 2nd hard drive. But the result is the same. Without the sda2 on the 2nd hdd my system refuse to let it go and just resume normal boot.

I will now try to install mint side by side with my previous mint installation and see if it's then possible to determine the boot order of my disks, as I never ever want to boot from my 2nd hdd.
This can also be because the second hdd is installed where the dvd used to be. And dvd is probably set to be the first boot. Or it is due to some windows ghost put on the 2nd hdd.

I can also get to root or what it is, it reminds me of the terminal. Perhaps it's possible to enter a line there to stop making my 2nd hdd essential for my system. Or at least stop it from auto mount?

I will look in this thread and see if I can find that command here.
Last edited by ALbin75 on Tue Dec 13, 2016 6:43 am, edited 1 time in total.

ALbin75
Level 2
Level 2
Posts: 76
Joined: Fri Nov 18, 2016 7:39 am

Re: No permission for mounted hdd.

Post by ALbin75 » Tue Dec 13, 2016 6:00 am

I was able to install mint alongside previous mint and access all files.
I had to physically remove the 2nd hdd to be able to install on the ssd. (or I had to manually create boot and partitions on the ssd, wish is too advanced for me)

I used the bookmark to create a shortcut in home folder. That's a really good trick. :D

I found fstab. I moved it to usb stick but no change.

However I'm finally able to enter boot setup. I was using the wrong key. Thought it was f8 turns out desperately trying other keys paid of. It's f12 :twisted:

I'll try to fix this by changing the boot order...

...I removed the 2nd hdd from the boot order, disabled it.
But I'm still not able to start my previous installation. Seems like it's still looking for sda2...

Guess I'm out of options and have to make use of the new installation.

User avatar
austin.texas
Level 20
Level 20
Posts: 12054
Joined: Tue Nov 17, 2009 3:57 pm
Location: at /home

Re: No permission for mounted hdd.

Post by austin.texas » Tue Dec 13, 2016 8:02 am

ALbin75 wrote:The lost and found folder seems to be completely empty. In view I checked show hidden files. No different. Also it can't contain any files that I would need since this harddrive has been added last, after mint 18 and all other software.
It should be a clean empty newly formated hdd. Do I really need to have this lost and found directory in my hdd? Is there some purpose with it?
If lost+found is empty, forget about it. It does serve a purpose - but it is not something you would normally have to worry about.
ALbin75 wrote:Also can I in this state use a comand that will stop the hdd from auto mounting at boot?
I gave you the answer to that previously - add noauto to the fstab line.
ALbin75 wrote: I deleted the extra partition that was still inside sda. I used a disk tool to do that. (big mistake...)
After that there was magically a home folder inside mnt DATA. It looked really good. And all the folders were empty. Everything worked good.
You created those folders when you entered the command: mkdir Documents Downloads Music Pictures Videos
ALbin75 wrote:I then reboot and I'm stuck. I can no longer boot. When sda2 partition on sda isn't found my system refuse to move on to normal boot from ssd.
Guess I'm out of options and have to make use of the new installation
When it gets stuck, is there a message that says, "Press S to skip mounting" ?
ALbin75 wrote:I found fstab. I moved it to usb stick but no change.
fstab is not what you need. fstab only contains a few instructions used during boot. Grub is what controls which partition and which operating system is booted.
Mint 18.2 Cinnamon, Quad core AMD A8-3870 with Radeon HD Graphics 6550D, 8GB DDR3, Ralink RT2561/RT61 802.11g PCI
Linux Linx 2018

ALbin75
Level 2
Level 2
Posts: 76
Joined: Fri Nov 18, 2016 7:39 am

Re: No permission for mounted hdd.

Post by ALbin75 » Tue Dec 13, 2016 8:33 am

I just wanted to delete lost and fouind since I didnt understand the purpouse of it and don't want unused folders in my system.

Yes I got information about how to stop it from automounting but I didn't ad noauto to the fstab line at that moment. (if-ed up)

Yes and I created those folders with that command. But those folders were invisible somewhere until I removed the partition sda2 After that everything was pretty nice, until I rebooted.
(The "home folders" I created this time is once more nowhere to be found. )

Yes there was a message (option) pres S to skip mounting, I tried it but it didn't solve anything.

there is still arround 70gb in use on the empty hdd
Last edited by ALbin75 on Wed Dec 14, 2016 3:45 am, edited 4 times in total.

ALbin75
Level 2
Level 2
Posts: 76
Joined: Fri Nov 18, 2016 7:39 am

Re: No permission for mounted hdd.

Post by ALbin75 » Tue Dec 13, 2016 3:02 pm

Okay, so I made a clean reinstall. I can use the 2nd HDD now.
I used the guide I got from austin.texas and I used a disk tool to label it HDD. (to make it simpel)
I never got to the fstab, and I mounted it manually. All I did in the terminal was basically taking ownership of the HDD
I did use the command set mount point but got message that it was already mounted.

I did use

Code: Select all

mkdir Documents Downloads Music Pictures Videos
And I got this response:

mkdir: cannot create directory ‘Documents’: File exists
mkdir: cannot create directory ‘Downloads’: File exists
mkdir: cannot create directory ‘Music’: File exists
mkdir: cannot create directory ‘Pictures’: File exists
mkdir: cannot create directory ‘Videos’: File exists

but as last time there's no trace of any other folders than lost and found.

I have disabled the 2nd HDD from the boot order. There is only USB and built in SSD now.

I used disk manage to turn of auto mount and to set the hard drive to spin down after 5 minutes. (Not sure if 5 minutes is too aggressive)

I think it is all working pretty good now. I removed the lost and found directory on the HDD.
There is still 70GB in use somehow somewhere. (perhaps asus put windows 8 there and it cant be completely removed?)
There is still no trace of the "homedirectories" that I createdm in the HDD

Moving big files to and from the 2nd HDD is working good and fast.

Still at boot the HDD is turned on several times and the (for me who is guessing it appears as if) system is looking for something on it before moving on to boot normal.

Perhaps the reason for the odd behavior of the HDD is due to it being physically installed in place of the optical device and the hardware is just confirmed that way.
Always start the and check the optical unit as soon as the computer is turned on? The second HDD is not mounted in the filesystem after startup, just like I want it.
It mounts and give direct access to the files with one click. And if I do nothing the HDD spin down after 5 minutes, untill I manually mount it.
Last edited by ALbin75 on Wed Dec 14, 2016 3:43 am, edited 1 time in total.

ALbin75
Level 2
Level 2
Posts: 76
Joined: Fri Nov 18, 2016 7:39 am

Re: No permission for mounted hdd.

Post by ALbin75 » Wed Dec 14, 2016 3:33 am

ALbin75 wrote:Also can I in this state use a comand that will stop the hdd from auto mounting at boot?
I gave you the answer to that previously - add noauto to the fstab line.

I was so happy about the new comand opening fstab, that I didn't noticed that there was one extra word in the command line that I was supposed to add.
When fstab opened by itself it made a lot more sence, then when I previously manually opened a text document and pasted something in it and then saved it in a random folder.
# Mount sda2 at /mnt/DATA
UUID=9c1b3f85-4a25-4de8-a75a-12372fef6f31 /mnt/DATA ext4 defaults,noatime 0 2
# Mount 1TB DATA partition at /mnt/DATA
UUID=9c1b3f85-4a25-4de8-a75a-12372fef6f31 /mnt/DATA ext4 defaults,noatime,noauto 0 2
Anyway, right now it looks like this:

NAME FSTYPE LABEL UUID MOUNTPOINT
sda
└─sda1 ext4 HDD 41d2c8c0-391b-46ba-97bc-28b709a3c6ce
sdb
├─sdb1 vfat 00C5-301A /boot/efi
├─sdb2 ext4 729a23fb-5f75-4e45-8d0b-e00f5c2492e6 /
└─sdb3 swap d2938459-3d3f-4ef2-8289-b959cf595d25 [SWAP]

After i double click on the HDD icon in the filesystem and it mounts I repeat the lsblk -f I get a new output:

NAME FSTYPE LABEL UUID MOUNTPOINT
sda
└─sda1 ext4 HDD 41d2c8c0-391b-46ba-97bc-28b709a3c6ce /mnt/HDD
sdb
├─sdb1 vfat 00C5-301A /boot/efi
├─sdb2 ext4 729a23fb-5f75-4e45-8d0b-e00f5c2492e6 /
└─sdb3 swap d2938459-3d3f-4ef2-8289-b959cf595d25 [SWAP]

Since it is not mounted after a reboot and I can manually unmount it I guess it isn't auoto-mounting.

ALbin75
Level 2
Level 2
Posts: 76
Joined: Fri Nov 18, 2016 7:39 am

Re: [Solved] No permission for mounted hdd.

Post by ALbin75 » Wed Dec 14, 2016 2:22 pm

I marked this topic as solved. Since I can mount and unmount and use the 2nd HDD now.

The only thing I'm not sure about is what will happen if I remove the 2nd drive, will he system be unable to boot, due to some lost mount point?

At this state I do not dare to use fstab and ad anything without knowing exactly what. The file structure looks a little bit different and so. I can no longer just copy the commands for the terminal.

But as long as I do not format the HDD or remove it I think my system is pretty stable now. Also the read and write speed is pretty good.
Arround 100mb/s.

Post Reply

Return to “Mounting Partitions”