Dual Boot System: Unable to Mount Windows 10 Hard Disk Drive

Forum rules
Before you post please read this
Post Reply
jungle
Level 2
Level 2
Posts: 86
Joined: Thu Feb 05, 2009 9:21 am

Dual Boot System: Unable to Mount Windows 10 Hard Disk Drive

Post by jungle » Fri Jun 02, 2017 3:54 am

I have a dual boot set-up with Linux 17.1 on one hard disk and Windows 10 on a second hard disk. Both hard disks are internal. I recently upgraded the Windows hard drive from Windows 7 to Windows 10. Dual boot is working fine but for some reason I can no longer access the Windows hard disk when in Linux. On both hard drives I have separate partitions for the operating system and the "home' files.

When in Linuxmint and I click on the Windows system partition of the Windows hard drive I get the following message:

Error mounting /dev/sda1 at /media/jungle/Windows 10 System: Command-line `mount -t "ntfs" -o "uhelper=udisks2,nodev,nosuid,uid=1000,gid=1000,dmask=0077,fmask=0177" "/dev/sda1" "/media/jungle/Windows 10 System"' exited with non-zero exit status 14: Windows is hibernated, refused to mount.
Failed to mount '/dev/sda1': Operation not permitted
The NTFS partition is in an unsafe state. Please resume and shutdown
Windows fully (no hibernation or fast restarting), or mount the volume
read-only with the 'ro' mount option.

When I click on the Windows Home (data files) partition I get the following message:

Error mounting /dev/sda2 at /media/jungle/Windows Home: Command-line `mount -t "ntfs" -o "uhelper=udisks2,nodev,nosuid,uid=1000,gid=1000,dmask=0077,fmask=0177" "/dev/sda2" "/media/jungle/Windows Home"' exited with non-zero exit status 14: The disk contains an unclean file system (0, 0).
Metadata kept in Windows cache, refused to mount.
Failed to mount '/dev/sda2': Operation not permitted
The NTFS partition is in an unsafe state. Please resume and shutdown
Windows fully (no hibernation or fast restarting), or mount the volume
read-only with the 'ro' mount option.

Not sure what I need to do to regain access to the Windows data files drive when in Linuxmint.
Suggestions much appreciated.

Regards

jungle

sgtor
Level 3
Level 3
Posts: 164
Joined: Sat May 13, 2017 9:39 pm

Re: Dual Boot System: Unable to Mount Windows 10 Hard Disk Drive

Post by sgtor » Fri Jun 02, 2017 8:18 am

I think this is the key to your problem here:

non-zero exit status 14: Windows is hibernated, refused to mount

so reboot into windows and shut it down instead of hibernating try starting up into Linux again and see if it works

User avatar
michael louwe
Level 9
Level 9
Posts: 2787
Joined: Sun Sep 11, 2016 11:18 pm

Re: Dual Boot System: Unable to Mount Windows 10 Hard Disk Drive

Post by michael louwe » Fri Jun 02, 2017 9:29 am

@ jungle

Win 8/8.1/10 use a feature called Fast Startup or Hybrid Shutdown, similar to the Standby mode in smartphones which can be woken-up or start-up instantaneously. This feature in Win 10 has to be disabled before Linux can mount Windows files.

In the Fast Startup feature, when the user click the "Shutdown" button in Win 10, the computer is not really shutdown. Instead, it goes into minimal Hibernate mode(= no programs running), in order to give a "Fast Startup" when the user next press the Power button to switch on the computer.
....... To really and fully shutdown a Win 10/8.1/8 computer, the user needs to hard-press the Power button for a few seconds, similar to how smartphones are fully shutdown. Surprisingly, when the user clicks "Restart", the computer will be fully shutdown before restarting. Clicking "Restart" is required to complete most updates, ie should not click the "Shutdown" button and then press the Power button to complete an update.

Please refer to ... https://www.howtogeek.com/243901/the-pr ... rtup-mode/
Last edited by michael louwe on Fri Jun 02, 2017 10:45 am, edited 1 time in total.

sgtor
Level 3
Level 3
Posts: 164
Joined: Sat May 13, 2017 9:39 pm

Re: Dual Boot System: Unable to Mount Windows 10 Hard Disk Drive

Post by sgtor » Fri Jun 02, 2017 10:09 am

Interesting.

Looks like simply doing a restart should work too. When I had Windoze 10 dual booting I always just rebooted so I had never encountered this problem.
Last edited by sgtor on Sat Jun 03, 2017 9:39 am, edited 1 time in total.

jungle
Level 2
Level 2
Posts: 86
Joined: Thu Feb 05, 2009 9:21 am

Re: Dual Boot System: Unable to Mount Windows 10 Hard Disk Drive

Post by jungle » Fri Jun 02, 2017 11:05 pm

Thanks for the help.

I tried a full switch off/switch on (including switching off at the wall power plug) but that didn't solve my problem. I then switched off Fast Startup and Sleep in Windows 10, (as per the advice from Walter Glenn in the howtogeek attachment), then shut down completely and switched off the power at the wall power plug. On restarting into LinuxMint 17.3, I can now open the Windows operating system and Windows data file partitions no worries so great stuff and many thanks.

The only problem is that when I start up now I get the following message and it takes quite a few minutes to get to the boot menu and to then boot into LinuxMint (it gets there eventually). I am getting the following message:

GRUB4DOS 0.4.5c 2014-01-17, root is (0x80,0)
Processing the preset menu...

Any advice about this very slow startup into LinuxMint.

Maybe the answer will be to update to the next LinuxMint version, but I always lose access to my Brother multifunction when I update so I tend to update every two years...

TappiKid
Level 1
Level 1
Posts: 3
Joined: Thu Apr 05, 2018 6:25 pm

Re: Dual Boot System: Unable to Mount Windows 10 Hard Disk Drive

Post by TappiKid » Thu Apr 05, 2018 10:48 pm

I am having the same problem – Unable to Mount Windows 10 hard disk drive. I have done the steps to disable Fast Start in my Windows 10 side. Done power shut down and still unable to mount OS. Went back to windows and double checked and yes, Fast Start is not clicked. I did a restart and jumped into my Linux (I have Cinnamon Mint 18.3 Sylvia) and still Unable to mount OS. This is what it says:

Unable to mount OS
Error mounting /dev/sda5 at/media/africanviolet/OS: Command-line
mount -t “ntfs” -o “uhelper=udisks2,nodev,nosuid,uid=1000,gid=1000” “/
dev/sda5” “/media/africanviolet/OS? Exited with non-zero exit status 14:
Windows is hibernated, refused to mount.
Failed to mount’/dev/sda5’: Operation not permitted
The NTFS partition is in an unsafe state. Please resume and shutdown
Windows fully (no hibernation or fast restarting), or mount the volume
read-only with the ‘ro’ mount option.

I don't know what to try next. I really appreciate easy to follow steps because I'm not computer smart tho not a total idiot here, grin!
Thanks for whatever help you can give!
TappiKid

User avatar
Pierre
Level 17
Level 17
Posts: 7569
Joined: Fri Sep 05, 2008 5:33 am
Location: Perth, AU.

Re: Dual Boot System: Unable to Mount Windows 10 Hard Disk Drive

Post by Pierre » Thu Apr 05, 2018 11:30 pm

@TappiKid - - you've got the same issue:
The NTFS partition is in an unsafe state. Please resume and shutdown
Windows fully (no hibernation or fast restarting), or mount the volume
read-only with the ‘ro’ mount option.
you have to follow the above instructions, in order to disable the Fast Startup feature / Hibernate mode.
Image
Please edit your original post title to include [SOLVED] - when your problem is solved!
and DO LOOK at those Unanswered Topics - - you may be able to answer some!.

User avatar
vansloneker
Level 4
Level 4
Posts: 279
Joined: Sat Mar 17, 2018 6:10 am

Re: Dual Boot System: Unable to Mount Windows 10 Hard Disk Drive

Post by vansloneker » Fri Apr 06, 2018 2:11 pm

In Windows, open command as administrator, then enter powercfg.exe /hibernate off.
Unless stated otherwise Mint 18.3-64 XFCE

Post Reply

Return to “Mounting Partitions”