Recovering overwritten partition following partially aborted install?

Forum rules
Before you post please read this
unadon
Level 1
Level 1
Posts: 1
Joined: Sat Jul 08, 2017 10:39 pm

Recovering overwritten partition following partially aborted install?

Postby unadon » Sat Jul 08, 2017 11:14 pm

Hi,

I had partitioned my HD into a partition for the Linux 17 OS itself and 2 separate partitions for data on a 500 GB disk.

I used the Install Linux Mint tool to upgrade to 18.2, and chose the delete option (thinking it would only reformat the old OS partition), but it appears to have deleted all of my other partitions as well, so now I only see an EFI FAT32 partition, a ext4 partition, and a linux-swap partition. I tried to stop the installation at the select location screen, but it already went ahead and setup this new partition, so all of my old data is currently unrecoverable.

My old structure had 250 MB for the boot, 20 GB for the Linux OS, 1 partition to store data at around 200 GB, a swap partition at 1 GB, and another data partition of around 250 in that order. The new linux-swap partition probably causes problems in restoring the 250 GB partition, but I mainly need to recover data from the 1st 200 GB data partition.

When I run TestDisk, I only see the newly written partition structure. Is it possible to recover most of my old data from my old partition table? Is my old data recoverable and what would be the best way to go about recovering that data?

Thanks.

Return to “Mounting Partitions”

Who is online

Users browsing this forum: No registered users and 2 guests