Problems with UUID

Forum rules
Before you post please read this
Post Reply
User avatar
Lolo Uila
Level 5
Level 5
Posts: 576
Joined: Thu Mar 15, 2007 3:40 am
Location: Kapolei, Hawaii

Problems with UUID

Post by Lolo Uila » Tue May 08, 2007 4:46 pm

I've actually experienced the same thing recently. I formatted a new drive NTFS and rebooted but Mintdisk won't mount it. If I reformat it FAT32 it does mount.

Seems to be a problem with NTFS. Curiously, if I plug in an external USB NTFS drive it does mount. Or maybe it's a SATA thing? The drive I added is a SATA drive (if that makes a difference).

My Linux test system:
Intel D865GLCLK mobo (865/ICH5)
P4 2.4GHz CPU
1GB PC3200 DDR RAM

SATA1 = 20GB HD * new NTFS partition, won't mount
SATA2 = 30GB HD * FAT32, mounts
IDE1 = 30GB HD (primary master, no slave) * Mint boot drive
IDE2 = Sony DVD burner (secondary master, no slave)

At least that's the current config. I keep changing things around to experiment. Last week I had the burner on the SATA port (and it worked).

Anyway... I added that 20GB drive on SATA1 and formatted it NTFS and it wouldn't mount. Reformatted it FAT32 and it mounted. Reformatted it Linux ext3, and after I got past a little stupidity on my part I got it to mount. So it looks like only NTFS is a problem. Others here seem to be using NTFS without problems, so I'm not sure what's going on with my system?

Husse
Level 23
Level 23
Posts: 18701
Joined: Sun Feb 11, 2007 7:22 am
Location: Near Borås Sweden

Post by Husse » Tue May 08, 2007 5:58 pm

No it's not NTFS....it's UUID
I've posted that somewhere else (don't bother to look it up now as it's not necessary)
Disks are mounted in fstab using UUID which is "new" but the UUID may change when you format the drive thus giving you problems....
Image
Don't fix it if it ain't broken, don't break it if you can't fix it

User avatar
Lolo Uila
Level 5
Level 5
Posts: 576
Joined: Thu Mar 15, 2007 3:40 am
Location: Kapolei, Hawaii

Post by Lolo Uila » Wed May 09, 2007 1:37 am

But there was no entry for that drive in fstab, UUID or otherwise. I have only 2 UUID entries in fstab. One for my boot partition, and one for the swap partition; both on the same drive (hda).

The only other drive listed is my optical drive (hdc).

I did eventually add an entry for sda1 when I reformatted it to ext3, but when it was NTFS it was not in fstab, so Mintdisk should be handling it.

Any other thoughts on this?

Thanks, Tim

scorp123
Level 8
Level 8
Posts: 2277
Joined: Sat Dec 02, 2006 4:19 pm
Location: Switzerland

Post by scorp123 » Wed May 09, 2007 2:39 am

Lolo Uila wrote: I did eventually add an entry for sda1 when I reformatted it to ext3, but when it was NTFS it was not in fstab, so Mintdisk should be handling it.
Hmmm ... maybe there was something wrong with the NTFS filesystem on it? Or something about the partition table it did not like ...? In your other posting you wrote you at first tried to put an ext3 file system on the disk ... Did you change the partition table for this? Each partition type has it's own hexadecimal code. So for Linux you'd use 83 hex, for Windows XP's NTFS you'd use 07 hex, for Windows 95/98 FAT32 you'd use 0B hex, and so on.

The point is this: Regardless what you set the partition type to, you can use a different file system on that partition.

e.g. I could define a partition -- let's say: /dev/hda9 -- and mark it as being "NTFS" (Code: 07 hex) and then nontheless put a SGI XFS filesystem on it. Or the other way round: Mark it as being a Linux partition (Code: 83 hex) but then put NTFS on it.

This can be done. And it sometimes totally confuses programs handling disks because the filesytem they encounter is not what they'd expect guessing from the hex codes of the partition type.

Maybe this is what happened? You first created an Ext3 partition, changed it to NTFS, then changed it to FAT32, then changed it again to Ext3 ... Did you re-partition in between and have fdisk change the hex codes?

That's just an idea here. To really find out what happened you'd probably have to repeat your steps and see if mintDisk fails again; and then maybe try if you could squeeze out some logs or debug information (e.g. by launching the relevant NTFS3g processes manually?) ...

User avatar
Lolo Uila
Level 5
Level 5
Posts: 576
Joined: Thu Mar 15, 2007 3:40 am
Location: Kapolei, Hawaii

Post by Lolo Uila » Wed May 09, 2007 7:19 am

Interesting thoughts. It probably is something like that. I still think it's odd that it did mount as FAT32, though, since a partition table error should have affected that as well.

Maybe I'll boot up my zero fill utility and totally blow the partition away and try again.

User avatar
Lolo Uila
Level 5
Level 5
Posts: 576
Joined: Thu Mar 15, 2007 3:40 am
Location: Kapolei, Hawaii

Post by Lolo Uila » Wed May 09, 2007 8:16 am

Odd results from a little experimentation. I took the "sda" drive reference out of fstab and rebooted with my Partition Magic disk. I deleted the Linux partition and created and formatted a new NTFS partition. Rebooted into Mint and it didn't mount. Gparted could see the NTFS partition, but Mintdisk wouldn't mount it.

Rebooted with a hard disk utility and zero filled the drive. Booted back into Mint and gparted showed it as unallocated. Used gparted to create an NTFS partition and when I rebooted it MOUNTED!

So there was something funky about the drive. Odd that repartitioning it didn't fix it (and that FAT32 worked in spite of the funkyness). Probably something to do with the fact that the drive came out of a PS3. Who knows what kind of file system that thing uses.

Oh well... just part of the adventure of scavenging parts, I guess. :?

Husse
Level 23
Level 23
Posts: 18701
Joined: Sun Feb 11, 2007 7:22 am
Location: Near Borås Sweden

Post by Husse » Wed May 09, 2007 9:59 am

Oh well... just part of the adventure of scavenging parts, I guess.

:)
Or of UUID if you still used it
(PS completely of topic:
sometimes hard dics can be a problem.
I think you know what I mean :))
Image
Don't fix it if it ain't broken, don't break it if you can't fix it

Post Reply

Return to “Mounting Partitions”