mount read write MacOs usb external drive, copy files

Forum rules
Before you post please read this
Post Reply
User avatar
Level 3
Level 3
Posts: 122
Joined: Sun Sep 19, 2010 10:22 pm
Location: Australia

mount read write MacOs usb external drive, copy files

Post by beachgardener » Tue Sep 05, 2017 1:19 am

Trying to copy files from an external hard drive formatted squashfs or maybe HFS+, not working, some sort of error "Permissions denied".
Bus 004 Device 002: ID 1058:1140 Western Digital Technologies, Inc. My Book Essential (WDBACW)
it is mounted in /media
From what I have read squashfs is read only, Edit: now I don't know if this is squashfs or HFS+ ???
It seems that some folders on the drive have an x on them and some don't, some files have an x on them and some don't. I need to be able to copy the files and folders, but be able to view/play them also.
Some of the files I can view/play, but files and folders with x on them, no can't play.
How can i make it read write so I can copy some files, I tried opening as root, didn't work. I have tried searching for clues, but hard to pin down exact remedy.
Mint Cinnamon 17.3
Thank you, much appreciative of help here.

Edit, it appears that I can access the folders with an x on them with open as root and play the file, but not copy the folder with x on it.

sudo fdisk -l
Device Boot Start End Blocks Id System
/dev/sde1 * 2048 3906963455 1953480704 af HFS / HFS+

just found this and might be working
sudo mount -t hfsplus -o force,rw /dev/sdXY /media/mntpoint

OK, i have been able to copy some files, where I am stuck is with the files and folders with an X on them, can someone please help me sort that out so I can copy the files.
Thank you.
Linux Mint 17.3 Cinnamon - 64bit

Level 7
Level 7
Posts: 1531
Joined: Tue Mar 11, 2014 4:30 pm

Re: mount read write MacOs usb external drive, copy files

Post by fabien85 » Tue Sep 05, 2017 9:03 am

You cant write to an hfs+ partition because (at least last time I looked) Linux doesnt have full support of this proprietary filesystem.
You need to copy the files to a linux filesystem before playing with them. For some files you will need to be root to copy them : in the file manager click on the partition to mount it, then in the window right click > Open as root, enter your pass word and you will get a new window where you can right click > cut, and then copy wherever you want.
Alternatively you can do it in the terminal if you are used to it

Code: Select all

cd /media/path/to/USB
sudo cp files-of-interest /path/to/some/directory

Post Reply

Return to “Mounting Partitions”