Cannot mount Sandisk SDXC 64GB SD Card Linux mint 18

Forum rules
Before you post please read this
Post Reply
MaggaP
Level 1
Level 1
Posts: 1
Joined: Fri Jan 05, 2018 5:17 pm

Cannot mount Sandisk SDXC 64GB SD Card Linux mint 18

Post by MaggaP » Fri Jan 05, 2018 6:01 pm

I am trying to mount my Sandisk SDXC 64GB SD Card but I am running into some issues.

The card itself is recognised ( so I guess its not a driver issue with the sd card reader ) but when I try to access the card I receive an error message "Unable to mount location" and below "Can't mount file".

I've looked into this a bit and the recommended solution appears to be installing exfat fuse and utils :

Code: Select all

sudo apt-get install exfat-fuse exfat-utils
Unfortunately this does not seem to solve my issue. I attach some outputs from the terminal which hopefully help diagnose the problem ( this is my first post so bear with me if I haven't included the right information).

Any help with this issue would be greatly appreciated

Code: Select all

inxi -Fxz
System:    Host: migz Kernel: 4.10.0-21-generic x86_64 (64 bit gcc: 5.4.0)
           Desktop: Cinnamon 3.2.7 (Gtk 3.18.9-1ubuntu3.3)
           Distro: Linux Mint 18.1 Serena
Machine:   System: Notebook (portable) product: N24_25BU
           Mobo: Notebook model: N24_25BU
           Bios: American Megatrends v: 5.12 date: 12/21/2016
CPU:       Dual core Intel Core i5-7200U (-HT-MCP-) cache: 3072 KB
           flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx) bmips: 10848
           clock speeds: max: 3100 MHz 1: 633 MHz 2: 576 MHz 3: 599 MHz
           4: 553 MHz
Graphics:  Card: Intel Device 5916 bus-ID: 00:02.0
           Display Server: X.Org 1.18.4 drivers: intel (unloaded: fbdev,vesa)
           Resolution: 1920x1080@60.05hz
           GLX Renderer: Mesa DRI Intel HD Graphics 620 (Kaby Lake GT2)
           GLX Version: 3.0 Mesa 17.2.4 Direct Rendering: Yes
Audio:     Card Intel Device 9d71 driver: snd_hda_intel bus-ID: 00:1f.3
           Sound: Advanced Linux Sound Architecture v: k4.10.0-21-generic
Network:   Card-1: Intel Device 24fd driver: iwlwifi bus-ID: 02:00.0
           IF: wlp2s0 state: up speed: N/A duplex: N/A mac: <filter>
           Card-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller
           driver: r8169 v: 2.3LK-NAPI port: e000 bus-ID: 03:00.1
           IF: enp3s0f1 state: down mac: <filter>
Drives:    HDD Total Size: 240.1GB (14.1% used)
           ID-1: /dev/sda model: KINGSTON_SV300S3 size: 120.0GB
           ID-2: /dev/sdb model: KINGSTON_SM2280S size: 120.0GB
           ID-3: /dev/mmcblk0 model: N/A size: 63.9GB
Partition: ID-1: / size: 102G used: 25G (25%) fs: ext4 dev: /dev/sdb2
           ID-2: swap-1 size: 8.37GB used: 0.00GB (0%) fs: swap dev: /dev/sdb3
RAID:      No RAID devices: /proc/mdstat, md_mod kernel module present
Sensors:   System Temperatures: cpu: 41.0C mobo: N/A
           Fan Speeds (in rpm): cpu: N/A
Info:      Processes: 226 Uptime: 13:07 Memory: 2201.8/7777.8MB
           Init: systemd runlevel: 5 Gcc sys: 5.4.0
           Client: Shell (bash 4.3.481) inxi: 2.2.35 
Output from lspci:

Code: Select all

lspci
00:00.0 Host bridge: Intel Corporation Device 5904 (rev 02)
00:02.0 VGA compatible controller: Intel Corporation Device 5916 (rev 02)
00:08.0 System peripheral: Intel Corporation Sky Lake Gaussian Mixture Model
00:14.0 USB controller: Intel Corporation Sunrise Point-LP USB 3.0 xHCI Controller (rev 21)
00:14.2 Signal processing controller: Intel Corporation Sunrise Point-LP Thermal subsystem (rev 21)
00:16.0 Communication controller: Intel Corporation Sunrise Point-LP CSME HECI (rev 21)
00:17.0 SATA controller: Intel Corporation Sunrise Point-LP SATA Controller [AHCI mode] (rev 21)
00:1c.0 PCI bridge: Intel Corporation Device 9d10 (rev f1)
00:1c.2 PCI bridge: Intel Corporation Device 9d12 (rev f1)
00:1c.5 PCI bridge: Intel Corporation Sunrise Point-LP PCI Express Root Port (rev f1)
00:1f.0 ISA bridge: Intel Corporation Device 9d4e (rev 21)
00:1f.2 Memory controller: Intel Corporation Sunrise Point-LP PMC (rev 21)
00:1f.3 Audio device: Intel Corporation Device 9d71 (rev 21)
00:1f.4 SMBus: Intel Corporation Sunrise Point-LP SMBus (rev 21)
02:00.0 Network controller: Intel Corporation Device 24fd (rev 78)
03:00.0 Unassigned class [ff00]: Realtek Semiconductor Co., Ltd. Device 5287 (rev 01)
03:00.1 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller (rev 12)
 
Please let me know if any other output is required and thanks in advance for any help.

User avatar
Termy
Level 5
Level 5
Posts: 618
Joined: Mon Sep 04, 2017 8:49 pm
Location: UK
Contact:

Re: Cannot mount Sandisk SDXC 64GB SD Card Linux mint 18

Post by Termy » Mon Jan 22, 2018 3:06 pm

Hi. I just so happened to have that very same card in my Android phone. I just took it out and plugged it into my lil USB gizmo, and had no issues detecting it, like in your case. I got a load of messy error output when I tried to mount it (terminal) with udisksctl, so I ran sudo apt-get install exfat-fuse, figuring my lite setup probably doesn't yet have exfat (the filesystem the card uses) support. As soon as the packages you mentioned were installed, I could mount it without issues. I'm not in Mint, but I am in an Ubuntu-based setup, so it should really be working. I can't test it in Mint as I don't have such an installation except in a virtual machine. :?

The only thing I can think of is that your reader doesn't actually support SDXC. I made sure my gizmo supported it; this is its title so you can search it on Amazon (UK):
Anker® USB 3.0 Card Reader 8-in-1 for SDXC, SDHC, SD, MMC, RS-MMC, Micro SDXC, Micro SD, Micro SDHC Card, Support UHS-I Cards, 18 Months Warranty
Currently still available on Amazon, but there's an upgraded model available.

By the way, you did a bang up job including that inxi output. :) And welcome to the Mint forums.

User avatar
Rebel Dog
Level 2
Level 2
Posts: 70
Joined: Sat Apr 02, 2016 10:05 am

Re: Cannot mount Sandisk SDXC 64GB SD Card Linux mint 18

Post by Rebel Dog » Tue Jan 23, 2018 11:55 am

I ran into an issue with an SD card just now. Linux Mint could not see it, Ubuntu 16.04 could not see it, MAC OSX could not see it, Windoze 7 could not see it, and last Windows 10 computer cannot see the card.

I booted Puppy Slacko,,,,,,stuck the drive in got the data, sees everything on the drive. And it shares hardware with half the OS listed above.
I know Puppy is a Pitt Bull with strong jaw, Any body else run into this???

Any how, Puppy takes up very little room, and Grub lets you boot into any Linux Distro easy, and Grub is customizable,,,,The new Puppy has, Libre Office, a ton of cool audio software, and I just installed WINE on it.
I keep a copy of Puppy ready to boot, Just in case the world comes to an end, if I absolutely have to get it done ,,,Here Spot,,,,,,
Exiled, I have no country

Post Reply

Return to “Mounting Partitions”